LinuxMCE Forums

General => Installation issues => Topic started by: david_a_dawson on July 14, 2007, 04:00:19 pm

Title: ATI Remote Wonder
Post by: david_a_dawson on July 14, 2007, 04:00:19 pm

I've been scanning all over the forums and docs about how to get the ATI remote wonder remote to work with lmce.  As far as I can see, this should work through lirc, however I've come to a bit of a dead end with that.
What happens at the moment is I boot up my hybrid, with the remote dongle plugged in, and it starts to emulate a mouse.  This is from the ati_remote modules that gets auto loaded at boot time.
However, there is no lirc running, and lmce doesn't seem to recognise the remote.
I've added a child device, with the licr config pulled from, still not joy.  I've tried disabling the ati_remote module, nada. 
I've tried installing lirc from the repositories (strangely it seemed not be be already), still nothing.
I'm at the end of my ideas, anyone had any joy with this remote?

Title: Re: ATI Remote Wonder
Post by: bulek on July 15, 2007, 01:04:49 am

some time ago I had this remote working under Pluto, but :
if I remember right, I had to do few things :
- disable kernel module that makes RW acting like mouse
- add Ati Remote Wonder as lirc remote
- stock configuration file didn't work for me, so I recorded new one and I guess contributed back into Pluto database
- I also remember that lirc was not working and I ran out of ideas, but then after few reboots it started to work - no clue why...

So maybe you should try to get it working with lirc manually, record buttons and see where the problem is...


Title: Re: ATI Remote Wonder
Post by: david_a_dawson on July 15, 2007, 02:40:46 pm
right-o, I'll give that a try and see what happens.
Title: Re: ATI Remote Wonder
Post by: david_a_dawson on July 15, 2007, 09:32:02 pm
Right, I've managed to break lmce, reinstall it twice, bludgeon one set of hardware into oblivion and then rebuild the machine  ;).
Took me a while, I got the remote recognised in kubuntu, using the config from pluto.   I can do irw and see all the commands from the remote coming into the system.
I've added the remote as a device on my hybrid media director (using the admin website), and I can't seem to get it to do anything.
Is there a way I can check the connection?  I notice in adept_manager that there is a pluto lirc wrapper, is this required? 
I'll try it again I think, see what happens.


NB, this is what I just did.

* Install lirc via adept
* follow the instructions here
* Swear a bit
* It works!
Title: Re: ATI Remote Wonder
Post by: david_a_dawson on July 20, 2007, 10:38:01 am
Well, how fascinating.  I've discovered a lot about how lmce works and finally got the remtoe to work nicely.
It comes down to a misunderstanding about how lmce works, something that's obvious when you realise it, but not so obvious when you start looking.
Lmce is all about devices, everything in it is a device of some sort.
With my remote, there were in fact exactly two devices, the lirc subsystem, and the remote itself.

So, without further ado, here is how I got my remote working.

* I got the remote to function using the ubuntu lircd, as above.
* Then disable ubuntu lircd, lmce will shut it down anyway, but it seems to cause interference sometimes.
* Start up lmce, if it's not going already.
* In the admin page, show your devices tree in the left hand pane (it's at the bottom).

We will now add the first device, the lirc subsystem :-
* Click on Core/ Hybrid (in my case)
* Create child device
* Pick device template,
In the popup,
* Device Category = Lirc Drivers
* Click Apply Filter
* Select 'default' from the device category list
* Click 'Pick Device Template'

We now have lirc available.

Now we add the remote itself.
* Go to the top menu, Wizard > Devices > Media Directors
* Find the media director you want to control, click 'Add Remote'
* In the popup, Device Category = 'LIRC Remote Controls',  Template = 'ATI Remote Wonder' (In my case)
* Click 'Pick Device Template'

Now do a Wizard > Restart > Quick Reload Router.

Everything should now be active and working.
Try a reboot to settle things if it isn't.  I didn't need to, but some other people on the pluto forum reported that they did.

The multiple devices issue confused me with this, it's not immediately obvious from the documentation that there are two devices to set up, maybe the script adds them if thery are present on install, unlike my remote, which was added after.

I like the 'everything is a device', it sits well with the unix philosophy, which is good.

Most of the buttons on the remote work well, although a few are unmapped.  I think I'm going to fiddle the script and post back here in a few weeks with my results.

Title: Re: ATI Remote Wonder
Post by: aurum on October 21, 2007, 12:03:34 pm
ok, i follow ur instructions. i have working remote with lirc, the irw write the commands what i mapped to buttons. so working.

but... the linuxmce cant use my remote. a made all devices, the core is installed, sw automaicaly, restart but nothing happened...

the lircd.conf(for atiusb) what in the lirc package also not good for my remote, i made with irecord new one, with same commands what is in the officinal lircd.conf. it is possible, i must give this .conf to pluto? (how?) if i undestand well, the lirc is not needed for linuxmce, it is use own (something) what is also wrong as in package of lirc.