LinuxMCE Forums

General => Installation issues => Topic started by: Wiseguy on May 21, 2007, 08:52:01 pm

Title: Throwing in the towel...
Post by: Wiseguy on May 21, 2007, 08:52:01 pm
Well after several attempts and many hours, I think it's time to throw in the towel. Unfortunately my unfamiliarity with Linux has proven too large a hurdle to get past. I've learned quite a bit, but every time I get an issue resolved I run into a new one. Here's a quick list of the issues I did overcome for any other Linux newbies out there who want to take a crack at this thing:

1.) Successfully downloaded and installed Kubuntu 7.04.  Comments:  This went pretty smooth although for whatever reason it couldn't resize the windows partition on the drive I selected for install. Not sure if Kubuntu uses "Gparted" for this task or what the problem may have been, but for whatever reason it failed, so I had to wipe the drive entirely to get the OS installed.

2.) Installing Linux MCE:  Right away it recommended I install the latest Nvidia's drivers for my GPU. On my first attempt I let it install them for me, but after logout and restarting the X Server as per the on-screen instructions -  once I logged back in, my screen res resized itself to to 640 x 480 and the option to step it back up to 1280 x 1024 was no longer available in display properties. This made me think the drivers didn't install properly or were incompatible (like on a Windows box). I decided to just ignore the problem and move on with the install. Eventually it finished successfully and instructed me to reboot. 

3.) Initial boot after install attempt 1:  As it configured all the new packages and started their services I monitored their progress. 3 or 4 failed to start successfully - the main one I recall was the DHCP server.  After going through the AV wizard successfully, it eventually dropped to what I guess is the linux console.  I was prompted to login to the "DCERouter" - hell if I know what that is or what it's about, but I went ahead and supplied my user credentials for Kubuntu and the login appeared to be successful.  At that point I was given a DCERouter prompt and the boot process stopped...  Wasn't really sure what happened or how to proceed at this point. After some research on these forums without any clues as to what had gone wrong, I decided to start from scratch. Later on I discovered this was probably unnecessary - but how the hell was I supposed to know?

4.) Driver update challenge:  With Kubuntu freshly reinstalled I decided to tackle my (perceived) graphics driver problem, which I thought may somehow have been related to the "failed" install above.  What a friggen nightmare. A simple task I've done thousands of times on a Windows box, suddenly a 3 hour pain in my ass. First of all I'd just like to say how disconcerting it is to in one moment be extremely confident in my knowledge of "all things computer" and in the next be reduced to complete and total computer ineptitude. I know you Linux guys would get a good laugh at my expense if I took the time to explain this experience in detail, so I'll just skip to the highlights. I eventually figured out to get the driver installed I needed to execute the following command with "root" privilages: "sh /path-to-file/".  Unfortunately once I accomplished this successfully the install failed because something called the "X Server" must first be stopped. After a bunch of hunting around the UI and after some Google goodness about Linux "runlevels", "ctrl-alt-backspace", etc. - all unsuccessful, I decided to just get back to trying to install Linux MCE. At that point I was fairly certain the drivers had not been the issue and since the Linux MCE installer was capable of disabling the X Server I gave up on trying to do it myself.

5.) Install attempt number 2:  Everything proceeded exactly as had my first attempt and I eventually found myself staring at the DCERouter prompt yet again. Hmmm... what to do… My hope at that point was that everything had installed successfully, but that for whatever reason the Kubuntu UI had just failed to launch.  OK… how the hell to start it manually? Again I’ll spare the gruesome details, but I eventually discovered that all I needed to do was type “startx” at the DCERouter login to get the UI running and hopefully – finally get to see Linux MCE in action.

6.) Yeeha! It’s finally working… right?:  Nope. On login Linux MCE automatically launched and a warning appeared directing me to the machines IP to run the web-based configuration utility.  Unfortunately the warning wouldn’t go away and I had no idea what the Linux equivalent to “ALT-F4” was so back to Google I went, eventually I discovered that the Linux equivalent to “ALT-F4” is “ALT-F4” : ) Unfortunately I had already tried that unsuccessfully.  So I decided to just access the page from another machine on my network, which did work as it should have.  Although what I found once I got there was pretty disappointing.
One of my main motivations for giving up a Saturday to undertake this project was I had seen the LinuxMCE video up on YouTube (the one voiced by Satan from Southpark) and was intrigued.  The out-of-the-box auto configuration of my AV hardware it promised seemed too good to be true.  I wanted to learn how this thing was going to automatically configure IR codes without the “learning” process we’re all familiar with in relation to universal remotes and other IR products.  Well… what I discovered was a configuration utility, several pages deep, looking for me to do it all manually – not cool. I’ll grant you that maybe I missed the magic “auto-configure-all” button somewhere, but I don’t think so. Instead of going through that configuration nightmare before actually seeing the thing in action and because at this point I was pretty tired and frustrated, I decided to just skip all the AV configuration, home automation, etc and instructed the machine to reboot through the web config utility.

7.) This time it’s got to work! - Nope, still no dice.  Linux MCE launched successfully and proceeded to display some sort of screensaver, which cycled through stock photographs, but would not respond to any keyboard, mouse, or Windows MCE remote input – lame.

So that’s where I left off.  While this thing looks like it has tremendous potential I think I’m going to have to wait for someone else to work out all the kinks. I’m sure that my lack of Linux expertise played a big part in my inability to get Linux MCE up and running, but I’m also confident that most other folks with an all Windows background will also find this thing pretty difficult to get up and running. Could you guys do another video that goes through install and configuration start to finish?  You could even get Satan to do it again... he did a bang up job on the first video, made me want to run right out and try it!
I hope this information is useful to somebody : )
Title: Re: Throwing in the towel...
Post by: isilmeraumo on May 22, 2007, 02:19:51 pm
Yes, it was useful.  I wasn't getting dumped to the console but was being left staring at the init statuses, think it stopped on rc.local.  I wouldn't be so hard on yourself, you did pretty well for messing around with a beta Linux product and being a new person to Linux.  To fix your video issue, as I had a similar problem but am very familiar with Linux, fixed it with a wonderfully lucky shot in the dark.  Edit your /etc/X11/xorg.conf and comment out the line that reads 'option "UseEDID" "False"' and restart the X server via the usual <Ctrl>+<Alt>+<Backspace> or reboot the machine.  That solved it for me.  X is a total mess still, much better then it was in the past but still far from being user friendly, so I feel for you with the video issue.  As for LMCE, it has great potential but is definitely not a polished product and has lots of areas I am sure the developers are hard at work on.  Also, I believe they are working on videos that will go along with the setup/installation of a system.  One suggestion I might have for you is to just install the [U,Ku,Xu]buntu base and get to know Linux.  Most things are pretty polished in the base distros, although the X configuration when installing nVidia drivers is still lacking but from what I've heard the community is working hard to clean X up and make it work much better.  I think the only commandline workings I have to do these days are changes to my xorg.conf file.  Good luck to you.  Hope you give Linux a try again.
Title: Re: Throwing in the towel...
Post by: Wiseguy on May 22, 2007, 05:53:27 pm
Thanks for the advice, Isilmeraumo. I'll give that a try when I get some time this week. Did you get yours up and running eventually? I'm still curious whether I missed some critical step during or after install. At this point everything is installed, but the LMCE UI (I think it's called "Orbit" or something like that) will not start, it just loops trying to start the service. The main reason I've basically given up for now is that I'm not really sure where to begin troubleshooting the problem.

Has anyone worked with the live tech support mentioned on the LinuxMCE homepage? I usually like to resolve problems on my own especially when the software I'm working with is free.  Nobody likes to be that guy who didn't RTFM (read the f'n manual), but I think this thing just isn't going to happen without some direction from somebody who knows their way around this product and Linux.

Cheers : )