LinuxMCE Forums

Archive => Archive => DCE Router Users => Topic started by: archived on January 03, 2005, 01:46:08 pm

Title: Trouble logging in
Post by: archived on January 03, 2005, 01:46:08 pm
I (think I) successfully installed from the Debian quickstart package. However, when I go to log in to the web-based admin page, it says that my password is not correct.  It also says that the initial user name and password should be the same as this site, which I checked again: They are.  
There was one additional issue with naming of the machine: dce_router is not a possible name, as underscores returned an error, and a message that they are not legal in naming of machines.  So, I named it dce-router.
Any help with the admin login problem would be gratefully appreciated.
Title: Trouble logging in
Post by: archived on January 03, 2005, 07:10:06 pm
That is odd.  Are you familiar with a Linux console, and how to login?  If so, please login as root and type this:
#That will start the sql database client and give you a mysql> prompt, at which type:
use pluto_main
select * FROM Users;
#You should then see the contents of your Users table, and there should be 1 record with your user info.  If you don't see any records, please do a "select * FROM Device;" and let me know if you have records in the Device table.  The 'password' column contains your password as an md5 hash.  If you want to see a password as md5, type this:
select md5('foo');
# where 'foo' is what you think your password is.  That will show you your password as an md5 hash.  Is it the same as the md5 column?  If not, then somehow the password is different.  Please e-mail me the md5 hash that is in your table to aaron.b at plutohome dot com, and I'll check to see if it's the same as on our server.  If you want to change the password, type this:
update Users set Password=md5('newpassword');
#to set the password to [newpassword].  Type 'quit' at the mysql> prompt to exit mysql and return to the Linux console.  Whenever you login with the pluto-admin site your password is validated against that Users table in your local database.  So the failure was either (a) that the user record wasn't pulled from the website, or (b) that the password in your local database is not what you think, or (c) that there's a problem with the pluto-admin page.  Please let me know so we can figure out what went wrong and be sure to correct it.  Thanks.
Title: Been there, tried that...
Post by: archived on January 04, 2005, 09:41:45 am
It appears that there are no records in the Users or Device tables, which would explain why I couldn't log in.  Why the installer did not create the records is a different question.  I will attempt to create the record for user, but for device there could be an issue...
Title: Trouble logging in
Post by: archived on January 04, 2005, 12:44:01 pm
The database is populated with it's initial data during the DCERouter's post install script.  This gets run automatically when you install the Debian packages.  Did you install with Debian, or by source, or a .tar file?

The post install script does this:
wget -O /usr/pluto/install/database_initial_data.sql "$code&device=$device"

where code is your activation code and device is the device id.  It then does:

 /usr/bin/mysql pluto_main </usr/pluto/install/database_initial_data.sql

All our internal testing is with Debian and using the Debian packages.  There are actually quite a few post install scripts that need to be run for everything to work.  The programmer who is responsible for all the scripts is a bit behind schedule and has not yet started created rpm packages and other mechanisms for doing the same thing on a non-debian system.

If your system is non-debian, just try running the wget and the mysql command manually.
Title: Actually...
Post by: archived on January 05, 2005, 01:04:45 am
Thanks for your help.
I *did* do the install from the Debian Quickstart CD downloaded from PH, which is why I was a little surprised that it hadn't successfully run the mySQL scripts. It wasn't a network issue, as most of the packages appear to have installed correctly, and they were downloaded.
I will either run the scripts that you suggest from the command line, or perhaps try running the Quickstart again over the top of my current installation.  
Any other suggestions?
Title: Aha!
Post by: archived on January 05, 2005, 12:49:11 pm
Here is the error I received when I ran
Code: [Select]
usr/bin/mysql pluto_main </usr/pluto/install/database_initial_data.sql
ERROR 1054 at line 12: Unknown column 'FK_Device_Audio' in 'field list'

I had a look at initialdata.php on my browser, and it looks like a SQL script file should look, (very well commented, by the way!), and contains the correct data for myself and my devices. The issue clearly seems to be that the field FK_Device_Audio doesn't exist, and therefore an error is thrown.

I am no a real wiz at mySQL nor Linux, and so I will refrain for the moment from bumping around looking for the original SQL script used to create the table, but it seems that may be where the problem is.
Title: Trouble logging in
Post by: archived on January 05, 2005, 02:06:19 pm
that explains everything.  Thanks.  It's an error in the database synchronization between our production server and our in-house development one.  We will post a new release (hopefully) tomorrow or the next day that will fix this.  You will probably just want to redo the kick-start cd then.  You will see on our website in the 'news' section the moment the updated version is posted.
Title: Pluto Admin login
Post by: archived on March 06, 2005, 11:39:34 pm
I have the same problem, I can't log onto the Pluto Admin website after installing the Core (Debian), checked the Users & Device tables, neither have any entries....
Title: Trouble logging in
Post by: archived on March 07, 2005, 03:19:12 pm
Can you tell me what is your installation number so I can do some checking? You can see what the installation number is both in the "My Pluto" section on the website and in /etc/pluto.conf on your system as "FK_Installation=<number>"
Title: Trouble logging in
Post by: archived on March 07, 2005, 03:47:50 pm
The installation number is 6422
Title: Trouble logging in
Post by: archived on March 07, 2005, 04:05:29 pm
There was a field FK_Device_Audio in the table Device, database pluto_main.  But it was removed over a month ago.  I checked and our main server's schema is properly synced (ie the field isn't there).  And in the current kick-start cd also the field isn't there.  So I don't know where it's coming from.  Is this an old kick-start cd?  Do you know what version it is?  The initial boot screen says the version in the lower-left corner.  It's harmless to boot the cd to that point--it doesn't do anything there but show the welcome screen.
Title: Trouble logging in
Post by: archived on March 07, 2005, 04:06:56 pm
Never mind.  I just noticed that the thread with the reference to FK_Device_Audio was made in December -- this is a new post to an old thread.  So I think that the cause of your problem is somehow different and not related to FK_Device_Audio.
Title: Trouble logging in
Post by: archived on March 07, 2005, 04:12:44 pm
It is a Kick Start image I downloaded from install 1348 yesterday as I needed to reinstall the core. I created the 6422, after I had the logon issue with install 1348 but did not download the kickstart image again, I didn't realise that the kickstart CD's where install specific...
Title: Trouble logging in
Post by: archived on March 07, 2005, 04:41:01 pm
The kick start CD isn't installation specific.

The initial data looks fine here. Did you get any errors while doing the install? Also, tell me if your /usr/pluto/install/database_initial_data.sql file contains data (lines starting with INSERT), especially a line starting with "INSERT INTO `Users`
Title: Trouble logging in
Post by: archived on March 07, 2005, 06:33:23 pm
The /usr/pluto/install/database_initial_data.sql file does not exist!
Title: Trouble logging in
Post by: archived on March 07, 2005, 07:06:04 pm
That file is created by one of our packages (pluto-dcerouter) at install time. If you do a dpkg -l pluto-* which packages do you see? If you see a pluto-dcerouter package, notice the two letters at the left of that row. If they don't say "ii", it means something went wrong while installing it.

You can try to do a dpkg --configure -a and see what happens. If it gives any errors, plese tell me what they are.

Did you see any package installation errors at install time?

Did you get to the end of the installation process where the system reboots itself after pressing Enter?
Title: Trouble logging in
Post by: archived on March 07, 2005, 07:43:21 pm
The pluto-dcerouter package is not listed, the only package listed when running a dpkg -l pluto-d* is pluto-cdecommo, all the packages listed have the ii on the left.
The install did complete with few prompts about unavailable packages but did complete without any other errors
Title: Trouble logging in
Post by: archived on March 07, 2005, 08:24:47 pm
Which packages did it say were unavailable?

Anyway, you should have a screenful of pluto packages, not just dcecommon.

One possibility is that apt-proxy, the software we use to cache all the debian packages that come from the Net, failed at some point while retrieving the listings. Did you see any "warning: could not get listing" messages? Still, the packages should have been drawn from our on-disk cache that the CD creates just before it reboots, unless you don't use the current version of the CD, in which case it will pull everything from the Net.

-- Edit --
In this case, choices are like this: you reattempt the installation; when you get a "package not available" or "package not found on any servers" error you go to a console and type "apt-get update" until none of the files fail. I'm still searching for a viable alternative/fix for this apt-proxy thing.
Title: Trouble logging in
Post by: archived on March 07, 2005, 11:10:33 pm
I reinstalled the core again.

The Kick Start version is
The following packages where unavailable:

Later he processing of the Pluto DCE Router package fails with errror:
The following packages have unmet dependencies:
  pluto-dcerouter: depends on pluto-kernel-upgrade but is not installable

The ploto-mythtv-plugin fails with same error because libmith-0.17 is missing

Is there a logfile I can upload to assist with the trobleshooting?


Title: Trouble logging in
Post by: archived on March 08, 2005, 12:58:10 am
There are two log files in /var/log/pluto (Initial_Install.newlog and Initial_Install_trace.newlog), but what you said was good enough to know where to look. On of the repositories had two overlapping files (Packages and Packages.gz) of which one (Packages) was misplaced there (I don't even know how it got there since we only use Packages.gz). I removed that file and now things should work.

libmyth and UpdateEntArea shouldn't have failed

Please try again and if it fails again, you can send me the log files at this e-mail address: radu.c(at) (replace (at) with @) and I'll fix it, because this isn't normal. Thanks.