LinuxMCE Forums

General => Users => Topic started by: Govo on December 21, 2015, 02:35:12 pm

Title: Device died when selecting radio station
Post by: Govo on December 21, 2015, 02:35:12 pm
Hi Folks

when selecting a radio station system does a reload every time a station is selected

Looking at the DCERouter.log it shows the below error.


Return code: 134
3   12/21/15 13:30:06   DCERouter (server)   Device died... count=3/200 dev=DCERouter
Mon Dec 21 13:30:06 GMT 2015 died


any ideas

LMCE 14.4

Cheers
Govo
Title: Re: Device died when selecting radio station
Post by: maverick0815 on December 21, 2015, 06:30:43 pm
and I thought it was my hardware :-)

I got the same issue...have you tried using your windows orbiter to switch tv-channels? Because I also have that issue, but I can't say yet where this comes from.
Title: Re: Device died when selecting radio station
Post by: Govo on December 21, 2015, 10:29:24 pm
Hi maverick0815

Thanks for the reply, sorry don't use the TV function so can't test that part of the system, I going to assume its to do with the xine player, I have trouble with playing mp4 videos, the player is not switching to mplayer , so I am going to assume that the xine is not loading the radio stream and dies then reloads.

Lets see what the lads have to say!

Cheers
Govo
Title: Re: Device died when selecting radio station
Post by: _if_ on December 21, 2015, 11:56:26 pm
same problem here!
Title: Re: Device died when selecting radio station
Post by: darkwizard864 on December 22, 2015, 03:36:48 am
http://svn.linuxmce.org/trac/ticket/2562
Title: Re: Device died when selecting radio station
Post by: Govo on December 22, 2015, 07:09:49 pm
Hi darkwizard864


I readed the ticket, please can  you advise what the format is fk_fileformat?  right now it only allows numericals.

So I set it 0 ..crashes the system, same for 1 and I added 43 LinuxMCE streamed audio,  still the same.

Added 0 to Path in the database  and the system  does nothing, put back to null and system crashes

And you cannot delete a radio station using the delete buttons

Cheers
Govo

Title: Re: Device died when selecting radio station
Post by: phenigma on December 22, 2015, 07:27:32 pm
please create a ticket for not being able to delete stations.  looks like there is a ticket for the other issue already.  thanks for testing guys!

J.
Title: Re: Device died when selecting radio station
Post by: Govo on December 22, 2015, 07:36:59 pm
Hi phenigma

Thanks for the reply, the ticket is open for  fk_fileformat = null, causing the reload of system.

I am trying to troubleshoot this myself and with the help of  the community.

I am drilling into the core end, getting a full understanding of how the system works.

I will create a ticket for deletions, but I am not worried about that as it seems to be done through php, which I might be able to fix myself.

anyways, jumping through the database, if you change the path to something other than NUll  the system does  not reload or do anything. i.e play the file.

So I am check 10.4 to see if the path needs to be something else, unless you can advise ?

Cheers
Govo

Title: Re: Device died when selecting radio station
Post by: phenigma on December 22, 2015, 08:43:44 pm
I will create a ticket for deletions, but I am not worried about that as it seems to be done through php, which I might be able to fix myself.

If you get that figured I'd really appreciate you attaching the fix to a ticket!  :)

anyways, jumping through the database, if you change the path to something other than NUll  the system does  not reload or do anything. i.e play the file.

So I am check 10.4 to see if the path needs to be something else, unless you can advise ?

My 'Path' entries are '', but not NULL for all media with MediaType=43;

J.
Title: Re: Device died when selecting radio station
Post by: phenigma on December 23, 2015, 02:42:01 am
PK_FileFormat=NULL for MediaType=43 is normal.

J.
Title: Re: Device died when selecting radio station
Post by: Govo on December 23, 2015, 02:23:56 pm
Hi J

Please can you advise how to open a ticket, I completely confused, I have fixed the single deleting and working on the select all to delete. should have it ready for this evening.

or will I just post it to paste bin

Please advise

Cheers
Govo
Title: Re: Device died when selecting radio station
Post by: posde on December 23, 2015, 02:57:04 pm
http://forum.linuxmce.org/index.php?topic=13696.0
Title: Re: Device died when selecting radio station
Post by: Govo on December 23, 2015, 04:16:10 pm
Hi Posde

Just sent you a pm.

Cheers
Govo
Title: Re: Device died when selecting radio station
Post by: posde on December 23, 2015, 05:45:36 pm
and you received a reply :D
Title: Re: Device died when selecting radio station
Post by: Govo on December 23, 2015, 07:52:36 pm
Thanks Posde

Ticket raised,http://svn.linuxmce.org/trac/ticket/2567#ticket

I have fixed the delete button(s), also have update the page with bootstrap and given the page a makeover. ! hope this was ok, didn't really like the layout

here as screenshot
https://www.dropbox.com/home/lmce?preview=Screenshot+from+2015-12-23+18%3A44%3A48.png (https://www.dropbox.com/home/lmce?preview=Screenshot+from+2015-12-23+18%3A44%3A48.png)

I have also added in new alert boxes

New Alert when the box is not ticked
https://www.dropbox.com/s/1hhwc3s1o26k7wx/Screenshot%20from%202015-12-23%2018%3A48%3A45.png?dl=0 (https://www.dropbox.com/s/1hhwc3s1o26k7wx/Screenshot%20from%202015-12-23%2018%3A48%3A45.png?dl=0)


When the box is  ticked and delete button is pressed

https://www.dropbox.com/s/h3emnzy08eia6c2/Screenshot%20from%202015-12-23%2018%3A50%3A15.png?dl=0 (https://www.dropbox.com/s/h3emnzy08eia6c2/Screenshot%20from%202015-12-23%2018%3A50%3A15.png?dl=0)


How do I get the changes to you J?

Cheers
Govo

Title: Re: Device died when selecting radio station
Post by: phenigma on December 23, 2015, 09:35:01 pm
Govo,

Thanks!  You can attach your files to the ticket you created. 

I'm fine with changes to the look as long as we maintain a common look with the reset of the webadmin.  If we're going to change the look/feel of webadmin pages then it needs to be applied across the entire webadmin as a 'theme' so to speak, imho.

Attach your files to the ticket and someone, perhaps me, can test it out and provide feedback.

Thanks so much for digging in!   :D

J.
Title: Re: Device died when selecting radio station
Post by: Govo on December 24, 2015, 12:51:09 am
Hi J

Files are up for testing, regard the theme, I agree, but I just took the time to update this page, will look at adding bootstrap to all pages in  the web admin.

Cheers
Govo
Title: Re: Device died when selecting radio station
Post by: Govo on December 24, 2015, 05:58:52 pm
I've uploaded some logs for this issue as per topic
http://forum.linuxmce.org/index.php?topic=14260.0

can view them here
https://www.dropbox.com/sh/r3862zdltrid0df/AADrJ2Gp5UKexOU8K1aptFs4a?dl=0 (https://www.dropbox.com/sh/r3862zdltrid0df/AADrJ2Gp5UKexOU8K1aptFs4a?dl=0)

Regards
Govo

Title: Re: Device died when selecting radio station
Post by: darkwizard864 on December 24, 2015, 08:45:35 pm
try removing null in path
like this

Title: Re: Device died when selecting radio station
Post by: Govo on December 25, 2015, 11:43:01 am
Hi darkwizard864

Removing the Null  from the Path stops it from reloading but nothing plays or happens.


Regards
Govo

Happy Xmas ...
Title: Re: Device died when selecting radio station
Post by: darkwizard864 on December 25, 2015, 12:53:13 pm
what area are you in so I can test the streams from ur area on my box..
Title: Re: Device died when selecting radio station
Post by: Govo on December 27, 2015, 06:28:31 pm
Hi darkwizard864

I am actually in Ireland and the script dectects most of the streams listed in the below url

http://www.listenlive.eu/ireland.html

Regards
Govo


Title: Re: Device died when selecting radio station
Post by: darkwizard864 on December 27, 2015, 11:42:15 pm
post the last lines of /etc/pluto/xine.conf
the radiostation in ur area I added to my box they work here.
Title: Re: Device died when selecting radio station
Post by: maverick0815 on January 04, 2016, 10:04:33 pm
here the script is working and no more crashing when trying to play radio...good job :-)
The only thing that is not working is radio energy here, but I can live with that..or put it manually. They use some weird url.
Title: Re: Device died when selecting radio station
Post by: posde on January 04, 2016, 11:24:07 pm
Maybe you should post the URL, so the script can be amended.