LinuxMCE Forums

General => Users => Topic started by: MarcoZan on January 04, 2014, 02:00:27 pm

Title: [SOLVED] GSD problem
Post by: MarcoZan on January 04, 2014, 02:00:27 pm
Hi all
after a _long_ time I'm diving back into LinuxMCE.
I'm setting up a new hybrid based on 10.04, and I'm trying to recover all the interesting feature that were running in my old 7.10.

Precisely I'm trying to bring again to life a GSD driver that I wrote to interface LMCE to my lighting system. At that time (several years ago...) I created a Generic Serial Device, and filled in with ruby code all the internal commands.

Now I cannot find my way in doing the same. I created a device template, checked the Internal Ruby Command option, but when I add a GSD based on that template I cannot see the usual ruby command set (PrivateMethodListing, ProcessIDLE, ProcessIncomingData, ....) where I should paste my ruby code.

I've read wiki and I believe I followed the instructions, but since the things are not working surely I'm missing something (it's  _really_ long time I don't play with LMCE).
Is there anyone that can point me in the right direction?
Thanks and regards

Title: Re: GSD problem
Post by: Marie.O on January 04, 2014, 04:07:04 pm
Add the commandgroup ruby internal command
Title: Re: GSD problem
Post by: MarcoZan on January 04, 2014, 05:32:56 pm
Hi posde

I have already added the command group in the device template (actually it was already there by default), but still I cannot see the commands.
Have also reloaded the router several times, no luck ...
Title: [SOLVED] Re: GSD problem
Post by: MarcoZan on January 05, 2014, 10:27:55 am
Just for the records

when creating the GSD from the device template I did not pay proper attention to a warning that was saying that no group/codeset were associated to the manufacturer of the device.
Then I went back to the device template and changed the manufacturer from the real one (that was not in the list and I had added on the spot) to Pluto and saved.

Therefore in the instance of GSD all Ruby command set appeared.

Not sure whether this is the proper way to do it, anyway now everything is working and I'm happily up'n'running again,

Kind of obvious, I have a lot of rust to clean off my LMCE rememberings ...

Thanks anyway

BTW: you guys have done a _great_  job with 10.04, I think I'll have some fun in the next weeks discovering and testing all the new goodies  ;)
Title: Re: [SOLVED] GSD problem
Post by: tschak909 on January 07, 2014, 12:21:19 am
I'm glad this was resolved.

And, thanks, from all of us. It's been a definite challenge moving entirely to a community supported development model, as many of us have lives, and can't spend 8 hours a day coding on this thing (although some of us have tried!), this puts a smile on my face.

Title: Re: [SOLVED] GSD problem
Post by: MarcoZan on January 08, 2014, 08:04:50 am
Your're welcome Thom
I admire you guys very much, as you were able to do such a huge job on a volunteer basis and had the capability to do it in a so passionate way and coping with all the other things you have to deal with in your personal lives (something that I wasn't able to do)

So thanks again

P.S: Acually I was waiting for a twap ... as I solved the issue kind of "duct taping"  :)