LinuxMCE Forums

General => Installation issues => Topic started by: RayBe on August 12, 2012, 09:55:30 pm

Title: Z-Wave weirdness [SOLVED]
Post by: RayBe on August 12, 2012, 09:55:30 pm
Hi All,

Recently i upgraded from 8.10 to 10.04.
On 8.10 i had z-wave working perfectly.
Right before going to 10.04 i added a Aeon-Labs door/window sensor which worked also perfectly.

Now on 10.04 i re-added my "respond to event" event (sunset) to control a light (this worked great under 8.10)
But now every time when the event gets fired, another light also gets turned on.
Its always the same combo.

I can turn both these lights on and of individually with a orbiter.

the zwave gear used in above case:
- Aeon-Labs zwave controller:
- duwi inwall switch on/off
- duwi dimmer:üwi_ZW_ZDAN_300_Dimmer

I also tried deleting the "respond to event" event ad re-adding it but without any luck.

In the Event Plug-in log i can see that the 2 wave-modules get a "on" command, but thats not what i specified in the "respond to event" event.

Any pointers are welcome.

Title: Re: Z-Wave weirdness
Post by: gilgoe on August 14, 2012, 01:54:27 pm
May be the thing is with Aeon controller?
Title: Re: Z-Wave weirdness
Post by: JaseP on August 14, 2012, 03:32:20 pm
I suspect gilgoe may be onto something. I have a Wayne Dalton Z-wave enabled, IR "learning" remove. Currently,  I di not hace Z-wave functions working with it (batteries died, apparently taking the Z-wave settings with them). But when it was working, I had scenarios programmed to activate lights in certain rooms. If I left the activation number too close together on the keypad, multiple lights were activated/deactivated. If I kept them apart by one digit, they responded normally.  LinuxMCE was not installed at the time,... This was through a MCV Vera. My MCV Vera is an older one which uses an USB Aeon Labs Inclusion Controller.

So, I suspect this is purely a Z-wave thing... Z-wave scenarios somehow bleeding into one another.
Title: Re: Z-Wave weirdness
Post by: hari on August 14, 2012, 10:36:54 pm
@jasep: gilgoe is just a bot. And your suspicion is wrong. I don't know how you relate some IR remote with the issue from RayBe? RayBe stated that he sees two ON commands in the logs. How the heck should that relate to the Aeon controller? And what do you drivel regarding bleeding Z-Wave scenarios?

@RayBe: catch some of the devs on IRC, we need to track own why the event plugin is misbehaving
Title: Re: Z-Wave weirdness
Post by: JaseP on August 15, 2012, 01:01:54 am

It's not just an IR remote,... It's also a Z-wave controller, independent of the remote functions. The model I'm referring to is the Wayne Dalton WHDC-20 Teleport Universal Remote Control:

See a description from Wayne Dalton's web store:

In my system, it was a secondary controller.

What happened to me was similar to what he was describing. Except I wasn't using LinuxMCE. With the WHDC-20, you assign Z-wave scenes to the remote's number keypad. When you put the scenes only one keypad number apart, it would grab it's assigned neighbor as well, sending on/offs for both sets of devices. The scenes were created on a Vera,... not in LinuxMCE, but, as he describes, you could individually turn on/off each light on the Vera's web interface. I thought it was just a quirk of the WHDC-20, but now, I'm not so sure... The Vera uses (used) an USB Aeon Labs inclusion controller. That's the common thread. It could be a bug in the Aeon Labs stick's firmware. I know there were updates available.
Title: Re: Z-Wave weirdness
Post by: RayBe on August 15, 2012, 02:09:50 pm

Thanks, i will be looking for you in IRC.

Title: Re: Z-Wave weirdness [SOLVED]
Post by: RayBe on August 17, 2012, 11:21:18 pm
it turns out that when you add a light to a room with room-type 'outside area', that light gets automatically added to LMCE's auto generated sunset/sunrise events.
The light gets the on command at sunset and the off command at sunrise.

a big thanks to every one who helped, especially hari, tschak, possy and sambuca.