LinuxMCE Forums

General => Installation issues => Topic started by: tkteun on May 25, 2011, 01:14:53 am

Title: Grub error
Post by: tkteun on May 25, 2011, 01:14:53 am
I tried installing the latest Linux MCE on my PC.
But since I'm too lazy to free up a hard drive or remove other drives I manually partitioned like I always do.

The drive I want to use is an IDE drive which gets recognized as SDD.

I tried it without changing partitions
sdd1 128 MiB ext3 /boot
sdd2 15 GiB ext3 /
sdd3 15 GiB ext3 (originally /home but not mounted in this case)
sdd5 about 80 GiB for data not mounted.
sdd6 2 GiB swap

I tried it with / and /boot formatted and mounted, then I removed both the partitions and installed it on a new sdd1 ext3 partition.

The problem is:

error: file not found.
grub rescue> _

The disk appears twice in grub as hd0 and hd4.

Some pages (like ( give some instructions on booting, but I can't really find a .mod file to insmod.

I really haven't got any experience in this because I've never encountered an installed but unconfigured bootloader. Too bad, I really wanted to try lmce, but it'll have to wait till next time.
Title: Re: Grub error
Post by: klanmce on May 26, 2011, 04:02:46 pm
Are you doing a dual booth scenario, linuxmce and windows, if not why just use the whole drive(sdd) for linuxmce.

I would try boothing to a live cd, mount the drive, check grub's config file  (/boot/grub/main.lst) , should have an entry for the kernel and image, not at home, so cannot send you and example.
Title: Re: Grub error
Post by: tkteun on May 26, 2011, 04:21:23 pm
I only had little time, didn't want to loose the data on sdd5.
No dual boot though.

I installed xubuntu after that with the same options and it works brilliantly.