LinuxMCE Forums

General => Users => Topic started by: gtsupport on February 15, 2011, 01:58:27 pm

Title: z-wave sensors
Post by: gtsupport on February 15, 2011, 01:58:27 pm
I'm having a spot of bother with my z-wave security devices.

I'm using the Aeon labs stick with the include button, works fine for the lights, but can't get it to work with my ZIR010 motion sensor, or the smoke alarm. (everspring SF812)

I know Hari put in the work to get the smoke alarm working, but when I include it, nothing appears in my list of Z-wave devices.

The PIR sensor includes OK, but when I put the stick back in the core the lighting wizard automatically runs, I select Alarm panel and it tells me there is 1 sensor which needs to be added.  Great, except that when I tell it which room its in, it asks what to call it and there it all goes pear-shaped.  There is no "Next" button after I name it, I can only exit the wizard, or go to the end and press "Start using the system"  When it has finished regening the orbiter and reloading the router it has disappeared again, and does not appear in the z-wave device tree any more.

I tried to add it manually, but I'm not sure which template to use?
The wiki is very good for this device, but I'm struggling to get through it properly

When I added it manually in webadmin I chose the generic motion detector, as there was no specific template for this device, but the wiki mentions using parameters #17 #18 and #22 to set it, but I can't see these in the generic template.

What am I doing wrong?  Should I do an apt-get update? I have already done the sqlcvs updates for all DCE and IR components
Title: Re: z-wave sensors
Post by: purps on February 16, 2011, 11:38:15 am
Hi Matt,

This might be to do with sending association commands, it's the downside of using that dongle, read all of this carefully and see what you think

I used to have that dongle, and I believe you can a) do the association manually for every device that needs it or b) get an inclusion remote (so that you don't have to remove the dongle from the core) - I actually got an inclusion remote AND the seluxit to be safe.

Title: Re: z-wave sensors
Post by: gtsupport on February 16, 2011, 12:34:16 pm
Ha Ha, I have to laugh Matt, it seems I am doomed to follow your problems throughout my whole LMCE setup, perhaps there should be some sort of badge system you can earn like the cub-scouts, one for cameras, one for Zwave etc....

Anyway I read through the post, and when I get home tonight I'll try something new.  I have one of the Duwi DUW_064459 remote controls, I tried in the beginning to include all devices with this remote, then copy them to the stick, but it wouldn't have it.  I'll try adding this to the network and then using it to add the other devices, that way I don't have to remove the stick from the core each time.  I was actually wanting to be able to use this as well as the lmce system to control lights, but that was going to be another post down the line!  :P

I'll update on how things go after this evenings tests.  Just for info, whats the next "badge" I'll be competing for?  ;D

Title: Re: z-wave sensors
Post by: purps on February 16, 2011, 03:13:06 pm
Hehe, yes it does seem that way. Maybe we should make a special effort to update the wiki with this stuff. The information does exist in the forums, but it is buried and easily missed. Also I tend to write a lot of my experiences in my own setup page (maybe you should read that a few times ;)), but I don't think the user pages are included in wiki search results? Not sure why that is.

With regards to your next badge, I think you are pretty much up to where I am with your LMCE system, so well done! Took me over 3 years to get to this point, and my system's not even working at the moment! :)

Title: Re: z-wave sensors
Post by: gtsupport on February 17, 2011, 09:24:16 am
Here's something strange...

Got home yesterday, switched the tv on in the kitchen (MD) to watch live TV via LMCE and there was a security screen announcement asking for my pin??  Strange, anyway after I entered it the screen went away again.  Then after about a minute it came back up and a lady said that the alarm would sound in 30 seconds.....counting down to 0??  Strange I thought to myself, what is all this about, then it clicked that my 18 month old son was running around in the lounge, where I had left the pir to try and get it working. "Blimey" says me, this thing could actually be working.  After going to check the core, it seems that I left the keyboard plugged in, and within easy reach of my nipper.  Whenever he sees anything button-like he has to press (bash) it.  So it seems that whilst I was away he has somehow "Enhanced" my system with his meddling to the point where the pir now activates the alarm.  Still haven't figured out how to get it to just switch on the lights when the alarm is not armed, but have left the keyboard plugged in again today, so with any luck he'll have sorted it when I get home!

As this is an open-source project with a great community I feel that it would not be right to hire-out my son for system support, however if you feed and change him regularly you can borrow him if all else fails! ;D
Title: Re: z-wave sensors
Post by: purps on February 17, 2011, 11:28:08 am
Well it sounds like it's working then!

To change the way in which sensors works with regards to security settings, look in web admin -> Wizard -> Security -> Active Sensors.

To make other devices (e.g. lights) respond to your sensors/events, take a look in web admin -> Wizard -> Events Handler -> Respond to Events. For example this is where I make my lights come on at sunset.