LinuxMCE Forums

General => Installation issues => Topic started by: axel on January 31, 2011, 06:00:49 pm

Title: Installation MCE 1004
Post by: axel on January 31, 2011, 06:00:49 pm
Hi,

Please help me:
 - The Installation LMCE 1004 was perfect until the reboot
 - Motherboard: msi k9n2 nForse750a SLI Platinum (integrated video GeForce 8 Series)
 - I have also the problem with the black screen after the reboot

What could be the reason?
 
Thank you for any help.
Title: Re: Installation MCE 1004
Post by: DragonK on January 31, 2011, 06:51:08 pm
Your setup connected to a LCD TV or Monitor? How is it connected? HDMI? DVI?

Karel
Title: Re: Installation MCE 1004
Post by: pigdog on January 31, 2011, 08:18:13 pm
More importantly this ...

http://wiki.linuxmce.org/index.php/AVWizard#What_to_do_if_A.2FV_Wizard_does_not_start

Cheers.
Title: Re: Installation MCE 1004
Post by: axel on January 31, 2011, 11:41:09 pm
- Setup connected to a Monitor (DVI)

Title: Re: Installation MCE 1004
Post by: rperre on February 01, 2011, 01:02:09 am
axel, i understand your curiousity, but 1004 is not yet in any state to be installed. Getting close though.

there are patches committed every day, if you want to test/help test and /or help fix, please come to the irc channel(s)

Richard
Title: Re: Installation MCE 1004
Post by: LmceCape on February 01, 2011, 02:01:08 pm
Hi Axel

I have tried to install 1004 twice now according to the wiki, but mce-install.sh fails horribly.
Title: Re: Installation MCE 1004
Post by: axel on February 01, 2011, 05:41:09 pm
Hi LmceCape

Maybe the problem with hard due to the fact that 1004 is an alpha version
Title: Re: Installation MCE 1004
Post by: tschak909 on February 01, 2011, 06:26:42 pm
guys, we are still working on it. Do not be surprised if the installer currently fails.

-Thom
Title: Re: Installation MCE 1004
Post by: posde on February 01, 2011, 06:49:09 pm
BE surprised if things don't fail  :D
Title: Re: Installation MCE 1004
Post by: l3mce on February 02, 2011, 04:00:59 pm
- Setup connected to a Monitor (DVI)



Plug into VGA.

Or, conversely, when you get to black screen, on a keyboard or remote, press the following.
Enter (then brief pause)
down (x2)
right
down (x7)
right
down
enter

This will pipe out through DVI, 1080p, at 60hz.
Good luck.
Title: Re: Installation MCE 1004
Post by: LmceCape on March 16, 2011, 05:16:54 pm
Hi All

After testing 1004 for a couple of weeks now, its doing very well considering its still in testing faze.

After using Megart.vlad asterisk files and a few extra mods (just post them on http://forum.linuxmce.org/index.php?topic=11348.msg78267#msg78267 (http://forum.linuxmce.org/index.php?topic=11348.msg78267#msg78267)). Asterisk and security working fine.

Security alert countdown still the same as in 810, sometimes plays the alert and sometimes not. I did however notice the reason it sometimes does not play the alert is due to the alert starting just before the last 1sec file is played. and on 1004 you can't hear the MDs' after about the 13sec notification.

The biggest issue I have had so far was with my remotes (it seems ubuntu have removed HAL from their distro and therefore when you place the line "Option  "AutoAddDevices" "False"" in the xorg.conf file, the keyboard stops working along with the remote.

However when I ran xev it showed the buttons but with different event mappings, so I changed my template and its all working again using udev without the Option  "AutoAddDevices" "False" entry.

UPNP (810 and 1004)
I copied /etc/mediatomb/config.xml.dpkg-dist    to  /etc/mediatomb/config.xml
change the port from 49153 to 49155 on line 10
---    <port>49153</port>
+++   <port>49155</port>


changed line 23 in file /var/www/lmce-admin/operations/others/upnpServer.php
---    $out.='<iframe src="http://'.$_SERVER['HTTP_HOST'].':49153/" style="width:98%;height:600px;"></iframe>';
+++   $out.='<iframe src="http://'.$_SERVER['HTTP_HOST'].':49155/" style="width:98%;height:600px;"></iframe>';

Initial diskless boot hangs on mounting filesystem because is trying to mount "/usr/pluto/var" which does not exist, remove that line from the /usr/pluto/diskless/$MD/etc/fstab and reboot the MD.
(192.168.80.1:/usr/pluto/var/)


I hope this helps
LMCECape
Title: Re: Installation MCE 1004
Post by: tschak909 on March 16, 2011, 05:26:56 pm
Fantastic, lmceCape! Thanks for testing!! :)

Thanks for the pointer regarding the remotes. I will make appropriate changes to make this work transparently.

We're investigating what to do with regards to Asterisk, right now we have three different approaches being tried ranging from using a newer FreePBX with this Asterisk (a la Megart), to completely ripping out FreePBX and doing our own scripts (tkmedia, uplink, etc.)

Once we get this resolved, we can definitely move forward.

-Thom
Title: Re: Installation MCE 1004
Post by: ardirtbiker on March 17, 2011, 11:41:00 pm
lmceCape,
  Thanks for finding this!!!   I'll be able to get past this issue on my 10.04 server as well... and to see what other equipment I have needs addressing!

Dennis
Title: Re: Installation MCE 1004
Post by: LmceCape on March 24, 2011, 06:02:08 pm
Some more info.

I have noticed when making or receiving calls internal or external from an orbiter, it does not show the call, you can hear it ringing but you cannot answer it or if you make the call from an orbiter, once answered by the remote person/orbiter it still shows "calling Please Wait".
It never registers that the call is active.

It seems that the DataGrid fails to get/give the data, but if you do a broadcast/conference then it works normally.

Here is the DCErouter.log when you goto "Active Calls"

Plug-in / Study), type 1 id 35 Command:Populate Datagrid, retry none, parameters: <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 4(PK_Variable): 0 <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 5(Value To Assign):  <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 10(ID): 98995 <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 15(DataGrid ID): ACTIVECHANNELS_ON_CALL_53 <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 38(PK_DataGrid): 100 <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 39(Options):  <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 40(IsSuccessful): 1 <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 44(PK_DeviceTemplate): 0 <0x693b7b70>
08      03/24/11 18:35:53.994             Parameter 60(Width): 6 <0x693b7b70>
08      03/24/11 18:35:53.995             Parameter 61(Height): 8 <0x693b7b70>
08      03/24/11 18:35:53.998           Received Message from 53 (OnScreen Orbiter / Living Room/Family Room) to 6 (Datagrid


I can't find any errors in the Asterisk log (debug set to max) so it does not seem to be Asterisk this time.

I know 1004 is not yet supported, I am just testing and giving my input, other than Asterisk, it seems fine, there are a few other minor bugs but the bulk of it seems to function the same as 810.
I am rebuilding my system and I am trying to go straight to 10.04.

As far as CADDX Alarm goes, has anybody gotten any further with that?

I have a caddx alarm and I have been waiting for about 2 years for somebody to right a Template for it, so if you have anything I am more than happy to test/debug it for you.

Regards
LMCECape