LinuxMCE Forums

General => Users => Topic started by: jimbodude on October 07, 2010, 03:42:47 pm

Title: broken package dependency: mediatomb, linux-igd
Post by: jimbodude on October 07, 2010, 03:42:47 pm
Anyone else seeing this on apt-get install lmce-mediatomb?  it is held back on upgrade and dist-upgrade.
Code: [Select]
The following packages have unmet dependencies:
  lmce-mediatomb: PreDepends: lmce-linux-igd but it is not installable
E: Broken packages
Title: Re: broken package dependency: mediatomb, linux-igd
Post by: posde on October 07, 2010, 10:52:04 pm
Should be in the repo now. We had some problems with building it, but mediatomb already had the dependency.

apt-get update and upgrade should fix this problem for you
Title: Re: broken package dependency: mediatomb, linux-igd
Post by: jimbodude on October 07, 2010, 11:04:04 pm
There is is, thanks - installed no issues.

Need dist-upgrade, by the way, since extra dependencies are installed.
Title: *SOLVED* Re: broken package dependency: mediatomb, linux-igd
Post by: RailFarmer on October 10, 2010, 03:31:27 am
It [...-linux-igd] wasn't there just now (practically all day today that is).  I've gotten around medibuntu's server move so that isn't the problem.  If for some extremely unlikely reason this matters:  The latest upgrades to the LIRC stuff makes my lirc_mceusb not work any more.  As I said I doubt that is it, but who knows?

[SOLVED: Although I had done "apt-get update" a couple of times within the past 24 hours, the /var/lib/apt/lists/deb.* file seemed to be a few days older than the one in deb.linuxmce.com so I forcibly deleted the file and reran apt-get update then dist-upgrade and it's fine now.  Must have been something wrong with apt (and/or the timestamping on the packages.gz file on deb.linuxmce?)]