LinuxMCE Forums

General => Users => Topic started by: wombiroller on July 14, 2010, 01:58:07 pm

Title: FIX: apt-get update / upgrade not upgrading
Post by: wombiroller on July 14, 2010, 01:58:07 pm
FYI - I wasn't able to get any updates of late and didn't know why (using a June Snapshot 0810). Possy pointed out a fix:

/etc/apt/preferences - change Pin-Priority to 500

That will be all ;)
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: huh on July 14, 2010, 03:03:37 pm
Cool- thanks.   Two questions

1) Should I change both pins in that file to 500?
2) Should I only do this on the core- or on all of the mds too?


Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: RayBe on July 14, 2010, 03:30:39 pm
wombiroller,

since i am a beginner to linux,
could u give a more detailed guide how to do this exactly?
and what exactly will there be chanced?

thanks a lot
Raymond
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: posde on July 14, 2010, 04:23:31 pm
Cool- thanks.   Two questions

1) Should I change both pins in that file to 500?
NO - only the 600 to 500
Quote
2) Should I only do this on the core- or on all of the mds too?

both.
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: wombiroller on July 14, 2010, 04:30:59 pm
For the record, if you can already do a sudo apt-get update and sudo apt-get upgrade to get the new packages - I don't think you should be playing here....

huh - I only changed the one that was set to 600. Worked for me.

RayBe - open a command prompt and type:
Quote
sudo pico /etc/apt/preferences
(pico is a terminal text editor, you can use others like vim but pico might be easier).

You will see this section
Code: [Select]
# If our local package uses the same version as elsewhere, we take the one we have locally.
Package: *
Pin: origin
Pin-Priority: 600
Change it to
Code: [Select]
# If our local package uses the same version as elsewhere, we take the one we have locally.
Package: *
Pin: origin
Pin-Priority: 500

Save the file and retry.

Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: RayBe on July 14, 2010, 05:00:59 pm
Ok thanks,

If i do this right after the install, before i connect any md, do i still have to do this on the core and the md?

All the best

Raymond
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: maverick0815 on July 14, 2010, 05:59:47 pm
so, I'm wondering what does changing the priority actually do -aside from the fact, that you get packages offered...or what is different with these packages in regards to packages I would get when they are with priority 600?
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: rperre on July 14, 2010, 07:03:25 pm
my question is on the md's the pin-priority is 9999. so still change that to the 500?

This is the preferences file on both my md's

Code: [Select]
Package: *
Pin: origin
Pin-Priority: 9999

Package: *
Pin: release v=8.10,o=Ubuntu,a=hardy,l=Ubuntu
Pin-Priority: 9998


Richard
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: posde on July 14, 2010, 08:03:24 pm
Richard,

core and MD should have the same preferences file.
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: rperre on July 14, 2010, 10:13:53 pm
Thank you,

should have, i understand, but they don't.

Can i just copy the preferences file to the MD's? meaning this will not botch my install?

Richard
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: posde on July 14, 2010, 11:18:04 pm
Correct
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: Beeker on July 15, 2010, 04:11:31 am
Hi All,
Attached is a list of the errors I am having whilst trying to do an update, I have modified the Pin priority to 500 still getting errors at the end of apt-get upgrade and apt-get update any help would be very much appreciated.....stuck in a rut

Cheers
Beeker
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: wombiroller on July 15, 2010, 07:03:44 am
Beeker - are you running 0810 Beta?
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: Beeker on July 15, 2010, 07:23:34 am
yes
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: posde on July 15, 2010, 08:17:48 am
Beeker,

remove the avenard repo from your sources.list. You will still get a couple of not founds during apt-get update, but apt-get upgrade should run through.
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: Beeker on July 15, 2010, 01:37:09 pm
Frustrated now, edited the sources.list to fix the avenard issue and I did a update and upgrade and it did a whole lot of updating and funny weborbiter is sort of working but my one and only md now wont play any video files it either says it cant find them or there is a CSS issue. Everything worked prior to updating the core, I had to end up deleting the md just to get it back working at all

Any ideas?

Cheers
Beeker
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: posde on July 15, 2010, 02:35:18 pm
Good to hear that the update upgrade issue has been fixed for you.

Regarding your MD trouble, you might want to open a new topic.
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: Kooma on July 17, 2010, 01:25:22 pm
Hi,
trying to update mainly to get the WO2.0. I guess it didn't go through, since WO2.0 files don't exist.

Was hoping to solve this by changing the priority from 600 to 500, but, I don't have this file /etc/apt/preferences. Avenard repo was not in sources.list.

Any hints how to proceed would be most appreciated.

/Kooma
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: posde on July 17, 2010, 04:23:29 pm
What does
Code: [Select]
dpkg -l pluto-website-admin
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: Kooma on July 17, 2010, 04:48:35 pm
Thanks posde for replying. This is the output, I have just no clue what that means:

Desired=Unknown/Install/Remove/Purge/Hold
| Status=Not/Inst/Cfg-files/Unpacked/Failed-cfg/Half-inst/trig-aWait/Trig-pend
|/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
||/ Name                         Version                      Description
+++-============================-============================-========================================================================
ii  pluto-website-admin          2.0.0.44.10042822898         <insert up to 60 chars description>

BR, Kooma
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: Kooma on July 18, 2010, 01:28:19 am
Okay dokay, I got bunch of help from posde in #linuxmce.
 
My installation turned out to be a very old one, therefore massively outdated and not really suitable for normal update. It required some sort of package etc magic, I was just repeating the commands instructed. After a few reboots, the system is up and running again.

Thank you for your help, I hope to contribute back soon.

BR, Kooma
Title: Re: FIX: apt-get update / upgrade not upgrading
Post by: RayBe on July 21, 2010, 11:25:40 pm
hi after installing LinuxMCE-8.10-23154-i386 snapshot, before installing lmce,
in kubuntu i tried:
apt-get update
sudo apt-get dist-upgrade,
no updates were installed;
so i changed the pin-priority too 500
but still no updates?!?

any ideas?

br
Raymond