Author Topic: [Solved] KDM login prompt is loaded before Orbiter starts  (Read 1795 times)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
[Solved] KDM login prompt is loaded before Orbiter starts
« on: April 21, 2010, 09:10:03 am »
Hi,

After last update of 0810 when hybrid core boots Orbiter doesn't start. Instead of that the KDM login prompt is showed on the screen. After success login as linuxmce the Orbiter starts but inside KDE.

Any idea how to solve that?

Thanks in advance.

UPDATED: Solved by removing KDM from startup scripts:
Code: [Select]
sudo update-rc.d -f kdm remove
« Last Edit: April 21, 2010, 01:06:09 pm by nite_man »
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

gadget

  • Veteran
  • ***
  • Posts: 136
    • View Profile
Re: [Solved] KDM login prompt is loaded before Orbiter starts
« Reply #1 on: April 22, 2010, 03:20:39 pm »
I have just had the same issue.
Thanks for solution.

gadget

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: [Solved] KDM login prompt is loaded before Orbiter starts
« Reply #2 on: April 22, 2010, 03:47:44 pm »
np :) Good to see that my post is useful for you
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

stallione

  • Veteran
  • ***
  • Posts: 60
    • View Profile
Re: [Solved] KDM login prompt is loaded before Orbiter starts
« Reply #3 on: April 28, 2010, 01:11:32 am »
Thanks nite_man! I was at a loss to why this was happening.

johanr

  • Veteran
  • ***
  • Posts: 144
    • View Profile
Re: [Solved] KDM login prompt is loaded before Orbiter starts
« Reply #4 on: June 01, 2010, 11:16:28 pm »
thx  :)

Esperanto

  • Guru
  • ****
  • Posts: 271
    • View Profile
Re: [Solved] KDM login prompt is loaded before Orbiter starts
« Reply #5 on: December 18, 2011, 10:17:01 am »
I had the same problem after an apt-get dist-upgrade and the above did not solve it. As a quick solution I moved the kde init file:

sudo mv /etc/init/kdm.conf /root/

not a pretty one but at least lmce showed again ;-)

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: [Solved] KDM login prompt is loaded before Orbiter starts
« Reply #6 on: December 21, 2011, 09:19:00 pm »
What is happening is that /etc/X11/default-display-manager is being overwritten by a kdm update.

As opposed to either of the above solutions, do this as root.

Code: [Select]
echo "/bin/false" > /etc/X11/default-display-manager
I never quit... I just ping out.