Author Topic: Need diskless driver for RealTek 8168B nic  (Read 1975 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Need diskless driver for RealTek 8168B nic
« on: October 11, 2006, 12:42:00 am »
Can someone point me in the direction of how to compile in support for a RealTek 8168B Gigabit NIC. Apparently it uses the r1000.ko module
Then I will need to make the mods to get PLUTOHOME script to install them when doing a diskless Media Director install.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Re: Need diskless driver for RealTek 8168B nic
« Reply #1 on: October 18, 2006, 02:28:39 am »
Quote from: "cbynaker"
Can someone point me in the direction of how to compile in support for a RealTek 8168B Gigabit NIC. Apparently it uses the r1000.ko module
Then I will need to make the mods to get PLUTOHOME script to install them when doing a diskless Media Director install.


On the way toward trying to remedy this I have compiled a new linux-image package and hit something I am unfamiliar and not spent time researching just yet. When I boot to the new file the console says the following:
initrd-tools: 0.1.01
mount: unknown filesystem type `devfs`
umount: devfs not mounted
setting ntfsserver 192.168.80.1
not loading ethernet modules, root not set to /dev/nfs
etc . . . until the kernel panic

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Re: Need diskless driver for RealTek 8168B nic
« Reply #2 on: October 18, 2006, 02:28:55 am »
Quote from: "cbynaker"
Can someone point me in the direction of how to compile in support for a RealTek 8168B Gigabit NIC. Apparently it uses the r1000.ko module
Then I will need to make the mods to get PLUTOHOME script to install them when doing a diskless Media Director install.


On the way toward trying to remedy this I have compiled a new linux-image package and hit something I am unfamiliar and not spent time researching just yet. When I boot to the new file the console says the following:
initrd-tools: 0.1.01
mount: unknown filesystem type `devfs`
umount: devfs not mounted
setting ntfsserver 192.168.80.1
not loading ethernet modules, root not set to /dev/nfs
etc . . . until the kernel panic

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Re: Need diskless driver for RealTek 8168B nic
« Reply #3 on: October 18, 2006, 03:13:31 am »
Quote from: "cbynaker"
Quote from: "cbynaker"
Can someone point me in the direction of how to compile in support for a RealTek 8168B Gigabit NIC. Apparently it uses the r1000.ko module
Then I will need to make the mods to get PLUTOHOME script to install them when doing a diskless Media Director install.


On the way toward trying to remedy this I have compiled a new linux-image package and hit something I am unfamiliar and not spent time researching just yet. When I boot to the new file the console says the following:
initrd-tools: 0.1.01
mount: unknown filesystem type `devfs`
umount: devfs not mounted
setting ntfsserver 192.168.80.1
not loading ethernet modules, root not set to /dev/nfs
etc . . . until the kernel panic


So far it looks like the initrd file compiled different that original.

The original from a previous MD install after gzip | cpio process:
dcerouter_6290:~/core2# file ./initrd.img-2.6.16.20-pluto-1-686
./initrd.img-2.6.16.20-pluto-1-686: ASCII cpio archive (SVR4 with no CRC)

The new compiled one is not gzipped !!!:
file /usr/pluto/diskless/120/boot/initrd.img-2.6.16.20-pluto-1-686
/usr/pluto/diskless/120/boot/initrd.img-2.6.16.20-pluto-1-686: Linux Compressed ROM File System data, little endian size 5931008 version #2 sorted_dirs CRC 0x4d676f30, edition 0, 3404 blocks, 386 files

Apparently there is a switch I did not set while compiling.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
Re: Need diskless driver for RealTek 8168B nic
« Reply #4 on: October 18, 2006, 04:18:41 am »
Quote from: "cbynaker"
Quote from: "cbynaker"
Can someone point me in the direction of how to compile in support for a RealTek 8168B Gigabit NIC. Apparently it uses the r1000.ko module
Then I will need to make the mods to get PLUTOHOME script to install them when doing a diskless Media Director install.


On the way toward trying to remedy this I have compiled a new linux-image package and hit something I am unfamiliar and not spent time researching just yet. When I boot to the new file the console says the following:
initrd-tools: 0.1.01
mount: unknown filesystem type `devfs`
umount: devfs not mounted
setting ntfsserver 192.168.80.1
not loading ethernet modules, root not set to /dev/nfs
etc . . . until the kernel panic


So far it looks like the initrd file compiled different that original.

The original from a previous MD install after gzip | cpio process:
dcerouter_6290:~/core2# file ./initrd.img-2.6.16.20-pluto-1-686
./initrd.img-2.6.16.20-pluto-1-686: ASCII cpio archive (SVR4 with no CRC)

The new compiled one is not gzipped !!!:
file /usr/pluto/diskless/120/boot/initrd.img-2.6.16.20-pluto-1-686
/usr/pluto/diskless/120/boot/initrd.img-2.6.16.20-pluto-1-686: Linux Compressed ROM File System data, little endian size 5931008 version #2 sorted_dirs CRC 0x4d676f30, edition 0, 3404 blocks, 386 files

Apparently there is a switch I did not set while compiling.