Author Topic: mce v2 receiver and lirc embedded transmit  (Read 777 times)

Kaelix

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
mce v2 receiver and lirc embedded transmit
« on: August 25, 2009, 09:51:39 pm »
I'm running 810 alpha 2.26. I added a version 2 mce receiver and it was pretty much plug and play. I went into the A/V Equipment section on the admin site and added my TV (zenith L20V36) I created the device template for it and configured all the pronto codes for basic functions like power toggle, mute, vol up and vol down. All the IR codes work from the admin site or from Advanced -> Infrared Codes on my webpad orbiter. I have the A/V pipes setup correctly on the MD. When I try to use the remote in a normal fashion, watch a video or TV, none of the commands (like volume) are passed to the TV. I've searched the forums and there are others with this issue, but I haven't been able to find posts with solutions. Thanks

chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: mce v2 receiver and lirc embedded transmit
« Reply #1 on: January 08, 2010, 06:51:58 pm »
I have the same issue. What happens is that the LIRC device does not appear to pick up on the fact that a command has been sent to its child device (the TV).

So pressing "Resend AV Commands" then pressing HDMI for my TV does nothing, and the following is logged by the DCERouter:

Code: [Select]
Received Message from 10 (Media Plug-in / Living Room) to 90 (Hitachi LCD / Living Room), type 1 id 91 Command:Input Select, retry none, parameters: <0x677f7b90>
But pressing advanced next to the command, and the pressing "HDMI" in the list of available commands for the TV works, and the following is logged:

Code: [Select]
Received Message from 126 (Orbiter / Living Room) to 63 (LIRC Embedded Transmit / Living Room), type 1 id 191 Command:Send Code, retry none, parameters: <0x677f7b90>

i.e. when the command is sent direct to the LIRC transmitter it works, but if it is sent to the child device the LIRC device (parent) does not react.

Can any of the devs confirm/deny this? Seems a bit odd that there would be a bug in this without loads of people complaining!

Chris


pedplar

  • Veteran
  • ***
  • Posts: 89
    • View Profile
Re: mce v2 receiver and lirc embedded transmit
« Reply #2 on: January 08, 2010, 11:24:39 pm »
As far as I know ir blasting isn't supported with windows mce receiver.  I have never been able to get it working.  So I just bought some usb-uirt.

MANDINGO

  • Guru
  • ****
  • Posts: 204
    • View Profile
Re: mce v2 receiver and lirc embedded transmit
« Reply #3 on: January 09, 2010, 12:15:46 am »
This is one of the things i will be looking into and getting the blasters blasting when im done with the addition of the DVB cards etc......

Mandingo
For a Current List of Plug and Play Capture Cards/Devices
http://wiki.linuxmce.org/index.php/Capture_Cards