Author Topic: Denon AVR 2307 - house to sleep mode while media is playing  (Read 6399 times)

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Denon AVR 2307 - house to sleep mode while media is playing
« on: February 09, 2009, 03:55:13 am »
Hey All,

Got myself a Denon AVR 2307 yesterday and was very impressed with the plug and play nature!!! (USB to RS232 cable)  ;D ;D

I did notice some odd behaviour though - hoping someone may be able to assist.

Prob1
I added the  Off command to the AVR under the Stop Media command in "House to Sleep" scenario.

This works (turns the AVR off) but it only _stays_ off if I run the scenario when no media is playing prior to running the scenario...

If I have audio or video playing and run the scenario - the media and amp get turned off, but then about 10sec later the amp comes back on again (not the media)....I tried adding a delay of ten seconds between the stop media and off command - but other than delaying the amp from switching off - it didn't fix the problem (it still comes back on).

When no media is playing - the AVR 2307 stays off when the house to sleep scenario is run.

Prob2
When I select new media, it starts to play immediately - but after a second or so - audio cuts out as Linuxmce seems to reset the Denons outputs. Then starts playing again. This doesn't happen if I change songs in a playlist - but if I load a new playlist or new media it happens every time...

Both problems are pretty minor but annoying no-the-less. Any ideas?

Cheers,
Adriel.





posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #1 on: February 09, 2009, 08:16:19 am »
[..]
Prob2
When I select new media, it starts to play immediately - but after a second or so - audio cuts out as Linuxmce seems to reset the Denons outputs. Then starts playing again. This doesn't happen if I change songs in a playlist - but if I load a new playlist or new media it happens every time...

As a heads up. I have seen the same problem with a different amp (Meridian Audio System). My assumption is, it has nothing to do with the amp, but with the sound card.

What sound card do you use?

Code: [Select]
root@moon67:~# lspci -v -s 00:1b.0
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller (rev 02)
Subsystem: ASUSTeK Computer Inc. Unknown device 829f
Flags: bus master, fast devsel, latency 0, IRQ 22
Memory at fbff8000 (64-bit, non-prefetchable) [size=16K]
Capabilities: [50] Power Management version 2
Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0 Enable-
Capabilities: [70] Express Unknown type IRQ 0

        *-multimedia
             description: Audio device
             product: 82801I (ICH9 Family) HD Audio Controller
             vendor: Intel Corporation
             physical id: 1b
             bus info: pci@0000:00:1b.0
             version: 02
             width: 64 bits
             clock: 33MHz
             capabilities: pm msi pciexpress bus_master cap_list
             configuration: driver=HDA Intel latency=0 module=snd_hda_intel


It is an Asus P5K.


wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #2 on: February 09, 2009, 12:04:31 pm »
Hey Posde...

Well spotted...it is a Asus PK5Pro MOBO... lspci  shows exact same info (copy paste from telnet):

Code: [Select]
00:1b.0 Audio device: Intel Corporation 82801I (ICH9 Family) HD Audio Controller                            (rev 02)
        Subsystem: ASUSTeK Computer Inc. Unknown device 829f
        Flags: bus master, fast devsel, latency 0, IRQ 22
        Memory at fbff8000 (64-bit, non-prefetchable) [size=16K]
        Capabilities: [50] Power Management version 2
        Capabilities: [60] Message Signalled Interrupts: Mask- 64bit+ Queue=0/0                            Enable-
        Capabilities: [70] Express Unknown type IRQ 0

I take it I'll just have to live with it?




posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #3 on: February 09, 2009, 01:11:52 pm »
I am not sure that one has to live with it.

Two options
* Wait for 0810 an hope it will solve the problem
* Buy a PCI soundcard and use that.


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #4 on: February 09, 2009, 06:37:48 pm »
Actually, the problem is in the device template itself, I'm assuming you're using the AVC-A1SRA template?

I had to do some Denon work for Totallymaxed, and we spotted this in the original template. I subsequently made a device template specifically for the 2308.

Basically, there is a mute command in the power command that gets executed after 2 seconds, it just needs to be removed. (look in the Ruby Codes for the template.)

-Thom

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #5 on: February 09, 2009, 07:08:13 pm »
Thom,

it would be nice, if this fixes the problem for wombiroller.

I suspect, it won't. As I see the same problem with the Meridian Soundprocessor, where I wrote the device template myself. It is a problem of the driver for the sound chip on the mainboard it seems.

@wombiroller: Check the device template, and see if Thom's suggestion help you. Would be the cheapest fix ;)

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5501
  • DOES work for LinuxMCE.
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #6 on: February 09, 2009, 07:49:49 pm »
Hm sorry, I am remembering more.. I made a function called switchInput(input) in Private Method Listing

Code: [Select]
def switchInput(newinput)

   if newinput = @currentInput
   else
      @currentInput = input
      conn_.Send(newinput)
   end

end

now replace the different input commands with: switchInput("DVD")  etc.

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #7 on: February 09, 2009, 11:24:07 pm »
Thanks Gents - i'll try when I get home tonight :-)

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #8 on: February 10, 2009, 11:41:13 am »
I stupidly f'd up a device template in the ruby code and can't find how to put the original one back in....
Wizard => Generic Serial Devices => AVC-A1SRA (RS232) => Ruby Codes => internal => #355 Process Initialize

If someone has the original code handy it'd be appreciated :)

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #9 on: February 10, 2009, 12:25:39 pm »
[..]
If someone has the original code handy it'd be appreciated :)

I regularly fuck up some existing templates. What I do is, I go into the web admin, Advanced / sqlCVS / Diff, and check all DCE and IR. lmce goes out, checks the sqlCVS version of my templates, and on the following screen, I select the tables I want to revert to their original information.

The first 4-5 times, I did not select the right tables and totally screwed my installation. Nowadays this works fairly well ;)

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #10 on: February 10, 2009, 12:56:01 pm »
I regularly fuck up some existing templates. What I do is, I go into the web admin, Advanced / sqlCVS / Diff, and check all DCE and IR. LinuxMCE goes out, checks the sqlCVS version of my templates, and on the following screen, I select the tables I want to revert to their original information.

The first 4-5 times, I did not select the right tables and totally screwed my installation. Nowadays this works fairly well ;)

Saviour! Great advice posde - worked a treat and I even remembered not to kill my gyro changes!  ;D

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #11 on: February 10, 2009, 01:22:28 pm »
Thom, Posde - thanks again for your help... I can confirm, after core reset - this minor but annoying issue (#2) is now resolved  :D

For the record - this is what I have now:
#373 Private Method Listing
Code: [Select]
def TestPrivate()
print "In TestPrivate\n"
end

def switchInput(newinput)

   if newinput = @currentInput
   else
      @currentInput = input
      conn_.Send(newinput)
   end

end

#355 Process Initialize
Code: [Select]
#31-May-06 14:13 init Denon AVC

initok=false


# It doesn't respond to anything but power on when it's off.  Before turning it on and off
# See if it responds to something it normally would while it's on

for iRetry in 0...4
    print "Initializing unit\n"
conn_.Send("MVUP\rMVDOWN\r")
    buf = conn_.Recv(200, 1000)
    if( !buf.nil? && !buf.index("MV" ).nil? )
        print "Initialized ok\n"
initok=true
break
else
print "Didn't respond to mv up/down\n"
end
end

if initok==false
for iRetry in 0...4
print "Initializing unit\n"
conn_.Send("PWON\r")
sleep(3);
conn_.Send("PWSTANDBY\r");
buf = conn_.Recv(200, 4000)
if( !buf.nil? && (!buf.index("ON" ).nil? || !buf.index("STAND" ).nil? || !buf.index("OFF"

).nil?) )
print "Initialized ok from off state\n"
initok=true
break
else
print "Failed to initialize\n"
end
print "Failed to initialize.  Wait 1 secs and try again\n"
sleep(1)
end
end

if initok==false
DisableDevice( device_.devid_, true )
print "The device wouldn't respond. Disabling it.\n"
return
end

print "Initialized ok, doing log\n"

$logFile = File.new("/var/log/pluto/DenonAVC.log", "w")
$SoundLevel = 0

#buffer for reading from serial
$line=String.new
$lineIndex=0

$waitTime = 3000      #wait time in comunication

$eventCode = {
"MS"    =>    "Mode surround",
"PS"    =>    "Parameter settings",
"TF"    =>    "Tone frequency",
"TP"    =>     "Tuner present",
"TM"    =>     "Tuner band",
"PW"    =>     "Power",
"MV"    =>     "Master volume",
"CV"    =>     "Chanel volume",
"MU"    =>     "Mute",
"SI"    =>    "Select Input"
}

$inputSources = {
switchInput("VDP")             =>        176,
switchInput("VCR-3")          =>        284,
switchInput("VCR-2")            =>        283,
switchInput("VCR-1")           =>        282,
switchInput("V.AUX")           =>        285,
switchInput("TV" )               =>       161,
switchInput("TUNER")          =>       166,
switchInput("PHONO")           =>       163,
switchInput("MD/TAPE2")     =>       174,
switchInput("DVD")             =>       165,
switchInput("DBS/SAT")        =>       281,
switchInput("CD")             =>       162,
switchInput("CDR/TAPE1")     =>       420
}

Worth a note in the Wiki or will this be a moot point in 0810?

Cheers,
Wombiroller.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3045
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #12 on: February 10, 2009, 01:26:50 pm »
Let's hope that the device template in sqlCVS is going to be updated ...

jondecker76

  • Alumni
  • wants to work for LinuxMCE
  • *
  • Posts: 763
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #13 on: February 10, 2009, 02:40:08 pm »
file a bug report with the instructions in Trac to make sure it doesn't get lost and make sure it makes it into 0810

wombiroller

  • Guru
  • ****
  • Posts: 340
    • View Profile
Re: Denon AVR 2307 - house to sleep mode while media is playing
« Reply #14 on: February 10, 2009, 11:40:36 pm »
file a bug report with the instructions in Trac to make sure it doesn't get lost and make sure it makes it into 0810
http://svn.linuxmce.org/trac.cgi/ticket/111  :)