Author Topic: VDR replay good and Media replay not so good - interlacing problem  (Read 1299 times)

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Hi,

I have recorded some things using DVB-T in denmark and it plays very well when using VDR recordings menu.
But replaying them with the Media listing looks awfull. Lots of Interlacing around Peoples bodies and elsewhere :(

VDR was changed in setup.conf to use tvtime :
xineliboutput.Video.Deinterlace = tvtime
xineliboutput.Video.DeinterlaceOptions = method=GreadyH,cheap_mode=0,pulldown=none,framerate_mode=full,judder_correction=1,use_progressive_frame_flag=1,chroma_filter=0,enabled=1

Btw. found a link explaining the options (someone asked in another topic) : http://www.linuxtv.org/pipermail/vdr/2008-July/017296.html


How can I change the the normal replay to also do interlacing ?


Btw. would it be possible to remove the resume.vdr files from the media listing, does not look very nice ;)

Thanks a lot to everybody working on integrating VDR into LinuxMCE :)

Greetings
Viking

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #1 on: January 20, 2009, 10:07:17 pm »
You can turn on deinterlacing for the MD in the admin site, but this will impact performance. No idea whether this means it deinterlaces twice when playing live TV (which would be bad)

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2925
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #2 on: January 20, 2009, 11:11:39 pm »
[..]
But replaying them with the Media listing looks awfull. Lots of Interlacing around Peoples bodies and elsewhere :(
[..]
xineliboutput.Video.Deinterlace = tvtime
xineliboutput.Video.DeinterlaceOptions = method=GreadyH,cheap_mode=0,pulldown=none,framerate_mode=full,judder_correction=1,use_progressive_frame_flag=1,chroma_filter=0,enabled=1
[..]

Could you check, if changing /etc/pluto/xine.conf helps you with the deinterlacing? I don't know, if the settings in there get overwritten (I think they don't), maybe that helps.

Keep us posted, please.

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #3 on: January 22, 2009, 01:08:17 am »
Hi,

I found the "try /etc/pluto/xine.conf" tipp somewhere else and already tried that. But maybe I did not find the right switches to play with. Some of the settings are marked as deprecated. Those I did not test yet. But until now I did not see any improvement.

Does anybody know if I must do a "quick reload" before the xine.conf settings are used ? Or are they used the next time one play something ?

If I find out something I will keep you informed :)

Greetings
Viking

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #4 on: January 22, 2009, 03:53:35 am »
Yes, you will need to do a reload. I note that you didn't take my advice. Can't help you any further ... the setting is already in the web admin.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2925
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #5 on: January 22, 2009, 10:34:06 am »
Yes, you will need to do a reload. I note that you didn't take my advice. Can't help you any further ... the setting is already in the web admin.

does clicking Deinterlace on the web admin update the pluto/xine.conf?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #6 on: January 22, 2009, 07:50:34 pm »
Yes, you will need to do a reload. I note that you didn't take my advice. Can't help you any further ... the setting is already in the web admin.

does clicking Deinterlace on the web admin update the pluto/xine.conf?

not sure, haven't checked - not sure on whether that config file is just for the Xine GUI player or whether it effects anything using the libraries. Changing the admin settings definitely has an impact on both the image and CPU usage...

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #7 on: January 26, 2009, 11:06:40 pm »
Hi Collin,

sorry, must have overlooked your advice - will have a look at it and report back :)

Greetings
Viking

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #8 on: January 26, 2009, 11:28:27 pm »
Hi again,

found it, so far it improves the VDR replay a lot :)
I think it only has an impact on stuff that is interlaced. Xine must be intelligent enough to decide when it is good to deinterlace and when not.
Did only try to play some HD video trailers and they did not seem to get deinterlaced (probably because they are not interlaced ;)). And as far as one can say using vmstat it did not look like ther ewas any CPU impact.

@colin
Thanks a lot :)

Greetings
Viking

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #9 on: January 27, 2009, 12:36:30 pm »
Hi again,

found it, so far it improves the VDR replay a lot :)
I think it only has an impact on stuff that is interlaced. Xine must be intelligent enough to decide when it is good to deinterlace and when not.
Did only try to play some HD video trailers and they did not seem to get deinterlaced (probably because they are not interlaced ;)). And as far as one can say using vmstat it did not look like ther ewas any CPU impact.

@colin
Thanks a lot :)

Greetings
Viking

In LinuxMCE-710 the xine configs for media playback from the media menu in the Orbiter and for playback of recordings (or live TV) in vdr are separate. You are already setting the deinterlace options correctly inside vdr (I would suggest trying the various de-interlacers available from inside the TVtime menu).

For deinterlacing of media playback from the Media menu in the Orbiter you need to set that on a per MD basis from Web Admin ->Wizard -> Devices -> Media Directors... scroll to the MD you want to set deinterlacing for and choose the setting from the 'Deinterlace Quality' pop-up (I would suggest choosing Lowest, Low or Medium as they have negligible performance impact)

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

Viking

  • Addicted
  • *
  • Posts: 521
    • View Profile
Re: VDR replay good and Media replay not so good - interlacing problem
« Reply #10 on: January 30, 2009, 11:33:13 am »
Hallo Andrew,

Thanks for the sugestions :) - I did not test much yet, but Low setting already improved the media replay a lot.

Greetings
Viking