Author Topic: Building on 0710  (Read 958 times)

visy

  • Making baby steps
  • Posts: 3
    • View Profile
Building on 0710
« on: January 12, 2009, 11:59:20 am »
I have tried to follow the instructions in newbielink:http://wiki.linuxmce.org/index.php/Building_From_Source [nonactive] to build 0710 from source but there seems to be no configure script, hence I cannot proceed with the step:

cd trunk
./configure


The reason I ask is that if I continue with the next steps I get errors when running make.

Are there any up to date instructions on how to build 0710?

Thanks in advance

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: Building on 0710
« Reply #1 on: January 12, 2009, 03:22:28 pm »
Yes, they are in the wiki. 0710 does not use a configure script at all. This was something that was tried on our trunk, but ultimately abandoned.

What are you trying to do specifically? This can help us tell you which parts of the build process you actually need to complete.

-Thom

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Building on 0710
« Reply #2 on: January 12, 2009, 04:49:10 pm »
What tschak909 said, and also see on the wiki page:
Quote
For the svn.linuxmce.org source there is no configure script yet. Run these to prepare bootstrapping:

You shoud also be aware that doing this on a LMCE machine (without taking special precautions) will most likely ruin its run-time database.
"Change is inevitable. Progress is optional."
-- Anonymous


visy

  • Making baby steps
  • Posts: 3
    • View Profile
Re: Building on 0710
« Reply #3 on: January 13, 2009, 11:26:33 am »
Well, ultimately I am trying to use CoreAVC for Xine. newbielink:http://wiki.linuxmce.org/index.php/How_to_play_MKV_H264_X264_video_files_using_CoreAVC_in_Xine_Player [nonactive]

There is a step in the above wiki page requiring me to set up a dev environment (presumably to patch the Xine-lib src).

I have found a couple of Wiki pages on this newbielink:http://wiki.linuxmce.org/index.php/Setting_Up_A_Development_Environment [nonactive] and newbielink:http://wiki.linuxmce.org/index.php/Building_From_Source [nonactive], but I have had trouble with both of them.

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 884
  • Living with LMCE
    • View Profile
Re: Building on 0710
« Reply #4 on: January 13, 2009, 08:56:09 pm »
Well, ultimately I am trying to use CoreAVC for Xine. http://wiki.linuxmce.org/index.php/How_to_play_MKV_H264_X264_video_files_using_CoreAVC_in_Xine_Player

There is a step in the above wiki page requiring me to set up a dev environment (presumably to patch the Xine-lib src).

I have found a couple of Wiki pages on this http://wiki.linuxmce.org/index.php/Setting_Up_A_Development_Environment and http://wiki.linuxmce.org/index.php/Building_From_Source, but I have had trouble with both of them.
Hi,

I have compiled Lighting and Climate plugins on 7.10. Notes are published on the bottom of :
http://wiki.linuxmce.org/index.php/Adding_support_for_floorplan_devices

Something similar will apply for your case. Get into desired directory, try to compile, and you'll see what libs are missing. Compile them too.. Remember to save original binaries, so you can revert back your changes....

HTH,

regards,

bulek
Thanks in advance,

regards,

Bulek.