Author Topic: Core Locks Up when MD gets to 'Reading files needed to boot'  (Read 2599 times)

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Core Locks Up when MD gets to 'Reading files needed to boot'
« on: January 05, 2009, 11:49:35 pm »
I tried to install a new MD on my current build (i have previously had this MD working before a did an unreleated reinstall).  I hit the button to add a new diskless MD in the webadmin tool and then quick reload and boot the New MD.  everything seems to go well, IP addresses are assigned and the MD gets to the line 'reading files needed to boot' and then nothing, and the mouse freezes and the core locks up

I am using 7.10 RC2 and my hardware is as follows:

Hybrid/Core (living room)
•   Gigabyte GA-M61SME-S2 with GeForce 6100 (256Mb shared), Realtek 8201 phy (10/100Mbit – eth0) LAN onboard
•   AMD Athlon 64 X2 5000+
•   2 x 1Gb DDRII
•   Nvidia GeForce 8600GT 512Mb (fitted but not working – yet)
•   10/100/1000 LAN card (eth1)
•   Creative Labs Audigy2 ZS (connected to receiver by Digital Coax)
•   Samsung 1Tb SATAII drive (boot drive)
•   Western Digital 200 Gb IDE drive
•   Hitachi 450 Gb SATAII drive
•   Bluetooth Dongle (from www.techstyleuk.co.uk)
•   DVD Player with Lightscribe
•   Wireless Keyboard
•   Wireless Trackball Mouse (from www.techstyleuk.co.uk)
•   Windows MCE Remote with IR Blaster
•   LG RZ-37LZ55 37” LCD TV connected by RS232
•   Pioneer VSX-411 A/V Receiver – ‘Blasted’ by the IR Blaster
•   CM11A X10 interface connected by RS232
•   Microphone

MD1 (Study)
•   Matsonic MS8147C VIA KT400 Chipset Socket A, Realtek RT8100B LAN (10/100 Mbit), AC’97 audio (sound did not work)
•   AMD Athlon XP 2600+
•   3 x 256Mb PC133 DDR
•   Elsa Erazor 8x AGP (Nvidia GeForce 440MX chipset) 128Mb
•   Creative Labs 5.1 sound card
•   Maxtor 40Gb IDE drive
•   CDRom
•   Viewsonic VE500 15” LCD Monitor
•   Creative Labs 5.1 Speakers
•   Bluetooth Dongle (from www.techstyleuk.co.uk)
•   Wireless Trackball Mouse (from www.techstyleuk.co.uk)

Mobile Orbiter
•   O2 XDA Iii connected via WIFI (802.11b)

Network Equipment
•   Motorola Surfboard connected to eth0
•   Linksys WRT54G router connected to eth1, MD1 and mobile orbiter via WIFI


Thanks for any pointers
Jason

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #1 on: January 21, 2009, 06:16:23 am »
No replies?  :(

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #2 on: January 21, 2009, 10:38:26 am »
No replies?  :(

Hmmm... why not just attach the MD to your network and let is PnP ?

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #3 on: January 21, 2009, 12:30:24 pm »
No replies?  :(

Yeah, sorry but your check bounced. ;)
"Change is inevitable. Progress is optional."
-- Anonymous


Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #4 on: January 22, 2009, 07:02:12 am »
Andrew,

I don't understand.  The MD has no HDD and PXE boots from the core over a wired 100mb network but when it gets to the 'reading files needed to boot'  the MD just stays there, and the Core freezes, mouse will not move the cursor and nothing works.  The other machines on the network (windows) can no longer access the Internet which was previously through the core.

did you mean there is no need to do anything in webadmin prior to plugging the MD into the network and turning it on?

Thanks for any help

Zaerc,

I was really asking if anybody had any pointers to what might be causing this issue.  I thought my first post may have been overlooked for some reason so I was re-posting without re-posting.  I had already searched the forums and the wiki.  I spend time helping with others issues where I can from my own experiences or things I have read.  I wasn't 'expecting' or demanding an answer, sorry if you think I was

Jason

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #5 on: January 22, 2009, 07:58:51 pm »
your assumption was correct - andrew was pointing out that the correct way to add an MD is to plug it into the network and turn it on. No manual action in the admin site required. The option you used is legacy, and you will probably need to clear out anything it has already done like creating an MD and orbiter devices, the diskless directory tree, and perhaps the DHCP lease, etc to get it to rediscover.

nosebreaker

  • Guru
  • ****
  • Posts: 202
    • View Profile
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #6 on: January 22, 2009, 10:35:16 pm »
Well its clearly locking the core when it boots, but it should never do that.  Can you try another box that can netboot and see if it crashes at the same point?

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #7 on: January 22, 2009, 11:17:49 pm »
...
Zaerc,

I was really asking if anybody had any pointers to what might be causing this issue.  I thought my first post may have been overlooked for some reason so I was re-posting without re-posting.  I had already searched the forums and the wiki.  I spend time helping with others issues where I can from my own experiences or things I have read.  I wasn't 'expecting' or demanding an answer, sorry if you think I was

Jason

Well, I was (more or less) just kidding, didn't mean for you to take it to seriously (hence the smiley) my appologies.  Simply try to ignore me and my smart mouth when I say things like that.
"Change is inevitable. Progress is optional."
-- Anonymous


Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #8 on: January 22, 2009, 11:49:44 pm »
I will try to do what Collin suggests first:

I can delete the MD devices and the orbiter device, as for the diskless dir tree, I should be able to find that but can you tell me how I access/edit/release the DHCP lease?

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #9 on: January 23, 2009, 12:25:11 am »
in /etc/dhcp3/dhcpd.conf

the image is under its device number in /usr/pluto/diskless - not sure if you need to delete it manually or if it gets cleaned up when you delete the MD. In any case, the new MD will have a different device number and therefore image directory, so this is really just a cleanup task more than anything.

Reload/reboot, then turn the MD back on and hopefully away you go!

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #10 on: January 23, 2009, 02:00:54 am »
Thanks, I will try it over the weekend and see let you know how it goes.

I did delete the MD and check the directory structure and there was nothing there so it must delete it as it goes

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #11 on: January 25, 2009, 11:45:54 pm »
I tried again as suggested and still the same issue.  I will try to get hold of some new hardware

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #12 on: February 21, 2009, 09:15:23 pm »
I tried a different machine and exactly the same problem.

Any suggestions?

I did just move from the UK to the US and therefore the Core was in a container for 6 wks.  When I started it back up a new MD wouldn't install and my PDA orbiter wouldn't work either.  Is it possible something has got corrupted?  can I reset/reinstall the OS/LMCE without losing my media which is on the same 1TB drive?

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4541
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #13 on: February 21, 2009, 10:01:53 pm »
I tried a different machine and exactly the same problem.

Any suggestions?

I did just move from the UK to the US and therefore the Core was in a container for 6 wks.  When I started it back up a new MD wouldn't install and my PDA orbiter wouldn't work either.  Is it possible something has got corrupted?  can I reset/reinstall the OS/LMCE without losing my media which is on the same 1TB drive?

Well something is not right. Do your existing MD's still boot ok... and work normally?

Andrew
Andy Herron,
Convergent Home Technologies Ltd

My Blog; http://ellipticalcurve.com

Get RaspSqueeze-CEC or Raspbmc-CEC Wifi enabled for Dianemo/LinuxMCE: http://wp.me/P4KgIc-5P

For Dianemo/LinuxMCE consulting advice;
@herron on Twitter, inquiries@ellipticalcurve.com via email or PM me here.

Get a Dianemo License: http://forum.linuxmce.org/index.php?topic=8880.msg100221#msg100221
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

http://www.dianemo.co.uk

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: Core Locks Up when MD gets to 'Reading files needed to boot'
« Reply #14 on: February 25, 2009, 07:53:36 pm »
This is my first MD. it did work when I tried it back in blighty (England) before I reinstalled in the UK when I added the 1TB drive and never added the MD because it was packed for the move.

My core/hybrid seems to work fine.  I can control it with XP orbiter from a laptop or on-screen.  It has been up for a few weeks without reboot (before I started messing with this).  it is a 64bit build.

Since we arrived though I have not been able to use my Windows CE orbiter (XDAII), it worked before and now it just crashes.