Author Topic: Skipping sound solved in KDE desktop need help for LinuxMCE  (Read 738 times)

itsmeok

  • Veteran
  • ***
  • Posts: 100
    • View Profile
Skipping sound solved in KDE desktop need help for LinuxMCE
« on: January 18, 2009, 02:12:57 pm »
I still have skipping sound in LinuxMCE. I found a solution while I am in my KDE desktop. By configuring Xine or Mplayer plugin to use Audio output OSS audio plays fine. I have three questions:

1) Would it be possible to use OSS output in MCE (how)
2) Is it good practice to do so and what are the consequences
3) Who has ideas to solve the Alsa output as I quess Alsa is the automatic one choosen.

The integrated sound on my mother board is Realtek ALC650 codec see output of the following command:
lspci -v | less

00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
        Subsystem: ASUSTeK Computer Inc. A7V8X Motherboard (Realtek ALC650 codec)
        Flags: medium devsel, IRQ 19
        I/O ports at e000 [size=256]
        Capabilities: <access denied>


Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Skipping sound solved in KDE desktop need help for LinuxMCE
« Reply #1 on: January 18, 2009, 03:21:14 pm »
1) I guess so, but you may have to go as far as digging into the source.  I've never looked into it myself, how is this changed for the regular version of Xine under KDE?  And have you looked in /etc/pluto/xine.conf?

2) If it works it works, couldn't hurt to have it as an option I reckon.

3) No idea, sorry.  :(
"Change is inevitable. Progress is optional."
-- Anonymous


itsmeok

  • Veteran
  • ***
  • Posts: 100
    • View Profile
Re: Skipping sound solved in KDE desktop need help for LinuxMCE
« Reply #2 on: January 18, 2009, 05:02:18 pm »
Reply to first question:

I changed xine.conf to use the oss driver. Sound is fixed but I do not know what will be the consequences later if I want to use 5.1 stereo. but at least I can enjoy LinuxMCE and build further with Home automation system

Part changed in xine.conf:

# audio driver to use
# { auto  null  alsa  oss  arts  esd  none  file }, default: 0
audio.driver:oss

The audio driver was auto.

If people know answers on the other two questions please reply as I will be checking this post.