Author Topic: RS-232 control for 32LG3000  (Read 861 times)

Gaute

  • Regular Poster
  • **
  • Posts: 33
    • View Profile
RS-232 control for 32LG3000
« on: February 16, 2009, 01:45:13 pm »
Hello!
I bought a LG3000 30" TV some days ago. I try to figure out how i can controll it over RS-232 with LinuxMCE. I have read about Generic Serial Device on the wiki, but cant get it to work.
Can anybody help me?
Gaute

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: RS-232 control for 32LG3000
« Reply #1 on: February 16, 2009, 02:34:59 pm »
The first thing you need before you can do anything is the communications protocol. You need to source this from the manuals or manufacturer.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: RS-232 control for 32LG3000
« Reply #2 on: February 16, 2009, 02:38:43 pm »
The first thing you need before you can do anything is the communications protocol. You need to source this from the manuals or manufacturer.

LG helpfully provide full rs232 codes in an appendix of the manual for each of their TV's

All the best

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

Gaute

  • Regular Poster
  • **
  • Posts: 33
    • View Profile
Re: RS-232 control for 32LG3000
« Reply #3 on: February 16, 2009, 03:09:59 pm »
I have the communications protocol... it is in the manual... i have also made a new device template, but where shall i put those commands?

Gaute

  • Regular Poster
  • **
  • Posts: 33
    • View Profile
Re: RS-232 control for 32LG3000
« Reply #4 on: February 16, 2009, 04:12:48 pm »
I've added a device and some commands but the log only says:
Code: (/var/log/pluto/74_Generic_Serial_Device.log) [Select]
        in: (eval): 89
        from (eval):89:in `cmd_355'
        from (eval):87:in `each'
        from (eval):87:in `cmd_355'
 <0xb57d6b90>
05      02/16/09 15:52:36.195           Got a reload command from 0  <0xb5fd7b90>
05      02/16/09 15:52:36.479           void ClientSocket::Disconnect() on this socket: 0x80ab610 (m_Socket: 8) <0xb77db6c0>
Return code: 2
2       02/16/09 15:52:36       74 (spawning-device)    Device requests restart... count=1/50 dev=74
2       02/16/09 15:52:36       74 (spawning-device)    Device was disabled or removed. Stopping and marking as not running.
What is wrong? nothing changes when i give it a command...