Author Topic: Issues with logging into MCE shares.  (Read 1054 times)

Woosey

  • Newbie
  • *
  • Posts: 8
    • View Profile
Issues with logging into MCE shares.
« on: December 04, 2008, 12:35:15 pm »
Hi Guys,

I'm having some trouble logging into my MCE shares. My core's internal ip is 192.168.2.2, so when i try to connect to this (\\192.168.2.2) it prompts for a username/password, of which it won't accept any of the account i give it, i even did 'adduser test' then gave it the password test, but still can't get it to accept my credentials!

What am i doing wrong?!

Thanks

Chris

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Issues with logging into MCE shares.
« Reply #1 on: December 04, 2008, 03:04:51 pm »
The username and password is the same as you use to log into the web admin. We do not use the unix accounts at all.

-Thom

seth

  • Guru
  • ****
  • Posts: 485
  • A day w/o LinuxMCE is like a day w/o sunshine!
    • View Profile
Re: Issues with logging into MCE shares.
« Reply #2 on: December 04, 2008, 03:09:55 pm »
 :-\
I see 2 possible issues here.

1.By default, the core's (LMCE's) internal ip should be 192.168.80.1.
And if you have really followed the instructions regarding networking in LMCE, you shouldn't even need the IP, you should simply have to use dcerouter://path/to/share, as LMCE provides its own internal DNS and name resolvers.
This is hard coded, and as a result so are all of its config files. samba.conf, /etc/exports, etc. This is why we HIGHLY RECOMMEND not changing these settings.

2.) Putting the above aside, perhaps you are a networking wizard (I sadly am not) and you knew that changing the internal ip address would change how the system shares media, and as it is a networked system, you went through and changed all the appropriate files so that now the 192.168.2.0 network is permissive to the shares. If this is the case, then all you should need to connect to the shares is the username and password you created on initial install,  for example, before I changed my password, my username was/is : seth and my password was : seth

Those credentials are all you should need to connect to the shares served up from the core. Provided the network you are accessing the media on is set to be permissive in all the appropriate config files.

Hope that helps. Best of luck to you.

Regards,

Seth
".....Because Once you've LinuxMCE'd....."
System stats located at my user page:

http://wiki.linuxmce.org/index.php/User:Seth

Woosey

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Issues with logging into MCE shares.
« Reply #3 on: December 05, 2008, 02:38:49 am »
Hi Guys,

Login details for the web UI don't work for the windows shares :(

:-\
I see 2 possible issues here.

1.By default, the core's (LMCE's) internal ip should be 192.168.80.1.
And if you have really followed the instructions regarding networking in LMCE, you shouldn't even need the IP, you should simply have to use dcerouter://path/to/share, as LMCE provides its own internal DNS and name resolvers.
This is hard coded, and as a result so are all of its config files. samba.conf, /etc/exports, etc. This is why we HIGHLY RECOMMEND not changing these settings.

2.) Putting the above aside, perhaps you are a networking wizard (I sadly am not) and you knew that changing the internal ip address would change how the system shares media, and as it is a networked system, you went through and changed all the appropriate files so that now the 192.168.2.0 network is permissive to the shares. If this is the case, then all you should need to connect to the shares is the username and password you created on initial install,  for example, before I changed my password, my username was/is : seth and my password was : seth

Those credentials are all you should need to connect to the shares served up from the core. Provided the network you are accessing the media on is set to be permissive in all the appropriate config files.

My network setup is....tricky. I need to use the 2.x subnet, so my internal address is 2.2 and external is 2.150, this should fit in with what mce wants to do.

For now i can put with SFTP to get my media onto the box, then moving it around via ssh. I will have to wait until i can change my subnet, then reinstall i guess!


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5497
  • DOES work for LinuxMCE.
    • View Profile
Re: Issues with logging into MCE shares.
« Reply #4 on: December 05, 2008, 02:56:19 am »
Dude, that network configuration won't work. Use the .80.1 range for the internal network.

amazing how the people who have the most trouble, are those who think they know better.

-Thom

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Issues with logging into MCE shares.
« Reply #5 on: December 05, 2008, 05:47:27 am »
Hi Guys,

Login details for the web UI don't work for the windows shares :(

...

My network setup is....tricky. I need to use the 2.x subnet, so my internal address is 2.2 and external is 2.150, this should fit in with what mce wants to do.

For now i can put with SFTP to get my media onto the box, then moving it around via ssh. I will have to wait until i can change my subnet, then reinstall i guess!



1. http://wiki.linuxmce.org/index.php/Logging_In
2. That is not a proper network setup.
"Change is inevitable. Progress is optional."
-- Anonymous


Woosey

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: Issues with logging into MCE shares.
« Reply #6 on: December 05, 2008, 07:42:41 am »
Dude, that network configuration won't work. Use the .80.1 range for the internal network.

amazing how the people who have the most trouble, are those who think they know better.

-Thom


Hi Thom,

WTF! :p

Ok well i could use 80.x for the internal network, i just wanted it to be a test box before i committed to MCE as a solution :)

Will edit them shortly

Thanks guys :)
« Last Edit: December 05, 2008, 07:47:55 am by Woosey »