Author Topic: MSI Media Live VFD Working  (Read 3989 times)

gbutters

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
MSI Media Live VFD Working
« on: July 23, 2008, 01:50:42 pm »
Can someone try this and let me know if it works for them. I got the VFD working on the MSI Media Live working by changing the template name from Media Live LCD/Buttons to Media Live LCDButtons. Before I made the change is was not loading the plugin.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4351
    • View Profile
    • Dianemo - at home with technology
Re: MSI Media Live VFD Working
« Reply #1 on: July 23, 2008, 04:04:39 pm »
Can someone try this and let me know if it works for them. I got the VFD working on the MSI Media Live working by changing the template name from Media Live LCD/Buttons to Media Live LCDButtons. Before I made the change is was not loading the plugin.

Hmmm... that does not seem to make the VFD work for me. Before you edited the template name were you able to use the transport buttons beneath trh VFD when Media was playing?

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom
@herron

Dianemo S Now Shipping on Ubuntu 12.04LTS
Build your system on the latest Ubuntu LTS OS Release!

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

gbutters

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: MSI Media Live VFD Working
« Reply #2 on: July 24, 2008, 12:28:15 am »
This is the output from lsusb for mine.

Bus 001 Device 009: ID 040b:7001 Weltrend Semiconductor

Do you get the same thing?

I do not know if the buttons were working or not.

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4351
    • View Profile
    • Dianemo - at home with technology
Re: MSI Media Live VFD Working
« Reply #3 on: July 24, 2008, 11:30:43 am »
This is the output from lsusb for mine.

Bus 001 Device 009: ID 040b:7001 Weltrend Semiconductor

Do you get the same thing?

I do not know if the buttons were working or not.

I get the same output as you... but then I get that even without editing the the template. Also the transport buttons beneath the VFD work without editing the template.

So can you describe what you see in the VFD once you have edited the name of the template?

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom
@herron

Dianemo S Now Shipping on Ubuntu 12.04LTS
Build your system on the latest Ubuntu LTS OS Release!

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

gbutters

  • Regular Poster
  • **
  • Posts: 19
    • View Profile
Re: MSI Media Live VFD Working
« Reply #4 on: July 24, 2008, 11:49:27 pm »
This is the output from lsusb for mine.

Bus 001 Device 009: ID 040b:7001 Weltrend Semiconductor

Do you get the same thing?

I do not know if the buttons were working or not.

I get the same output as you... but then I get that even without editing the the template. Also the transport buttons beneath the VFD work without editing the template.

So can you describe what you see in the VFD once you have edited the name of the template?

Andrew

Ok I checked and the buttons work when the display is not working.

Go on webadmin to Advanced > Configuration > Devices then select Media Live LCD/Buttons then select View Device Template Media Live LCD/Buttons #1860 and change description to Media Live LCDButtons. Now do quick reload router and the VFD should start working.

The VFD is displaying the Date and Time when idle.
When playing music it shows Arstist - Title & elasped time.

Crawtech

  • Veteran
  • ***
  • Posts: 68
    • View Profile
Re: MSI Media Live VFD Working
« Reply #5 on: July 25, 2008, 05:23:09 am »
mm
I have tried it as well a it still as black as it was before no go at all
you must have changed something else to make it work


tschak909

  • LinuxMCE God
  • ****
  • Posts: 5479
  • DOES work for LinuxMCE.
    • View Profile
Re: MSI Media Live VFD Working
« Reply #6 on: July 25, 2008, 07:07:20 am »
guys, after looking at the template, #1860, the following needs to be fixed:

(this will be applied next release)

  • Implements DCE needs to be checked


and Command Line needs to be set to Media_Live_LCDButtons

save

then restart your media director, all should be well.

-Thom

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4351
    • View Profile
    • Dianemo - at home with technology
Re: MSI Media Live VFD Working
« Reply #7 on: July 25, 2008, 07:19:15 am »
guys, after looking at the template, #1860, the following needs to be fixed:

(this will be applied next release)

  • Implements DCE needs to be checked


and Command Line needs to be set to Media_Live_LCDButtons

save

then restart your media director, all should be well.

-Thom


Thanks Thom :-)
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom
@herron

Dianemo S Now Shipping on Ubuntu 12.04LTS
Build your system on the latest Ubuntu LTS OS Release!

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4351
    • View Profile
    • Dianemo - at home with technology
Re: MSI Media Live VFD Working
« Reply #8 on: July 25, 2008, 12:26:41 pm »
guys, after looking at the template, #1860, the following needs to be fixed:

(this will be applied next release)

  • Implements DCE needs to be checked


and Command Line needs to be set to Media_Live_LCDButtons

save

then restart your media director, all should be well.

-Thom


Just to confirm that Thoms suggested changes to template  #1860 activates the Futaba VFD and its full display capabilities work really nicely.

Again... Thanks Thom :-)

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom
@herron

Dianemo S Now Shipping on Ubuntu 12.04LTS
Build your system on the latest Ubuntu LTS OS Release!

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1046
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Re: MSI Media Live VFD Working
« Reply #9 on: July 25, 2008, 08:31:30 pm »
Added to wiki, should be correct. I dont have one so i cant test it out myself

http://wiki.linuxmce.org/index.php/MSI_Media_Live_Barebone
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4351
    • View Profile
    • Dianemo - at home with technology
Re: MSI Media Live VFD Working
« Reply #10 on: July 28, 2008, 11:39:10 am »
Added to wiki, should be correct. I dont have one so i cant test it out myself

http://wiki.linuxmce.org/index.php/MSI_Media_Live_Barebone

I made some changes to the Wiki page you created above over the weekend to reflect the process I have tested on several MD's.

Thanks

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom
@herron

Dianemo S Now Shipping on Ubuntu 12.04LTS
Build your system on the latest Ubuntu LTS OS Release!

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

golgoj4

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1046
  • hrumpf!
    • View Profile
    • La Smarthomes - SoCal smarthome site
Re: MSI Media Live VFD Working
« Reply #11 on: July 28, 2008, 05:55:53 pm »
Added to wiki, should be correct. I dont have one so i cant test it out myself

http://wiki.linuxmce.org/index.php/MSI_Media_Live_Barebone

I made some changes to the Wiki page you created above over the weekend to reflect the process I have tested on several MD's.

Thanks

Andrew

thanks! i was a little worried i was missing some steps.
Those people who tell you not to take chances, they are all missing what life's all about.

Wiki Hardware Page http://wiki.linuxmce.org/index.php/User:Langstonius

Crawtech

  • Veteran
  • ***
  • Posts: 68
    • View Profile
Re: MSI Media Live VFD Working
« Reply #12 on: July 29, 2008, 05:02:04 am »
Hi all
I have tested the VFD in Mythtv and it works the same as it does in VDR as well

But I have also noticed that HDMI audio is working as well now, could some one else test and see if their HDMI audio is working as well

Thanks
Chris 


« Last Edit: July 30, 2008, 02:11:30 am by hgait »

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4351
    • View Profile
    • Dianemo - at home with technology
Re: MSI Media Live VFD Working
« Reply #13 on: July 29, 2008, 11:45:33 am »
Hi all
I have tested the VFD in Mythtv and it works the same as it does in VDR as well

But I have also noticed that HDMI audio is working as well, now could some one else test and see if their HDMI audio is working as well

Thanks
Chris 

The Media Live VFD template has no affect on HDMI audio.

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom
@herron

Dianemo S Now Shipping on Ubuntu 12.04LTS
Build your system on the latest Ubuntu LTS OS Release!

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

Crawtech

  • Veteran
  • ***
  • Posts: 68
    • View Profile
Re: MSI Media Live VFD Working
« Reply #14 on: July 30, 2008, 02:12:17 am »
Hi Andrew

yes i know that but it is working now
 Is the  HDMI Audio working on yours ??
« Last Edit: July 30, 2008, 05:05:27 am by hgait »