Author Topic: Bluetooth with Orbiter Problem  (Read 852 times)

rdmustang

  • Regular Poster
  • **
  • Posts: 33
    • View Profile
Bluetooth with Orbiter Problem
« on: May 16, 2008, 03:54:36 pm »
I have 2 WM2003 PDAs and 1 WM2003 phone.  All 3 are xscale processors.  When I enable BT my MD sees the phones and asks to add them. 

It asks if it's a Windows Mobile device or Windows Mobile 2005 device.  If I choose WM then all 3 devices get the file but when I go to run the cab file it says it's not a valid CE application.  If I choose WM2005 then the devices get the cab and it installs but when I go to run Pluto Orbiter it says it's not a valid CE application.

I then tried downloading the install from the web interface for the appropriate device (wm xscale cpu).  Those install fine and I can get them to work when sych'd with my computer (sharing network access with my computer).  I cannot figure out how to get them to sych with BT and control the MDs using BT.

Can anyone please provide any help?

ytuxedo002

  • Veteran
  • ***
  • Posts: 51
    • View Profile
Re: Bluetooth with Orbiter Problem
« Reply #1 on: May 18, 2008, 12:33:48 am »
Same problem here.  Anybody have a solution?

rdmustang

  • Regular Poster
  • **
  • Posts: 33
    • View Profile
Re: Bluetooth with Orbiter Problem
« Reply #2 on: May 22, 2008, 05:23:29 pm »
Any suggestions? This is the one barrier I have left with phase 1 of my MCE deployment :)

rdmustang

  • Regular Poster
  • **
  • Posts: 33
    • View Profile
Re: Bluetooth with Orbiter Problem
« Reply #3 on: May 25, 2008, 09:01:33 pm »
I haven't tested whether follow me works or whether this works on any MD's other than the one on my core and I'm not sure if there are better ways to do this or if some of this isn't required, but here is how I got my PDA working as an orbiter:

Pair the devices by using the following:
run: hidd --connect <MAC Address of PDA BT>

Enable Personal Area Network on the CORE:
modify:/etc/default/bluetooth
change:
   PAND_ENABLED=0
to:
   PAND_ENABLED=1

uncomment:
   PAND_OPTIONS="--listen --role NAP"


Set a static IP network for the core to speak to the PDA:
add to  /etc/network/interfaces:
auto bnep0
iface bnep0 inet static
        address 192.168.81.1
        netmask 255.255.255.0


Reboot the Core

Set the IP of the PDA to be 192.168.81.2
Then on the PDA use the BT manager to connect to a network and find the core and connect to it.

In the orbiter set the IP as 192.168.80.1 (assuming you use the default IP) and put in the device ID established by the core.
« Last Edit: May 25, 2008, 09:07:51 pm by rdmustang »