Author Topic: (0710 B4) MythTV exits automatically in less than 1 minute after start  (Read 2960 times)

finsdown

  • Veteran
  • ***
  • Posts: 54
    • View Profile
Both my MD's will automatically exit from MythTV after about 45 seconds every time.  This does not happen on the hybrid/core. If I run mythfrontend from the KDE desktop, I do not have this problem.  I've pasted the log below from one of my MDs.  Has anyone else seen this happen with 0710B4?



linuxmce@dcerouter:/usr/pluto/diskless/50/var/log/pluto$ sudo tail Spawn_mythfrontend_30109.log
2008-03-08 16:37:40.642 Unable to run plugin 'mythfrontend': not initialized
/usr/lib/mythtv/plugins/liblibmythmythfrontend.so: cannot open shared object file: No such file or directory
2008-03-08 16:37:40.642 MythPlugin::Init() dlerror:
2008-03-08 16:37:40.642 Unable to initialize plugin 'mythmythfrontend'.
2008-03-08 16:37:40.642 Unable to run plugin 'mythmythfrontend': not initialized
2008-03-08 16:37:40.643 MSqlQuery: SELECT data FROM settings WHERE value = 'MonitorDrives' AND hostname = 'moon50' ;
2008-03-08 16:37:40.643 MSqlQuery: SELECT data FROM settings WHERE value = 'NetworkControlEnabled' AND hostname = 'moon50' ;
2008-03-08 16:37:40.644 MSqlQuery: SELECT data FROM settings WHERE value = 'Theme' AND hostname = 'moon50' ;
2008-03-08 16:37:40.645 MSqlQuery: SELECT data FROM settings WHERE value = 'AllowQuitShutdown' AND hostname = 'moon50' ;
2008-03-08 16:37:41.686 MSqlQuery: SELECT data FROM settings WHERE value = 'Language' AND hostname = 'moon50' ;
linuxmce@dcerouter:/usr/pluto/diskless/50/var/log/pluto$       

finsdown

  • Veteran
  • ***
  • Posts: 54
    • View Profile
I think this log shows the error message:

linuxmce@dcerouter:/usr/pluto/diskless/50/var/log/pluto$ tail 58_MythTV_Player.log
05      03/08/08 16:58:05.979           MythTV_Player::pollMythStatus no jump livetv  <0x40800950>
01      03/08/08 16:58:05.980           Failed initial communications with Mythfrontend. <0x40800950>
01      03/08/08 16:58:05.983           Killed Mythfrontend. <0x40800950>
05      03/08/08 16:58:05.995           Going to send command quit <0x41802950>
05      03/08/08 16:58:06.999           Connect() failed, Error Code 111 (Connection refused)) <0x41802950>
05      03/08/08 16:58:08.023           Connect() failed, Error Code 111 (Connection refused)) <0x41802950>
05      03/08/08 16:58:09.023           Connect() failed, Error Code 111 (Connection refused)) <0x41802950>
05      03/08/08 16:58:09.023           ClientSocket::Connect() not successful <0x41802950>
05      03/08/08 16:58:09.023           void ClientSocket::Disconnect() on this socket: 0x6ae2e0 (m_Socket: 8) <0x41802950>
01      03/08/08 16:58:09.024           Unable to connect to MythTV client <0x41802950>
linuxmce@dcerouter:/usr/pluto/diskless/50/var/log/pluto$
linuxmce@dcerouter:/usr/pluto/diskless/50/var/log/pluto$         

l

finsdown

  • Veteran
  • ***
  • Posts: 54
    • View Profile
I rebuilt my CORE from scratch and this problem disappeared with new install.  The only differences was I chose to not save any settings (DL DVD upgrade) and I made sure DHCP was enabled on my external router before starting.  I have found that the install process needs DHCP to properly set the IP address on the external Interface card, and then will have internet access to download updates during the installation.   


Zener

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #3 on: August 20, 2008, 06:25:40 pm »
I've done 3 installations recently and I get the same error in my MD's log. I'm useing RC2. The first two installations was on Laptop MD's. Everything, but MythTV works. It plays about 30sec and die's. The 3'd installation was to a desktop, but same result. Odly i did not have this problem useing 710 B4. Real sad, because I'm not looking forward redoning the whole core. Making remotes and program schedules work is a pain in LinuxMCE.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #4 on: August 20, 2008, 08:39:59 pm »
I've done 3 installations recently and I get the same error in my MD's log. I'm useing RC2. The first two installations was on Laptop MD's. Everything, but MythTV works. It plays about 30sec and die's. The 3'd installation was to a desktop, but same result. Odly i did not have this problem useing 710 B4. Real sad, because I'm not looking forward redoning the whole core. Making remotes and program schedules work is a pain in LinuxMCE.

Had you bothered to add experience and instructions to the wiki, it probably would not be such a pain to do it all again.
"Change is inevitable. Progress is optional."
-- Anonymous


Zener

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #5 on: August 21, 2008, 05:40:26 am »
Thanks for your helpfull comment Zaerc.

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #6 on: August 21, 2008, 02:05:43 pm »
Thanks for your helpfull comment Zaerc.

No, thank YOU for helping out.  ::)
"Change is inevitable. Progress is optional."
-- Anonymous


Zener

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #7 on: August 21, 2008, 03:02:21 pm »
Glad that I could be of help.  ;D

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #8 on: August 21, 2008, 09:16:42 pm »
Glad that I could be of help.  ;D
Glad to see you're enjoying your own help.  :P
"Change is inevitable. Progress is optional."
-- Anonymous


niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #9 on: August 22, 2008, 07:31:36 am »
Zener.
Glad that I could be of help.  ;D

First of all update to RC2.
danielk did a lot up updates to lmce mythtv integration a mythv internals between B4 and RC2.
Have experienced the same problems myself.


/niz23

Zener

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #10 on: August 22, 2008, 11:31:37 am »
Thanks for the reply niz23. First let me say that if spent quite a bit of time to figure out whats going wrong. Sadly I'm at work, and can't include logs, but in short these are my findings:

1) I am useing RC2. 0710 B4 actually worked for me. Its only after installing RC2 that I have this problem.

2) I have the core/hydred plus the one diskless MD. The mythtv problem exists on the diskless MD.

3) If i go to KDE, and start mythfrontend, it it plays fine. So the problem is not Mythtv related.

4) The MythTV_Player.log actually complains that it is unable to comunicate with mythfrontend. I've verified this. (within the 45 seconds it displays mythtv, i can't go to ie. recordings via the orbitor) So after a period of time, Mythtv_Player actually kills mythfrontend.

01      03/08/08 16:58:05.980           Failed initial communications with Mythfrontend. <0x40800950>
01      03/08/08 16:58:05.983           Killed Mythfrontend. <0x40800950>

5) I added logging to mythfrontend, to both the core/hydred and the diskless MD and compared the outputs. There was only one difference: In the core/hydred log, it talks about having sucsessfully established a network connection. This does not happen on the diskless MD. I think this is where Mythtv_Player and mythfrontend or rather mythfrontend.real links up.

6) I looked at the Mythtv_Plugin on both the Hydred and diskless (WebAdmin), and everything looks correct.

7) At some stage I thought it might be firewall related, but can't find anything to that effect. I turned the firewall off on the core, but that made no diffrence.

So my question is, why would Mythtv_Player talk to mythfrontend on the core/hydred, but it won't on the Diskless MD?

Any suggestions are welcome, since like I've said before, I'm not in the mood to redo the core.
(Installation / Get remotes working - receiver and blaster / Get mythtv channels up and running - manual action for DSTV / Setup and configure X10 / redo all senerios / Copy across all media / etc)

I can post logs tonight if needed.

Regards

freymann

  • Douchebag
  • Guru
  • *
  • Posts: 380
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #11 on: August 22, 2008, 02:08:11 pm »
Both my MD's will automatically exit from MythTV after about 45 seconds every time.  This does not happen on the hybrid/core. If I run mythfrontend from the KDE desktop, I do not have this problem.  I've pasted the log below from one of my MDs.  Has anyone else seen this happen with 0710B4?

I've had similar issues with my setup. Read my thread here:

http://forum.linuxmce.org/index.php?topic=5602.msg32802#msg32802

I never get to the bottom of it. If I go to the KDE Desktop and fire up MythFrontEnd, everything works fine. If I go to TV through the LMCE menu, it gets to the MythTV Menu and stops. I can manually press Enter to start watching TV but then LMCE kills Myth in less than a minute.

This is an issue that needs to be looked into.

Last night, I blew away two test MD's in the web admin, and fired up my Dell Notebook and had it boot over the network and become a MD (again). Sure enough, everything works fine except MythTV.

I was thinking about buying a new computer for the master-bedroom, so we could have a fully functioning LMCE system in there, but I don't see that happening at the moment. The wife says she is happy with the little VIA EPIA running MythBuntu 7.10. If I tossed in a nice new shiny box that forced her to go to the KDE Desktop, then menu around and load MythTV to get to TV, then reactivate the Orbiter for video playback.... I'd never hear the end of it!

Same goes for my office. I have the same setup in there. Updating the computer would result in the same thing.

That is one thing that has been bugging me... (running two LMCE boxes and hanging two Mythbuntu 7.10 boxes off of it). I'd much rather go LMCE all around.

niz23

  • Guru
  • ****
  • Posts: 361
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #12 on: August 22, 2008, 04:21:07 pm »
Zener.
Thanks for the reply niz23. First let me say that if spent quite a bit of time to figure out whats going wrong. Sadly I'm at work, and can't include logs, but in short these are my findings:

1) I am useing RC2. 0710 B4 actually worked for me. Its only after installing RC2 that I have this problem.

2) I have the core/hydred plus the one diskless MD. The mythtv problem exists on the diskless MD.

3) If i go to KDE, and start mythfrontend, it it plays fine. So the problem is not Mythtv related.

4) The MythTV_Player.log actually complains that it is unable to comunicate with mythfrontend. I've verified this. (within the 45 seconds it displays mythtv, i can't go to ie. recordings via the orbitor) So after a period of time, Mythtv_Player actually kills mythfrontend.

01      03/08/08 16:58:05.980           Failed initial communications with Mythfrontend. <0x40800950>
01      03/08/08 16:58:05.983           Killed Mythfrontend. <0x40800950>

5) I added logging to mythfrontend, to both the core/hydred and the diskless MD and compared the outputs. There was only one difference: In the core/hydred log, it talks about having sucsessfully established a network connection. This does not happen on the diskless MD. I think this is where Mythtv_Player and mythfrontend or rather mythfrontend.real links up.

6) I looked at the Mythtv_Plugin on both the Hydred and diskless (WebAdmin), and everything looks correct.

7) At some stage I thought it might be firewall related, but can't find anything to that effect. I turned the firewall off on the core, but that made no diffrence.

So my question is, why would Mythtv_Player talk to mythfrontend on the core/hydred, but it won't on the Diskless MD?

Any suggestions are welcome, since like I've said before, I'm not in the mood to redo the core.
(Installation / Get remotes working - receiver and blaster / Get mythtv channels up and running - manual action for DSTV / Setup and configure X10 / redo all senerios / Copy across all media / etc)

I can post logs tonight if needed.

Regards

I was under the impression that you hadn´t tried RC2.
That´s why I repsonded as I did.

I suggest you talk to danielk22. He´s one of the guys that develops mythtv and lmce.
You most likely will find him on irc at UTC+6 +/- some time.

My experience with myth became more like a fight. Mythtv won. With mythbuntu 7.10 or 8.04 it worked fine.
But under lmce it just didn´t work out. At least on my setup. Happauge nova 500, DVB-T on AMD64.

I´m waiting for the enhanced vdr integration. It is probably better suited for use here in europe.

/niz23

Zener

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #13 on: August 22, 2008, 06:26:56 pm »
Thanks niz23, I'll try and get hold of him.

freymann: Sad to c that your problem is outstanding so long... All I can guess is that only a few people are useing Mythtv and/or or problem is very unique. Anyway I won't stress about the plugin problem, both the dcerouter and moon's mythfrontend log has the same error message. See: http://www.mythtv.org/pipermail/mythtv-users/2004-November/062874.html

Here's the logs:

First for dcerouter -

MythTV_Player.log
Quote
05   08/22/08 7:35:33.918      Going to send command query location <0xb7835b90>
05   08/22/08 7:35:34.374      ========== Before mythtv prompt <0xb7835b90>
05   08/22/08 7:35:34.374      ========== After mythtv promt <0xb7835b90>
05   08/22/08 7:35:34.374      ========== Command is sent <0xb7835b90>
05   08/22/08 7:35:34.935      ========== Got the answer:  Playback LiveTV 01:35:27 of 01:35:33 1x 1017 2008-08-22T06:00:00 <0xb7835b90>
05   08/22/08 7:35:34.935      Myth Responded: Playback LiveTV 01:35:27 of 01:35:33 1x 1017 2008-08-22T06:00:00 <0xb7835b90>
05   08/22/08 7:35:39.934      Going to send command query location <0xb7835b90>
05   08/22/08 7:35:39.934      ========== Before mythtv prompt <0xb7835b90>
05   08/22/08 7:35:39.934      ========== After mythtv promt <0xb7835b90>
05   08/22/08 7:35:39.934      ========== Command is sent <0xb7835b90>
05   08/22/08 7:35:39.975      ========== Got the answer:  Playback LiveTV 01:35:33 of 01:35:38 1x 1017 2008-08-22T06:00:00 <0xb7835b90>
05   08/22/08 7:35:39.975      Myth Responded: Playback LiveTV 01:35:33 of 01:35:38 1x 1017 2008-08-22T06:00:00

mythfrontend.log
Quote
2008-08-21 16:46:20.898 Overriding GUI, width=800, height=600 at 0,0
2008-08-21 16:46:20.898 Setting 'RunFrontendInWindow' being forced to '1'
2008-08-21 16:46:20.900 Current Schema Version: 1160
2008-08-21 16:46:20.909 mythfrontend version: 0.20.20070821-1 www.mythtv.org
2008-08-21 16:46:20.909 Enabled verbose msgs:  important general
2008-08-21 16:46:21.720 Switching to square mode (G.A.N.T.)
2008-08-21 16:46:21.803 Using the Qt painter
mythtv: could not open config file /root/.mythtv/lircrc
mythtv: No such file or directory
Failed to read lirc config /root/.mythtv/lircrc for mythtv
2008-08-21 16:46:22.030 Joystick disabled.
2008-08-21 16:46:22.448 Loading from: /usr/share/mythtv/themes/G.A.N.T./base.xml
2008-08-21 16:46:22.515 Loading from: /usr/share/mythtv/themes/default/base.xml
2008-08-21 16:46:22.673 Registering Internal as a media playback plugin.
/usr/lib/mythtv/plugins/liblibmythfrontend.so: cannot open shared object file: No such file or directory
2008-08-21 16:46:22.678 MythPlugin::Init() dlerror:
2008-08-21 16:46:22.678 Unable to initialize plugin 'mythfrontend'.
2008-08-21 16:46:22.678 Unable to run plugin 'mythfrontend': not initialized
/usr/lib/mythtv/plugins/liblibmythmythfrontend.so: cannot open shared object file: No such file or directory
2008-08-21 16:46:22.678 MythPlugin::Init() dlerror:
2008-08-21 16:46:22.678 Unable to initialize plugin 'mythmythfrontend'.
2008-08-21 16:46:22.678 Unable to run plugin 'mythmythfrontend': not initialized
2008-08-21 16:46:22.682 NetworkControl: Listening for remote connections on port 10001
2008-08-21 16:46:23.797 NetworkControl: New connection established. (23)
2008-08-21 16:46:23.845 New DB connection, total: 2
2008-08-21 16:46:23.846 Connected to database 'mythconverg' at host: localhost
2008-08-21 16:46:23.889 Connecting to backend server: 192.168.80.1:6543 (try 1 of 5)
2008-08-21 16:46:23.890 Using protocol version 31
2008-08-21 16:46:23.906 TV: Attempting to change from None to WatchingLiveTV
2008-08-21 16:46:23.910 Using protocol version 31
2008-08-21 16:46:29.225 AFD: Opened codec 0xb1943b10, id(MPEG2VIDEO) type(Video)
2008-08-21 16:46:29.242 AFD: Opened codec 0xb1943f10, id(MP2) type(Audio)
2008-08-21 16:46:29.304 Opening ALSA audio device 'default'.
2008-08-21 16:46:29.404 VideoOutputXv: XvMCTex: Init failed
2008-08-21 16:46:29.431 VideoOutputXv: XVideo Adaptor Name: 'NV17 Video Texture'
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  140
  Minor opcode:  14
  Resource id:  0x1ae
2008-08-21 16:46:30.351 TV: Changing from None to WatchingLiveTV
2008-08-21 16:46:30.354 New DB connection, total: 3
2008-08-21 16:46:30.355 Connected to database 'mythconverg' at host: localhost
2008-08-21 16:46:30.361 New DB connection, total: 4
2008-08-21 16:46:30.361 Using realtime priority.
2008-08-21 16:46:30.362 Connected to database 'mythconverg' at host: localhost
2008-08-21 16:46:30.366 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:46:30.471 Video timing method: USleep with busy wait
2008-08-21 16:46:35.401 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:46:40.454 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:46:45.559 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:46:50.628 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:46:55.696 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:47:00.745 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:47:05.818 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:47:10.869 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:47:15.901 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:47:20.934 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:47:25.988 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:47:31.064 TV: ProcessNetworkControlCommand(NETWORK_CONTROL QUERY POSITION)
2008-08-21 16:47:33.934 TV: ProcessNetworkControlCommand(NETWORK_CONTROL CHANID 1036)

Everything working.

Now the moon:

MythTV_Player.log
Quote
05   08/22/08 5:34:27.300      MythTV_Player::pollMythStatus no jump livetv  <0xb7817b90>
05   08/22/08 5:34:27.400      Going to send command jump livetv <0xb7817b90>
05   08/22/08 5:34:28.400      Connect() failed, Error Code 111 (Connection refused)) <0xb7817b90>
05   08/22/08 5:34:29.400      Connect() failed, Error Code 111 (Connection refused)) <0xb7817b90>
05   08/22/08 5:34:30.400      Connect() failed, Error Code 111 (Connection refused)) <0xb7817b90>
05   08/22/08 5:34:30.400      ClientSocket::Connect() not successful <0xb7817b90>
05   08/22/08 5:34:30.400      void ClientSocket::Disconnect() on this socket: 0x8097e30 (m_Socket: 8) <0xb7817b90>
01   08/22/08 5:34:30.400      Unable to connect to MythTV client <0xb7817b90>
05   08/22/08 5:34:30.400      MythTV_Player::pollMythStatus no jump livetv  <0xb7817b90>
01   08/22/08 5:34:30.401      Failed initial communications with Mythfrontend. <0xb7817b90>
01   08/22/08 5:34:30.412      Killed Mythfrontend. <0xb7817b90>
05   08/22/08 5:34:30.416      Going to send command quit <0xb6815b90>
05   08/22/08 5:34:31.416      Connect() failed, Error Code 111 (Connection refused)) <0xb6815b90>
05   08/22/08 5:34:32.416      Connect() failed, Error Code 111 (Connection refused)) <0xb6815b90>
05   08/22/08 5:34:33.416      Connect() failed, Error Code 111 (Connection refused)) <0xb6815b90>
05   08/22/08 5:34:33.416      ClientSocket::Connect() not successful <0xb6815b90>
05   08/22/08 5:34:33.416      void ClientSocket::Disconnect() on this socket: 0x80bdde0 (m_Socket: 8) <0xb6815b90>
01   08/22/08 5:34:33.416      Unable to connect to MythTV client <0xb6815b90>

mythfrontend.log
Quote
2008-08-21 16:33:09.760 Overriding GUI, width=640, height=480 at 0,0
2008-08-21 16:33:09.760 Setting 'RunFrontendInWindow' being forced to '1'
2008-08-21 16:33:09.761 Current Schema Version: 1160
2008-08-21 16:33:09.772 mythfrontend version: 0.20.20070821-1 www.mythtv.org
2008-08-21 16:33:09.772 Enabled verbose msgs:  important general
2008-08-21 16:33:10.262 Switching to square mode (G.A.N.T.)
2008-08-21 16:33:10.291 Using the Qt painter
mythtv: could not connect to socket
mythtv: No such file or directory
lirc_init failed for mythtv, see preceding messages
2008-08-21 16:33:10.980 Joystick disabled.
2008-08-21 16:33:11.657 Loading from: /usr/share/mythtv/themes/G.A.N.T./base.xml
2008-08-21 16:33:11.690 Loading from: /usr/share/mythtv/themes/default/base.xml
2008-08-21 16:33:11.781 Registering Internal as a media playback plugin.
/usr/lib/mythtv/plugins/liblibmythfrontend.so: cannot open shared object file: No such file or directory
2008-08-21 16:33:11.786 MythPlugin::Init() dlerror:
2008-08-21 16:33:11.787 Unable to initialize plugin 'mythfrontend'.
2008-08-21 16:33:11.787 Unable to run plugin 'mythfrontend': not initialized
/usr/lib/mythtv/plugins/liblibmythmythfrontend.so: cannot open shared object file: No such file or directory
2008-08-21 16:33:11.787 MythPlugin::Init() dlerror:
2008-08-21 16:33:11.787 Unable to initialize plugin 'mythmythfrontend'.
2008-08-21 16:33:11.787 Unable to run plugin 'mythmythfrontend': not initialized
2008-08-21 16:35:24.243 Current Schema Version: 1160
2008-08-21 16:35:24.253 mythfrontend version: 0.20.20070821-1 www.mythtv.org
2008-08-21 16:35:24.254 Enabled verbose msgs:  important general
2008-08-21 16:35:24.712 Total desktop dim: 640x480, with 1 screen.
2008-08-21 16:35:24.715 Using screen 0, 640x480 at 0,0
2008-08-21 16:35:24.716 Switching to square mode (G.A.N.T.)
2008-08-21 16:35:24.762 Using the Qt painter
mythtv: could not connect to socket
mythtv: No such file or directory
lirc_init failed for mythtv, see preceding messages
2008-08-21 16:35:25.672 Joystick disabled.
2008-08-21 16:35:26.238 Loading from: /usr/share/mythtv/themes/G.A.N.T./base.xml
2008-08-21 16:35:26.272 Loading from: /usr/share/mythtv/themes/default/base.xml
2008-08-21 16:35:26.387 Registering Internal as a media playback plugin.
2008-08-21 16:35:28.293 New DB connection, total: 2
2008-08-21 16:35:28.295 Connected to database 'mythconverg' at host: dcerouter
2008-08-21 16:35:28.359 Connecting to backend server: 192.168.80.1:6543 (try 1 of 5)
2008-08-21 16:35:28.361 Using protocol version 31
2008-08-21 16:35:28.375 TV: Attempting to change from None to WatchingLiveTV
2008-08-21 16:35:28.378 Using protocol version 31
2008-08-21 16:35:33.758 AFD: Opened codec 0x83caa90, id(MPEG2VIDEO) type(Video)
2008-08-21 16:35:33.779 AFD: Opened codec 0x83cade0, id(MP2) type(Audio)
2008-08-21 16:35:33.875 Opening ALSA audio device 'default'.
2008-08-21 16:35:33.965 VideoOutputXv: XvMCTex: Init failed
2008-08-21 16:35:33.966 VideoOutputXv: XVideo Adaptor Name: 'NV17 Video Texture'
X Error: BadMatch (invalid parameter attributes) 8
  Major opcode:  141
  Minor opcode:  14
  Resource id:  0x1b7
2008-08-21 16:35:34.694 TV: Changing from None to WatchingLiveTV

The difference is the "NetworkControl" stuff. I'm also useing amd's. Will try a i386 diskless to see if it makes a diffrence.



Zener

  • Newbie
  • *
  • Posts: 8
    • View Profile
Re: (0710 B4) MythTV exits automatically in less than 1 minute after start
« Reply #14 on: August 24, 2008, 06:31:22 am »
I took the plunge and reinstalled the core. MythTV now works on the diskless MD.  8)