Author Topic: VDR not working on a MD  (Read 5656 times)

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: VDR not working on a MD
« Reply #15 on: January 23, 2008, 11:45:21 pm »
@Rafik:
your are right with your hot-hack to get that working on a md.
but you will get always the same pic and osd on md and hybrid with that method, because it uses piping or broadcast-stream of the hybrid.

thats not the concept behind a server-client version having the same screens at the same time.
it's not that easy to get all vdr-standard features, extended with plugins and of course lmce-specific dce-functions under one hood....

believe me - i did the whole vdr integration till now and we are still working on a real server-client lmce version
burgiman


It's a hell of a start, really nice work!  If there is something I could do to help then please let me know.

I finally got DVB-T going thanks to a boosted antenna and the VDR integration, kaffeine works as well for me now, but eventhough MythTV managed to scan the channels it still couldn't get a signal...  ???  Another nice thing was that VDR works on the ATI X1250 chipset which MythTV doesn't like at all (except that now after a few days the channel-interface has gone black on that MD for some reason).  Still not entirely sure how the interface works but it's very nicely integrated and I have managed to make a few automatic recordings already.

Thanks.

PS. try adding $* behind "dcerouter" in rafik24's hack, looks almost for real now ;)
"Change is inevitable. Progress is optional."
-- Anonymous


chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: VDR not working on a MD
« Reply #16 on: March 06, 2008, 11:04:46 am »
PS. try adding $* behind "dcerouter" in rafik24's hack, looks almost for real now ;)

so,

plutovdr dcerouter $*

?

What does this achieve?

Thanks,

Chris


Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: VDR not working on a MD
« Reply #17 on: March 06, 2008, 03:20:10 pm »
PS. try adding $* behind "dcerouter" in rafik24's hack, looks almost for real now ;)

so,

plutovdr dcerouter $*

?

What does this achieve?

Thanks,

Chris


No, in the alternative wrapper, so that it becomes:
Code: [Select]
#!/bin/sh
plutovdr.orig dcerouter $* 2>/dev/null 1>/dev/null

It passes all the original arguments on, so that "plutovdr.orig dcerouter" gets called with whatever arguments the alternative "plutovdr" wrapper was called.
"Change is inevitable. Progress is optional."
-- Anonymous


chrisbirkinshaw

  • Guru
  • ****
  • Posts: 431
    • View Profile
Re: VDR not working on a MD
« Reply #18 on: March 06, 2008, 07:28:50 pm »
Ah, ok. My bash scripting skills are a little rusty!

What does it actually achieve though in terms of the user experience? Seems ok without? (well, apart from being unable to change channel from an MD!)





nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: VDR not working on a MD
« Reply #19 on: March 08, 2008, 10:24:36 pm »
Tried this solution to watch TV on MD. Works fine but you cannot control it. Even switch off. Maybe I ask stupid question but why streamdev plugin cannot be used on MD?
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru