Author Topic: Orbiter on N800 (OS2008)  (Read 7389 times)

avajon

  • Veteran
  • ***
  • Posts: 120
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #15 on: December 27, 2007, 12:44:41 pm »

Great! Unfortunately, I don't have MythTV or VDR setup in my home yet (I'm going to do it soon). So, I cannot test EPG functionality. Is it available on the XP or web Orbiters? In case of yes, what do you see on N800?

no, i don't think it is available on the XP Orbiters. But it would be great - because since i have mythtv i don't zap through all channels.

ciao
avajon

Correct... the Windows Orbiter and the N800 Orbiter are just that... Orbiters. They have no local lmce integrated media playing capabilities.

yes. but i don't want to watch tv on the N800 i only want to see whats playing on tv (EPG).

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Orbiter on N800 (OS2008)
« Reply #16 on: December 27, 2007, 05:00:58 pm »

Great! Unfortunately, I don't have MythTV or VDR setup in my home yet (I'm going to do it soon). So, I cannot test EPG functionality. Is it available on the XP or web Orbiters? In case of yes, what do you see on N800?

no, i don't think it is available on the XP Orbiters. But it would be great - because since i have mythtv i don't zap through all channels.

ciao
avajon

Correct... the Windows Orbiter and the N800 Orbiter are just that... Orbiters. They have no local lmce integrated media playing capabilities.

yes. but i don't want to watch tv on the N800 i only want to see whats playing on tv (EPG).

If your N800 or Windows Orbiter is being used to remotely control your Core then you can display the EPG just as you can if you are controlling the Hybrid's Orbiter directly.
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

ace195

  • Regular Poster
  • **
  • Posts: 17
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #17 on: December 27, 2007, 05:08:21 pm »
Although it would be nice to be able to watch TV or stored media from the N800

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #18 on: December 27, 2007, 06:27:56 pm »
Although it would be nice to be able to watch TV or stored media from the N800

As I already mentioned on this forum N800 provides a client for MythTV (https://garage.maemo.org/projects/mtv/) which allows to watch liveTV or recorded video. So, the problem is to launch maemomyth on the N800. But I have no idea how to do that and how complicated that feature. Maybe Andrew can clarify it.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

diamondcobra

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #19 on: December 29, 2007, 05:29:44 pm »
I just got my n800 a couple days ago and upgraded it to os2008.  I went to the garage site to download the orbiter files and dependencies but most of the debs say "Unable to install [filename].  Incompatible application package."  The only one that worked for me under os2008 dependencies was libusb1.0.1.12.armel.deb.

Also, I see a 0710 tar.gz file there - can I install that over the air, or do I need to extract it on my pc and then copy it to the n800 to install?

Thanks in advance


nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #20 on: December 29, 2007, 06:22:43 pm »
Please, use dependencies from that page https://garage.maemo.org/frs/?group_id=162, but section OS2008. All those packages were tested on the several N800 with the latest OS2008. Also there is an Orbiter 0710 package for OS2008 - https://garage.maemo.org/frs/download.php/2956/lmceorbiter-os2008-0704-01_armel.deb. For 0710 the package is not ready yet. But you can download tar file to your device, run xterm, untar it somewhere:
Code: [Select]
cd /home/user/
mkdir work
tar vzxf lmce-0710-os2008-251207.tar.gz
cd lmce-0710-os2008-251207
export LD_LIBRARY_PATH=$LD_LIBRARY_PATH:./lib
./bin/Orbiter -r <core IP> -d <orbiter ID>
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #21 on: December 29, 2007, 06:31:38 pm »
will that work on the 770 too?

-Thom

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #22 on: December 31, 2007, 08:35:34 am »
will that work on the 770 too?

I'll build the Orbiter for OS2006/OS2007 soon for sure. But that one is only for OS2008.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

diamondcobra

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #23 on: January 02, 2008, 08:48:30 pm »
Has anyone else tried the dependencies?  Those are the ones I tried but I am getting the same error - they are under os2008 dependencies from 2007-11-20 19:19.  Is my n800 retarded or am I?

I will wait for the 0710 package - thanks so much for working on it.  Any idea when it might be up?

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #24 on: January 03, 2008, 10:54:07 am »
Has anyone else tried the dependencies?  Those are the ones I tried but I am getting the same error - they are under os2008 dependencies from 2007-11-20 19:19.  Is my n800 retarded or am I?
I will wait for the 0710 package - thanks so much for working on it.  Any idea when it might be up?

I'll check dependencies tonight once again. The package for 0710 will be uploaded to the garage after lunch.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #25 on: January 03, 2008, 11:02:14 am »
Has anyone else tried the dependencies?  Those are the ones I tried but I am getting the same error - they are under os2008 dependencies from 2007-11-20 19:19.  Is my n800 retarded or am I?

Did you switch your device in the RedPill mode? Please, do it http://maemo.org/community/wiki/ApplicationManagerRedPillMode and try install the packages again.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: Orbiter on N800 (OS2008)
« Reply #26 on: January 03, 2008, 05:29:53 pm »
I just uploaded LMCE 0710 packages for OS2008 and OS2007 on Maemo garage. Feel free to test them and post here all found bugs and problems.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Orbiter on N800 (OS2008)
« Reply #27 on: January 05, 2008, 10:15:09 pm »
I just uploaded LMCE 0710 packages for OS2008 and OS2007 on Maemo garage. Feel free to test them and post here all found bugs and problems.

Hi Michael,

Just a few quick bits of feedback based on the install and about 30 mins of usage (our N800 has gone home for weekend with one of my coleagues!)

- The install was very smooth using the 0710/OS2008 .deb... I just pointed the N800 browser at your Maemo Garage page for the Orbiter and click/installed direct from the page. That took maybe 5 mins... and then i had to download the ms fonts from the Core (thats still a little messy... maybe a quick script to copy them over from the core would be the way to go)

Now a few observations after using the 0710 Orbiter;

- The opening screen of the 0710 Orbiter still states is 0704
- The tick box in the opening screen seems to loose its state when you go back to this screen.
- Some button in the main menu seem to be drawn highlighted in a pale/yellow-green colour when the main menu screen is redrawn
- Speed and stability of connection was excellent and much better than under 0704 Orbiter on N770 running OS2006

I'll post some more feedback on Monday after getting my colleagues experiences from over the weekend.

Well done another very nice release.

Thanks

Andrew
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk

diamondcobra

  • Regular Poster
  • **
  • Posts: 28
    • View Profile
Re: Orbiter on N800 (OS2008)
« Reply #28 on: January 06, 2008, 06:10:07 pm »
Nite_man,

Thanks for your help.  I guess my problem was not being in redpill mode since everything installed this time.  My core is down right now and its telling me that I need libxmu6 and libsdl-ttf2.0-0 to install the lmceorbiter-os2008-0710-01armel.deb, but I think i ought to be able to work that out.

Thanks again for your help, and for releasing these packages!

totallymaxed

  • LinuxMCE God
  • ****
  • Posts: 4360
  • Smart Home Consulting
    • View Profile
    • Dianemo - at home with technology
Re: Orbiter on N800 (OS2008)
« Reply #29 on: January 06, 2008, 06:15:50 pm »
I just uploaded LMCE 0710 packages for OS2008 and OS2007 on Maemo garage. Feel free to test them and post here all found bugs and problems.

By the way the LMCE-0710 deb for OS2008 works fine on lmce-0704 Core's too... flipping back an forth just requires re-connecting to the other Core's AP and then a new device number entered into the initial screen... smooth as glass :-)
Andy Herron,
Convergent Home Technologies Ltd
United Kingdom

Read My Blog; http://ellipticalcurve.com

Contact me for Smart Home consulting advice here;
@herron on Twitter, totallymaxed+consulting@gmail.com via email or PM me here.

Get a Dianemo S License: http://forum.linuxmce.org/index.php?topic=8880.0
iOS Orbiter: http://wiki.linuxmce.org/index.php/Dianemo_iOS_Orbiter
Follow us on Facebook: https://www.facebook.com/pages/Dianemo-Home-Automation/226019387454465

Sales & Info:
http://www.dianemo.co.uk