Author Topic: LCD working on Silverstone case  (Read 5330 times)

chamo

  • Newbie
  • *
  • Posts: 6
    • View Profile
LCD working on Silverstone case
« on: November 24, 2007, 01:39:44 pm »
Hello, I`m wondering if anybody has managed to get the LCD display working on a Silverstone HTPC case. Apparently for what I`ve read this is possible on the LC10M model (http://www.silverstonetek.com/products/p_contents.php?pno=lc10m&area=usa)

I also found these helpful links with plenty of info on how to get the LCD working.

http://www.checkthisshitout.com/post/33/
http://www.mythtv.org/wiki/index.php/Imon
http://venky.ws/projects/imon/
http://www.cwlinux.com/products/index.php

Unfortunely I don`t have a Silverstone case yet to try this, does any one has any inputs on this?

Thanks!

isaidi

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: LCD working on Silverstone case
« Reply #1 on: January 01, 2008, 01:01:09 pm »
Chamo..
have you had any luck with this since your post ? did you get your case yet ?

I have an Antec Veris Fusion  HTPC case which uses the same IMON/Soundgraph VFD/LCD with an IR reciever that i'd like to get working with my LinuxMCE box.

Code: [Select]
>lsusb | grep iMON
>Bus 001 Device 006: ID 15c2:ffdc SoundGraph Inc. iMON PAD Remote Controller

I am afraid of tampering with my box, as i already broke it once by installing apps or somthing... it is running perfect now, i would just like to get the VFD/LCD showing something and the Volume Knob working..

Found this..
http://wiki.linuxmce.org/index.php/IMON_PAD
but i don't actually have the remote... just need the VFD/LCD working and the IR Reliever, it seems like LIRC actual includes iMON since Version 0.7.1

chamo

  • Newbie
  • *
  • Posts: 6
    • View Profile
Re: LCD working on Silverstone case
« Reply #2 on: January 26, 2008, 01:14:11 am »
isaidi

I haven't the time (money) to get the case. I'd also like to see if anybody has had luck getting this working before I spend the money on it.  Thanks for the Imon Pad link, there's some helpful information there that could get this working.

It's interesting that nobody has got this to work yet  :(

I'll keep researching and posting more info on this topic.


danielmayer

  • Regular Poster
  • **
  • Posts: 35
    • View Profile
Re: LCD working on Silverstone case
« Reply #3 on: January 26, 2008, 12:30:27 pm »
Hey, guys,
of course IMON/VFD runs fine on Kubuntu 7.xx. I don't have a PC running a running linux currently, so I can only give hints: You need to have installed the lcdproc and lcdd. I remember them being installed already with LMCE. Search for the /etc/lcdproc.conf and /etc/lcdd.conf and search for "driver= ". You should write "driver=IMON". It *may* be that the driver doesn't support IMON, if it had been disabled when compiling. But just check that by trying it ;)
I don't remember in which file that was, but I think in lcdd.conf (kind of a server daemon, while lcdproc is "user" client).
If the driver doesn't support IMON, you'll have to download/install the sources and compile and install it by yourself *with* the "IMON" driver. The readme of the driver tells how to do this.
Shouldn't be necessary though, I think I got it running without recompling.

I'll install my htpc during next week, so I can give more advice in a few days.
Server: Ubuntu 10.04A2, 1xL5520 on Asus Z8-PED12X, 12GB, 300GB U320Raid0, 8TB HDDs@Adaptec 2820SA + 8TB@Perc 5/E. LMCE via KVM (running); other VMs;
Workstation: W7x64, 2xOpteron 2376, 24GB, 146 GB-SSD-Raid0, ATI 4850
MD: Asrock nv630i, 2GB

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: LCD working on Silverstone case
« Reply #4 on: January 27, 2008, 04:36:05 pm »
I have two Silverstone cases: LC20M and LC16M. I installed for both remote and LCD successful (ou can find some info im my blog - ttp://smart-home-blog.com/writes/configure-imon-padvfd-in-plutohome). But note that the LCE cannot display LMCE info. It can be configured to work with MythTV or VDR. It'd be great to add native support of iMON remote and LCD in LMCE 0710 since Silverstone cases are very popular and look nice as HTPC.
« Last Edit: January 27, 2008, 04:48:54 pm by nite_man »
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

colinjones

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 3003
    • View Profile
Re: LCD working on Silverstone case
« Reply #5 on: February 02, 2008, 01:52:21 am »
I have two Silverstone cases: LC20M and LC16M. I installed for both remote and LCD successful (ou can find some info im my blog - ttp://smart-home-blog.com/writes/configure-imon-padvfd-in-plutohome). But note that the LCE cannot display LMCE info. It can be configured to work with MythTV or VDR. It'd be great to add native support of iMON remote and LCD in LMCE 0710 since Silverstone cases are very popular and look nice as HTPC.

Michael - you mention VDR as well, but your blog only talks about Myth. Any chance you could update the instructions for VDR? :)

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: LCD working on Silverstone case
« Reply #6 on: February 10, 2008, 09:00:09 pm »

Quote
Michael - you mention VDR as well, but your blog only talks about Myth. Any chance you could update the instructions for VDR?

Will try it as soon as setup my satellite dish :)
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: LCD working on Silverstone case
« Reply #7 on: March 03, 2008, 11:19:24 pm »
Quote
Michael - you mention VDR as well, but your blog only talks about Myth. Any chance you could update the instructions for VDR?

Did it - http://tinyurl.com/2hqask. it works fine.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: LCD working on Silverstone case
« Reply #8 on: March 05, 2008, 02:22:15 pm »

But note that the LCE cannot display LMCE info.

I have been trying out an old driver on the 0710b3 that actually sends LMCE info to a vfd screen (mins an imon on a thermaltake bach case). When LMCE is idle the screen shows an scrolling 'LMCE' and time/date. Media info is sent to the screen as scrolling Title and time of play below.

***This is not my driver. I was given it by user 'zz9pa'. So all thanks to him! All I have done is try get it to work***

The only prob with it at the moment is that I can't get it to start on system boot.
Will have a go at making an init script for it later.

If you fancy having a go at this driver send me a pm with an email so I can forward it to you.
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: LCD working on Silverstone case
« Reply #9 on: March 05, 2008, 09:50:12 pm »
ok, No luck getting the lcd driver to run on boot...

The driver depends on LMCE having a vfd device setup, and so it appears that running an init script to start the driver (or a cronjob on boot) doesn't work because LMCE needs to be running first (and init scripts run before LMCE).

Is there a way to run a script from LMCE? i.e. copy the script somewhere in the vfd device template??
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

bulek

  • Administrator
  • wants to work for LinuxMCE
  • *****
  • Posts: 886
  • Living with LMCE
    • View Profile
Re: LCD working on Silverstone case
« Reply #10 on: March 06, 2008, 03:39:25 am »
ok, No luck getting the lcd driver to run on boot...

The driver depends on LMCE having a vfd device setup, and so it appears that running an init script to start the driver (or a cronjob on boot) doesn't work because LMCE needs to be running first (and init scripts run before LMCE).

Is there a way to run a script from LMCE? i.e. copy the script somewhere in the vfd device template??

There is a field to specify binary command line to start device -  not sure if it appears for you ?

Regards,

Bulek.
Thanks in advance,

regards,

Bulek.

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: LCD working on Silverstone case
« Reply #11 on: March 06, 2008, 09:47:22 am »
The start of LCD daemon can be disabled in the /etc/init.d/LCDd script or in the its config /etc/LCDd.conf I suspect.
BTW, it's a good to have iMON and LMCE working together!
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: LCD working on Silverstone case
« Reply #12 on: March 06, 2008, 12:21:42 pm »
Ok, the driver is here (again credit to zz9pa) -->

http://www.aubit.com/transfer/lcd.tgz


Just download it, and untar.
Go into the folder and 'make'

There is a pdf in the folder explaining the device setup in LMCE and the lcd_direct startup command (run in konsole)

You need to have lcdproc running (should be displaying the lcdproc screen on your vfd) or you will get an access denied error

I changed the LCDd.conf for lcd proc -> un-hash the 'server screen' option and make sure it is set to 'no'
And delete the number next to the 'time for sceen to be displayed for' - this needs to be done to stop the vfd flicking between the LMCE display and the lcdproc server screen.

I also unhashed the 'goodbye message' option and deleted the bit to be displayed next to it so that the screen shuts off on shut down.

Any probs, just post.

Like I said in my prev post, I have it running fine except for getting it to start auto on boot.
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT

nite_man

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1019
  • Want to work with LinuxMCE
    • View Profile
    • Smart Home Blog
Re: LCD working on Silverstone case
« Reply #13 on: March 17, 2008, 05:17:20 pm »
I compiled and run the lcd_redirect but it displayed only date, time and caption LinuxMCE. No any events such playback video, tripped sensor etc are showed on LCD.
Michael Stepanov,
My setup: http://wiki.linuxmce.org/index.php/User:Nite_man#New_setup
Russian LinuxMCE community: http://linuxmce.ru

gazlang

  • Guru
  • ****
  • Posts: 210
    • View Profile
Re: LCD working on Silverstone case
« Reply #14 on: March 23, 2008, 11:01:17 am »
I haven't looked at this for a while.

When I run the client It displayed the date / time and LMCE caption. Then when I played a dvd it displayed the dvd title and progression time. I tried the TV but it didn't display any info for that - I wasn't too bothered as I can have the myth lcd client for that job. I didn't try any other events like tripped sensor.

I'm guessing this driver needs a lot more work, but i'm not qualified to do it :-) I haven't seen the guy who made it on the forums for a long time neither.

It would be a start if I can get the driver loading properly on boot
AMD Athlon 5800+ X2
Asus M2N-SLI-Deluxe
2x Corsair XMS6400 DDR2 512mb
Samsung 400GB SATA + 500GB SATA
nVidia GeForce 7300GT
Hauppauge Nova-T 500
Hauppauge PVR-500
Thermaltake low-noise 450w PSU
Thermaltake Bach Case w/ imon vfd
Fiire Remote
UIRT