Author Topic: Compiling LinuxMCE version of MythTV  (Read 1963 times)

dopey

  • Guru
  • ****
  • Posts: 223
    • View Profile
Compiling LinuxMCE version of MythTV
« on: August 27, 2007, 01:54:05 am »
MythTV in the source.

I wanted to at least get mythfrontend working on my Gentoo boxes. It seemed pretty straight forward to do that. I created a tar archive of the MythTV source in the LinuxMCE source. I then created an ebuild for that (actually I just modified an already existing one and copied it to an overlay with a new version number). It compiled and installed just fine.

However, it seems that the version in the source is not the same version that LinuxMCE actually uses. As soon as I ran mythfrontend it had to upgrade the database schema and then it gave me an error saying that that version of mythfrontend only supports protocol version 33, but the backend is running version 31. I verified that it is in fact compiling and installing the version in the LinuxMCE source and that it is connecting to the database on the core.

I'm sure I just missed something obvious, but I'm at a loss as to what that is...

dopey

  • Guru
  • ****
  • Posts: 223
    • View Profile
Re: Compiling LinuxMCE version of MythTV
« Reply #1 on: August 30, 2007, 03:34:22 am »
Am I the only one having this problem? Has anyone else tried yet?

karib

  • Newbie
  • *
  • Posts: 5
    • View Profile
Re: Compiling LinuxMCE version of MythTV
« Reply #2 on: August 30, 2007, 06:02:30 am »
I have a gentoo frontend connected to the core.

Try the following package:
media-tv/mythtv
     Installed versions:  0.20.1_p14146(07:02:21 08/09/07)

It's working just fine to the LinuxMCE core machine.

dopey

  • Guru
  • ****
  • Posts: 223
    • View Profile
Re: Compiling LinuxMCE version of MythTV
« Reply #3 on: August 30, 2007, 07:59:40 am »
That's good that there is a version in Gentoo that works with LinuxMCE. It solves the immediate problem of me getting a frontend on the Gentoo boxes. Thank you.

However, that doesn't solve the underlying problem of source in LinuxMCE being a different version than the provided binary.

What's really confusing is that release is actually fairly recent and I think is using protocol 33 not 31... If that's true then I will get the same error... maybe it's the binary on my core that's wrong... I'll post back once Myth is finished compiling.

Ok, that version did work for me so that means the binary installed on my core is definitely the same as on yours. It's just the myth source provided with LinuxMCE is not the same version... or maybe there's some patches somewhere that it needs that I missed?
« Last Edit: August 30, 2007, 08:27:12 am by dopey »

Zaerc

  • Alumni
  • LinuxMCE God
  • *
  • Posts: 2256
  • Department of Redundancy Department.
    • View Profile
Re: Compiling LinuxMCE version of MythTV
« Reply #4 on: August 30, 2007, 09:56:35 am »
Where are you getting this source code from exactly?
"Change is inevitable. Progress is optional."
-- Anonymous


dopey

  • Guru
  • ****
  • Posts: 223
    • View Profile
Re: Compiling LinuxMCE version of MythTV
« Reply #5 on: August 31, 2007, 08:37:41 am »
From the torrent that was released with the rest of the 0704 release.