Author Topic: The whole networking thingy!  (Read 1307 times)

Pastor

  • Veteran
  • ***
  • Posts: 58
    • View Profile
The whole networking thingy!
« on: June 21, 2007, 06:03:43 pm »
Hi

I have a lovely LMCE 1.1B install that works and looks great unfortunatly I seem to have messed up my networking and I am in a tizzy!!!! Everthing was going fine until I decided to setup a laptop for "diskless booting" via my hybrid/Core system. I could not get this to work and read about the fact that my wireless router (linksys WTGC54) has a DHCP server so I disabled this. I also swicted the ethernet cables so much going into my PC nothing seems to work I cannot get internet access and my VOIP phone cannot access a server.

Can I please confirm the order of cables. I currently have ethernet throughout the house via cat 5 cable and a switch. I connect my cable modem into an ethernet port in my bedroom and the rest of the equipment is in the attic. I have a cable comming from the switch into the "internet" port of the linksys wireless router and a cable comming from the router into the 2nd ethernet port on my PC I have also connected a cable straight from the switch into the first ethernet port on the PC. I am assuming that the first port is the internal port and the 2nd the external port? (the manual does not tell me - A8N32-SLI Deluxe motherboard with two ethernet ports on board) As I mentioned previously I have to disable DHCP networking on the router. Is this the correct configuration? I presume that I will need to leave the PC on as it will be acting as a DHCP server to use the VOIP phone etc?

I hope that the above makes sense it does to me I think!

Thanks for any help or information.


Paul

When I try to do

pixelator

  • Veteran
  • ***
  • Posts: 70
    • View Profile
Re: The whole networking thingy!
« Reply #1 on: June 21, 2007, 08:44:47 pm »
Did you enable your core to act as the DHCP server for your network after disabling it on the linksys?

Cabling should be something like:
modem > internet port on Linksys
Linksys switch port > any other switch in the house.

A set up like this would be used for a single ethernet on the core.

To use a dual ethernet on the core, you would need to connect the modem directly to the cores external port (eth0) and connect eth1 to the internal network. You also will need to set up the core as your gateway and maybe also PPPoE depending on your connection type.

You cannot connect both a external and internal network or subnet to the same switch unless you are using VLANs.
« Last Edit: June 21, 2007, 08:59:33 pm by pixelator »

cckrobinson

  • Veteran
  • ***
  • Posts: 124
    • View Profile
Re: The whole networking thingy!
« Reply #2 on: June 21, 2007, 11:00:31 pm »
Make sure that the core has the necessary ports opened for you VOIP phone.  I ran into a similar issue when I initially disabled DHCP on my router and enabled it on the Core.  My vonage phone could only make outgoing calls.  I'm using an older modem that required a special port to be open.  I had to manually tweak the network settings via the pluto admin pages.

Pastor

  • Veteran
  • ***
  • Posts: 58
    • View Profile
Re: The whole networking thingy!
« Reply #3 on: June 25, 2007, 02:10:16 pm »
Hi cckrobinson & pixelator

I have reconfigured the net working and all seems well, I have gone back to using a single ethernet port. VOIP is my next project I have the settings for my provider and I will need to setup my Siemens VOIP phone.

Thanks for the help.


Paul