Author Topic: Orbiter generation gets stuck  (Read 972 times)

chriss

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Orbiter generation gets stuck
« on: May 30, 2007, 10:35:10 pm »
Hi there,

during the last days I installed LinuxMCE stuff and somehow made it to the point where an MD boots from network. Today I changed some stuff (lights and prepared setup of mythtv) that caused the orbiters to regenerate. Now the orbiter wizard screen tells me for all orbiters "Regen status: Stage 2 of 2 - Rendering screen 97 of 259". The webpage keeps refreshing but the progress did not change for quite a long time (>1h). What's going wrong here? Any ideas?

BTW, the last entries of /var/log/pluto/orbitergen.log:
Quote
Saving /usr/pluto/orbiter/C62/2427.0.0.1581.1557_S.png
Saving /usr/pluto/orbiter/C62/2427.0.0.1582.1558_S.png
Saving /usr/pluto/orbiter/C62/2427.0.0.png
Rendering screen 2437.0.0 in orbiter: 62
Saving /usr/pluto/orbiter/C62/2437.0.0.2439.1561.png
Saving /usr/pluto/orbiter/C62/2437.0.0.2439.1563.png
Saving /usr/pluto/orbiter/C62/2437.0.0.2439.1565.png
Saving /usr/pluto/orbiter/C62/2437.0.0.2439.1567.png
Failed to render screen 2437.0.0 error: Can't create surface from FILE pointer: Error reading the PNG file.on the fly regen of 48 9 -a

I don't understand the last error. Might that be a problem with the .png-files I uploaded for my room maps?

Cheers and thanks in advance
Chris

chriss

  • Veteran
  • ***
  • Posts: 140
    • View Profile
Re: Orbiter generation gets stuck
« Reply #1 on: May 30, 2007, 10:52:00 pm »
stupid me... just need to ask the right questions. I found a corrupt graphics file for one of my rooms. After replacing it the orbiter generation worked flawlessly again. Never mind :/

/Chris