Author Topic: Installation Problem LMCE1.1Beta + Asus V7700 Geforce2 GTS/Pro - Solved  (Read 1684 times)

Cryoniq

  • Regular Poster
  • **
  • Posts: 29
    • View Profile
Edit:
It seems like LMCE doesn't do a good job changing xorg.conf. Instead, in my case with this GFX card, installed nvidia-glx-legacy drivers.
Then I changed via KDE settings panel the manufacturer and vendor to legacy, choose proprietary, and restarted the xserver.
Problem is that, those routines doesn't do a good job with the screen and monitor and it is set to 640x480 etc. That part is just either edit from own experience, or copy paste the large sections of 'Section "Montior" and 'Section "Screen" from old xorg config file (which one of course backuped before changing anything) to new xorg.conf.
Then restart xserver again. When starting Xserver a quick nvidia logo should be shown on the whole screen before login screen pops up.

Might be ghetto version to do it since I am just semi experienced Linux user that used to do slakware around 1993/94 (and a lot have changed since then), but it works and LMCE1.1 install didn't bugg me about driver change now. Just remain to be seen how the rest of the installation goes :P

Leaving my letter of problem below in case anyone search for same problem around forums:

....

Hi lads and ladettes! :)

I have a problem installing Linux MCE 1.1 Beta. Maybe it is my own fault for bringing it towards this somewhat old 1 ghz 1 gig ram box over here with a Asus V7700 Geforce 2 Pro card, but shame on me for not trying. It isn't a bad card actually, just a couple years old.

Anyway, this is what I have done:

Installed Kubuntu 7.04. Worked like a charm I might add.
NOT updated anything.
Burned the ISO's of Package and Cache CD.
Running the install script and got install icon on desktop.

So far so good :P

Then I started the install. I was asked if this was going to be used as media player or core.
I choose the first option here (I got experience from same box trying to install 1.0 on Ubuntu 6.10 whole last day before gave up. Had major problem with orbital couldn't contact route etc.).

Then I was asked, and it is here where the juicy parts come, and informed that the current nvidia driver isn't working well. In fact it told me exactly this:

Quote
The open source nv driver doesn't work well.
Replace it with Nvidia's proprietary driver?

Yes, I want it installed
No, I want to use the open source driver without 3d acceleration.

I first took it for its word and picked yes. And then I was asked to reboot my system. So I did.

Happy as I was, turned to unhappy as I was when KDE said "up yours" to me with a black screen and a blinking cursor in the upper left corner.

And I waited... and I waited... then I hit ctrl+F1, logged in and copied xorg.conf.1 over xorg.conf and rebooted.

That did the trick entering KDE.

Now I started the install again and this time I choose No on the question. Something was obviously changed and I was asked to reboot again.

So I did.. and.. it was "up myself" again :D

Overwrote xorg.conf again and rebooted and sat there for a moment trying to figure out what to do. I should of course check the log file for xorg, but I am behind a couple hours sleep from yesterday and I tried go for the admin panel and try out different drivers.. which of course failed on me the same way after I changed them.

So I came here.. and joined the party thinking I might ask for help or get some clues from other people that might had same experience or know someone with similiar or same experience.

If possible I will try edit in the log information from the failing startups in a bit. :)

Edit: One could say that the problem is pretty obvious earlier, but xorg log file smacks the confirmation by this:

Quote
(II) Setting vga for screen 0.
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(**) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(**) NVIDIA(0): Enabling RENDER acceleration
(II) NVIDIA(0): Support for GLX with the Damage and Composite X extensions is
(II) NVIDIA(0):     enabled.
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):     that there is a supported NVIDIA GPU in this system, and
(EE) NVIDIA(0):     that the NVIDIA device files have been created properly.
(EE) NVIDIA(0):     Please consult the NVIDIA README for details.
(EE) NVIDIA(0):  *** Aborting ***
(II) UnloadModule: "nvidia"
(II) UnloadModule: "ramdac"
(II) UnloadModule: "fb"
(EE) Screen(s) found, but none have a usable configuration.

Fatal server error:
no screens found

Question is what I do now. Asus V7700 Pro does have a Geforce 2 GTS GPU and it should work with that driver.
I will keep on testing and fiddling around with xorg.conf. I still think it is strange that even if I told it to leave driver and etc. alone it had to mess with it and corrupt/prevent KDE from starting up.

Anyway. Here is the current working xorg.conf file (the non working one is below it):

Quote
# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
   FontPath   "/usr/share/fonts/X11/misc"
   FontPath   "/usr/share/fonts/X11/cyrillic"
   FontPath   "/usr/share/fonts/X11/100dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/75dpi/:unscaled"
   FontPath   "/usr/share/fonts/X11/Type1"
   FontPath   "/usr/share/fonts/X11/100dpi"
   FontPath   "/usr/share/fonts/X11/75dpi"
   # path to defoma fonts
   FontPath   "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
   Load   "i2c"
   Load   "bitmap"
   Load   "ddc"
   Load   "dri"
   Load   "extmod"
   Load   "freetype"
   Load   "glx"
   Load   "int10"
   Load   "vbe"
EndSection

Section "InputDevice"
   Identifier   "Generic Keyboard"
   Driver      "kbd"
   Option      "CoreKeyboard"
   Option      "XkbRules"   "xorg"
   Option      "XkbModel"   "pc105"
   Option      "XkbLayout"   "se"
EndSection

Section "InputDevice"
   Identifier   "Configured Mouse"
   Driver      "mouse"
   Option      "CorePointer"
   Option      "Device"      "/dev/input/mice"
   Option      "Protocol"      "ImPS/2"
   Option      "ZAxisMapping"      "4 5"
   Option      "Emulate3Buttons"   "true"
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "stylus"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "stylus"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "eraser"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "eraser"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "InputDevice"
   Driver      "wacom"
   Identifier   "cursor"
   Option      "Device"   "/dev/input/wacom"
   Option      "Type"      "cursor"
   Option      "ForceDevice"   "ISDV4"      # Tablet PC ONLY
EndSection

Section "Device"
   Identifier   "nVidia Corporation NV15 [GeForce2 GTS/Pro]"
   Driver      "nv"
   BusID      "PCI:1:0:0"
EndSection

Section "Monitor"
   Identifier   "COMPAQ FP745"
   Option      "DPMS"
EndSection

Section "Screen"
   Identifier   "Default Screen"
   Device      "nVidia Corporation NV15 [GeForce2 GTS/Pro]"
   Monitor      "COMPAQ FP745"
   DefaultDepth   24
   SubSection "Display"
      Depth      1
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      4
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      8
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      15
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      16
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
   SubSection "Display"
      Depth      24
      Modes      "1024x768" "832x624" "800x600" "720x400" "640x480"
   EndSubSection
EndSection

Section "ServerLayout"
   Identifier   "Default Layout"
   Screen      "Default Screen"
   InputDevice   "Generic Keyboard"
   InputDevice   "Configured Mouse"
   InputDevice     "stylus"   "SendCoreEvents"
   InputDevice     "cursor"   "SendCoreEvents"
   InputDevice     "eraser"   "SendCoreEvents"
EndSection

Section "DRI"
   Mode   0666
EndSection

And the non working one that LinuxMCE 1.1 install was messing with:

Quote
/etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
#   sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
  FontPath "/usr/share/fonts/X11/misc"
  FontPath "/usr/share/fonts/X11/cyrillic"
  FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
  FontPath "/usr/share/fonts/X11/Type1"
  FontPath "/usr/share/fonts/X11/100dpi"
  FontPath "/usr/share/fonts/X11/75dpi"
  # path to defoma fonts
  FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
  Load "i2c"
  Load "bitmap"
  Load "ddc"
  Load "extmod"
  Load "freetype"
  Load "int10"
  Load "vbe"
  load "glx"
  load "GLcore"
  load "v4l"
EndSection

Section "InputDevice"
  Identifier "Generic Keyboard"
  Driver "kbd"
  option "CoreKeyboard"
  option "XkbRules" "xorg"
  option "XkbModel" "pc105"
  option "XkbLayout" "se"
EndSection

Section "InputDevice"
  Identifier "Configured Mouse"
  Driver "mouse"
  option "CorePointer"
  option "Device" "/dev/input/mice"
  option "Protocol" "ImPS/2"
  option "ZAxisMapping" "4 5"
  option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "stylus"
  option "Device" "/dev/input/wacom"
  option "Type" "stylus"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "eraser"
  option "Device" "/dev/input/wacom"
  option "Type" "eraser"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "InputDevice"
  Driver "wacom"
  Identifier "cursor"
  option "Device" "/dev/input/wacom"
  option "Type" "cursor"
  option "ForceDevice" "ISDV4"# Tablet PC ONLY
EndSection

Section "Device"
  identifier "nVidia Corporation NV15 [GeForce2 GTS/Pro]"
  boardname "nv"
  busid "PCI:1:0:0"
  driver "nv"
  screen 0
EndSection

Section "Monitor"
  identifier "COMPAQ FP745"
  vendorname "Plug 'n' Play"
  modelname "Plug 'n' Play"
  modeline  "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
  gamma 1.0
EndSection

Section "Screen"
  Identifier "Default Screen"
  Device "nVidia Corporation NV15 [GeForce2 GTS/Pro]"
  Monitor "COMPAQ FP745"
  DefaultDepth 24
  SubSection "Display"
    depth 24
    virtual 640 480
    modes "640x480@60"
  EndSubSection
EndSection

Section "ServerLayout"
  Identifier "Default Layout"
  screen 0 "Default Screen" 0 0
  InputDevice "Generic Keyboard"
  InputDevice "Configured Mouse"
  InputDevice "stylus" "SendCoreEvents"
  InputDevice "cursor" "SendCoreEvents"
  InputDevice "eraser" "SendCoreEvents"
EndSection

Section "DRI"
  Mode 0666
EndSection
Section "ServerFlags"
EndSection
« Last Edit: May 21, 2007, 11:12:07 pm by Cryoniq »