Author Topic: Geforce 6600 GT  (Read 3705 times)

mking

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Geforce 6600 GT
« on: April 03, 2007, 10:17:12 pm »
Has anyone got the Geforce 6600 GT video card to work in Ubuntu/Linux MCE? If so, what driver did you use? Did you have to do anything special to get it to work?

cckrobinson

  • Veteran
  • ***
  • Posts: 124
    • View Profile
Re: Geforce 6600 GT
« Reply #1 on: April 04, 2007, 12:24:19 am »
My 6600GT is working with UI2 alpha-blending.  I'm using the latest nVidia driver (9755).  Follow the steps outlined by user k84 in this thread:
http://forum.linuxmce.com/index.php?topic=1310.0

That will get you past the incorrect driver detection problem and LMCE will start using the nVidia driver.  Depending on the TV/Monitor that you are connected to you may still have problems.  In my case, the default 720p timings that LMCE uses weren't supported over DVI by my HDTV.  The TV did report the correct EDID information back to the video card, but LMCE ignores it when generating the xorg.conf.pluto file.  Some TV's are better than others about reporting the correct EDID information.  To correct the problem I manually edited the /etc/X11/xorg.conf.pluto file.  Under the "Monitor" section there will be any entry like this:

Option          "IgnoreEDID"   "true"

I changed it to false so that it actually uses the EDID info.  That fixed my problem.  The catch is that each time you start LMCE it will regenerate the xorg.conf.pluto file, so my changes were lost.

The work around is to add an "exit;" to the top of this file:
/usr/pluto/bin/XConfigure.sh

That essentially aborts the script that tries to reconfigure the display.  So once you have a valid config it won't change it again.

Give that a try.

mking

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: Geforce 6600 GT
« Reply #2 on: April 04, 2007, 12:54:42 am »
Thanks...I will give that a try. 

k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Geforce 6600 GT
« Reply #3 on: April 04, 2007, 01:56:06 am »
Tell us if you get it working or not :-)
I'll gladly try to help out a fellow linuxMCE user.

Best Regards,
K84

mking

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: Geforce 6600 GT
« Reply #4 on: April 04, 2007, 07:11:24 pm »
Did not work for me. I followed the directions on modifying the Cards file. No problem.


The /etc/X11/xorg.conf.pluto file.  Under the "Monitor" section there will be any entry like this:
Option          "IgnoreEDID"   "true"

I did not have the above entry to modify. The was one called UseEDID...which was set to false.

My system still boots into Unbunto..and I can not set the resolution to anything other thant 640x480.  I thinking that the install of the Nvidia 9755 driver must have not worked.  When I originally installed the driver it warned me that I was at run level 1...and should be at run level 3.  Telinit 3 does not work because it boots you into Unbuntu. When I figure out how to install the Nvidia driver without any RunLevel warnings...maybe I can get this to work.








k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Geforce 6600 GT
« Reply #5 on: April 04, 2007, 07:29:52 pm »
If you really are at runlevel 1, that's the same as Single user mode.
Can more the less be seen as "Safe mode" in windows.

Ubuntu X starts or LinuxMCE launches?

Has it been like this since you originally installed ubuntu?
you say telinit 3 does not work, because it boots you into ubuntu, take it as the ubuntu X is starting and you get the desktop,
if you try to run The nvidia installer from there you get complaints about X is running, ctrl-alt-backspace should stop X
then login to a console, sudo su

Try to install the NVIDIA driver now.
./NVIDIA......


mking

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: Geforce 6600 GT
« Reply #6 on: April 04, 2007, 08:04:53 pm »
Ok...here is what I did:

1. Boot Machine into maintenance mode
2. Telinit 3...which then brings up the Unbuntu login screen.
3. I login to unbuntu ...then do the ctrl+alt+backspace.
4. Sometimes I get just a blank screen...sometimes I get a maintenace screen that I can login to.
5. when I login...it shoots me back to the Unbuntu X login screen.

I thought it should log me in and keep me in the maintenace mode...now at RunLevel 3. The I could go to the Desktop and run the Nvidia install.

What am I doing wrong???

k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Geforce 6600 GT
« Reply #7 on: April 04, 2007, 08:37:06 pm »
Do you select maintenance mode?
you should not.

mking

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: Geforce 6600 GT
« Reply #8 on: April 04, 2007, 11:12:39 pm »
Is this the procedure?

1. Boot Machine and log into Ubuntu .. X Windows
2. Ctrl+Alt+Backspace
3. Shoud now be at a console window
4. sudo su
5. Install Nvidia driver

k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Geforce 6600 GT
« Reply #9 on: April 04, 2007, 11:28:40 pm »
That sounds fine :-)
Try that :-)

If it screams about an running xserver, do a: killall xinit

k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Geforce 6600 GT
« Reply #10 on: April 04, 2007, 11:33:01 pm »
For further steps, can you please paste your output of :
lshwd -id


cckrobinson

  • Veteran
  • ***
  • Posts: 124
    • View Profile
Re: Geforce 6600 GT
« Reply #11 on: April 05, 2007, 04:07:27 am »
The /etc/X11/xorg.conf.pluto file.  Under the "Monitor" section there will be any entry like this:
Option          "IgnoreEDID"   "true"

I did not have the above entry to modify. The was one called UseEDID...which was set to false.

My bad.  I meant UseEDID not IgnoreEDID. 

mking

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: Geforce 6600 GT
« Reply #12 on: April 05, 2007, 09:51:51 pm »
Here is this the procedure I ran...and what happened:

1. Boot Machine and log into Ubuntu .. X Windows [OK]
2. Ctrl+Alt+Backspace                                      [Screen went blank for about 3-4 seconds, then went back to X Windows login]
3. Shoud now be at a console window                 [Did not get to this step]
4. sudo su                                                      [Did not get to this step]
5. Install Nvidia driver                                       [Did not get to this step]

Also tried this:

1. Boot Machine and log into Ubuntu .. X Windows [OK]
2. Ctrl+Alt+F11                                               [Screen went console type window]
3. Logged in using my account and password        [OK]
3. changed directory to Desktop                         [OK]
5. su NVIDIA-Linux-x86-1.0-9755-pkg1.run           [OK]
6. System said cannot do...because X Server was running.
7. Types Killall xinit
8. System said No processes killed.

So far the only way I was even close to installing the NVidia driver was using the Envy script. Of course that complained too about not being at run level 3. I installed it anyway...I was just unable to get the driver to be used.


k84

  • Veteran
  • ***
  • Posts: 69
    • View Profile
Re: Geforce 6600 GT
« Reply #13 on: April 05, 2007, 10:13:51 pm »
Sounds stange,
Then let's get brutal:
1) killall screen
2)killall -9 xinit
3)killall xfwm4

you did type sudo NVIDIA.....
su NVIDIA ..... would just say, user not found or similaer.

Jametsi

  • Making baby steps
  • Posts: 2
    • View Profile
Re: Geforce 6600 GT
« Reply #14 on: April 09, 2007, 02:09:07 pm »
You are doing it all wrong. The easiest and most compatible way to kill gdm and install Nvidia drivers is like this:

1) press ctrl+alt+F1 (this brings you the text-based login outside the X)
2) command "sudo /etc/init.d/gdm stop" if you use ubuntu, and "sudo /etc/init.d/kdm stop" if you use kubuntu
3) now you have no X running and can install the Nvidia-drivers by commanding "sudo sh NVIDIA..." completing the package name which you are installing