Author Topic: File share not mounted on MD (SOLVED)  (Read 390 times)

Dap-P

  • Veteran
  • ***
  • Posts: 85
    • View Profile
File share not mounted on MD (SOLVED)
« on: October 09, 2013, 10:22:30 am »
Hi all,

This week i installed a 2nd NAS, a freenas server, with a bunch of old harddisks.
LMCE didn't dectect it automaticly, so i created the file server device, and file share device manually.

I ran the scripts for creating LMCE file structure and such. The media that i placed on this share now gets index by the core, but i cannot play it on the MD because the smb share doesn't get mounted.

Anyone that can point in the the right direction?

Anton
« Last Edit: October 09, 2013, 01:01:35 pm by Dap-P »

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: File share not mounted on MD
« Reply #1 on: October 09, 2013, 11:07:57 am »
Are you able to play stuff on the core already? It takes time for the indexer to complete.

After everything is indexed the right way, you can select media on the orbiter, and the requested device will be automounted on your MD.

Dap-P

  • Veteran
  • ***
  • Posts: 85
    • View Profile
Re: File share not mounted on MD
« Reply #2 on: October 09, 2013, 12:04:18 pm »
Are you able to play stuff on the core already? It takes time for the indexer to complete.

After everything is indexed the right way, you can select media on the orbiter, and the requested device will be automounted on your MD.
I dont have a hybrid core. so i cannot play media on the core.
Yes, the media is indexed, and i see the media on the MD orbiter.
When i select to play the media, nothing happens

I ssh'd into my core from my windows pc, then ssh'd into the md, and noticed the smb share was not mounted,
while my other share is mounted (altough that is an nfs share on another nas)


posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2974
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: File share not mounted on MD
« Reply #3 on: October 09, 2013, 12:11:15 pm »
what happens when you ssh into your MD and cd into /mnt/device/<id-of-share-that-doesnt-want-to-mount>

Dap-P

  • Veteran
  • ***
  • Posts: 85
    • View Profile
Re: File share not mounted on MD
« Reply #4 on: October 09, 2013, 12:37:45 pm »
Ok, if i cd into the directory, it exists, and i can see the media.
but if i 'ls -la' in /mnt/device i only see '.' and '..' and no symlinks

And i can also play media now.

Thanks posde