Author Topic: Does anyone have an idea why there is a different kernel on the core than the MD  (Read 1036 times)

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
There are many great features in 10.4: Installation seems flawless, many of the devices that were laborious to install in 8.10 are PNP in 10.4 (gc-100 and PLM for example) and video streaming of movies and recorded TV seems to work better than ever.

However, there are also a number of surprising things I have been finding out while trying to get 8.10 devices to work on 10.4:

Don't try and upgrade the nvidia driver--it will put you into API mismatch hell

Ctrl alt backspace will not get you out of the x terminal in 10.4--you have to manually go in to the keyboard setup and tell it those keystrokes

The PNP que only gives you so many chances to use a device--use them up and you have to go into mysql and delete all instances of the device in the database so that it can start over.

Drivers that were buggy/non functional in 8.10 may seem functional in 10.4 but may still be buggy--do your research.

A case in point brought me to another surprising discovery: When you go to update a diskless MD (as when you change the buggy Realtek 8169 driver that comes with 10.4 to the updated 8168 driver that works well with 10.4) you run into a conflict between different kernels:

root@dcerouter:/boot# cd /usr/pluto/diskless/
root@dcerouter:/usr/pluto/diskless# chroot 80
root@dcerouter:/# depmod
WARNING: Couldn't open directory /lib/modules/2.6.32-45-generic: No such file or directory
FATAL: Could not open /lib/modules/2.6.32-45-generic/modules.dep.temp for writing: No such file or directory

???
root@dcerouter:/boot# uname -a
Linux dcerouter 2.6.32-45-generic #104-Ubuntu SMP Tue Feb 19 21:21:41 UTC 2013 i686 GNU/Linux

root@dcerouter:/# cd /lib/modules/
root@dcerouter:/lib/modules# ls
2.6.32-46-generic

What is going on? one says 45 and the other is 46.

My workaround (which seems to work so far):

root@dcerouter:/usr/pluto/diskless# chroot 80
root@dcerouter:/# depmod 2.6.32-46-generic
root@dcerouter:/# mkinitramfs -o initrd.img-`uname -r` 2.6.32-46-generic

here is the background on the issue:
http://wiki.linuxmce.org/index.php/Realtek_8168

I've done update and upgrade inside both the core and the MD

I admit profound ignorance when it comes to depmod and the different kernels in play. My question: Is this a bug that needs to be addressed?

Many thanks for any input.

_if_

  • Guru
  • ****
  • Posts: 239
    • View Profile
did you do a apt-get dist-upgrade or just apt-get upgrade?

sedgington

  • Veteran
  • ***
  • Posts: 80
    • View Profile
apt-get update then apt-get upgrade from command line.

Does no one else have this issue or am I the only lucky one?

i"ll try installing another diskless MD this weekend and see if the issue is duplicated on that one.


posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3020
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
The version on the core and the version on the MDs do not have to be in sync. For example, my core had the original 1004 kernel, whereas my MD had a backported natty kernel to support the SandyBridge GPU