Author Topic: Update 10.04 to 12.04 = success (at least to me)  (Read 9288 times)

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #15 on: March 26, 2013, 11:20:23 am »
Hey ....


here is the current Update script:

Code: [Select]
#!/bin/sh

# SET VARIABLES
backSuffix=.1004

## SOURCE LIST
sourceBackup=/etc/apt/sources.list${backSuffix}
releaseFrom=lucid
releaseName=precise

# UPGRADE LMCE
echo 'Start Upgrade  ...'

# MODIFY FILES BECAUSE OF CHANGES IN NEW VERSIONS
## SOURCES.LIST
echo 'save backup "sources.list" to' $sourceBackup '...'
cp /etc/apt/sources.list $sourceBackup
echo 'Set package entries from' $releaseFrom 'to' $releaseName
#sed -i "s/$releaseFrom/$releaseName/g" /etc/apt/sources.list
sed -i "s/beta2/unstable/g" /etc/apt/sources.list

## MYSQL
mysqlUtf8='default-'
mysqlUtf8Comment='#default-'
mySqlConf=/etc/mysql/my.cnf${backSuffix}

## MYSQL
echo 'save backup "my.cnf" to ' $mySqlConf '...'
cp /etc/mysql/my.cnf ${mySqlConf}
echo 'Set value in my.cnf from' $mysqlUtf8 'to' $mysqlUtf8Comment
sed -i "s/$mysqlUtf8/$mysqlUtf8Comment/g" /etc/mysql/my.cnf
sed -i "s/$mysqlUtf8/$mysqlUtf8Comment/g" /etc/mysql/conf.d/lmce-my.cnf

echo '### do-release-upgrade'
do-release-upgrade -mode=desktop

echo '### REENABLE THIRD PARTY SOURCES'
sed -i "s/# deb/deb/g" /etc/apt/sources.list

echo '### MAKE SURE ALL PACKAGES ARE CONFIGURED'
apt-get update
apt-get -y --force-yes install xorg xserver-xorg
apt-get -y --force-yes install pluto-dcerouter
/usr/pluto/bin/ConfirmDependencies -h localhost -u root -o 20 -f -d 1 install > /usr/pluto/bin/verifyinstallation.sh && chmod +x /usr/pluto/bin/verifyinstallation.sh && /usr/pluto/bin/verifyinstallation.sh
apt-get -y dist-upgrade

echo '12.04 installed? ...'

i tried it serveral times in my VM to update  from 10.04 to 12.04 but after "do-release-upgrade" my lan connection is almost dead.
It might run well on a "normal" (not VM) install.

If anyone knoww howto fix this or what is causing the slow lan connection after "do-release-upgrade" please help me! :-)

cheers,
ochorocho

coley

  • Guru
  • ****
  • Posts: 474
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #16 on: March 26, 2013, 12:14:06 pm »
Will try your updated script and let you know if I run into the same problems.
-Coley.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #17 on: March 26, 2013, 04:18:59 pm »
thanks mate ...
currently running a modified version of the script ....
last 10% of the script take 5 times the time it took me to get there .... maybe more...
i reckon this shows my skills :-D

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 945
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #18 on: March 27, 2013, 03:34:31 am »
The portion after the do-release-upgrade will take quite some time as it will dl anywhere from 500MB to 1G, and then as it upgrades lmce components from 1004 to 1204, database updates can take a considerable time.  By contrast the do-release-upgrade portion dls approx 880MB on my systems.  So total upgrade is > 1.6GB of dled .debs.  Keep this in mind.

Otherwise, I have had success with the script.  Please keep in mind that upgrading to 1204 is not an option for a production system, there is a lot that does not function properly. 

If you do attempt this, please file tickets about anything you discover is not working, check to make sure no one else has reported it first.  http://svn.linuxmce.org

Thanks for all everything polly!  I'm hoping we can have a clear upgrade path for people from 1004 to 1204 once things are more stable.

J.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #19 on: March 27, 2013, 12:23:02 pm »
Hey,

@phenigma this script works for me now:
http://dokuwiki.knallimall.org/de/linuxmce_macmini_2010_4_1/linuxmce_1204_upgrade_script

i will try to pre answer all the prompts. After that i'm done for now and go on with qOrbiter skinning.
Currently everything i use works ootb after upgrade.... to be honest i use not even 1% of the system! ...

thanks.
ochorocho

Esperanto

  • Guru
  • ****
  • Posts: 240
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #20 on: March 27, 2013, 03:54:13 pm »
Could you create a wiki page with a list with what is working and what is not working (maybe with links to future tickets)?

coley

  • Guru
  • ****
  • Posts: 474
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #21 on: March 27, 2013, 04:03:29 pm »
I kicked off the script last night, but it was waiting on my input when I got back to it today.
After babysitting it for a while it completed.
VM Hybrid looks like it is operational.
Anything specific I should test for completeness?

-Coley.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #22 on: March 27, 2013, 04:50:30 pm »
Esperanto, currently i had no issues @all .... because of the fact i'm running LMCE not productive atm. I'll look into the issues i can find ... currently documenting stuff here: http://dokuwiki.knallimall.org/de/linuxmce_macmini_2010_4_1/linuxmce_1204_upgrade_script

Coley, just keep me posted what issues occur, so i can write it down on the wiki or trac (ticket) ...

i'm really happy that people paying so much attention on that skript .....

cheers,
ochorocho

coley

  • Guru
  • ****
  • Posts: 474
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #23 on: March 27, 2013, 05:19:03 pm »
Just to add VM MD booted and ran AVWiz successfully.
Currently downloading pkgs for MD.

-Coley.

Um... maybe a bit too fast to report there - MD is 10.04 based.
« Last Edit: March 27, 2013, 05:20:35 pm by coley »

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 945
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #24 on: March 27, 2013, 07:21:38 pm »
Could you create a wiki page with a list with what is working and what is not working (maybe with links to future tickets)?

Development for 1204 can be followed on the 1204 alpha wiki page.  Tickets should be filed for items that are not found to be working.  Feel free to grab the script and test!  If you wish to create a wiki of what is working or not please feel free to do so.  Polly is quite busy from what I have seen.  ;)

J.
« Last Edit: March 27, 2013, 07:24:20 pm by phenigma »

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 945
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #25 on: March 27, 2013, 07:22:21 pm »
Just to add VM MD booted and ran AVWiz successfully.
Currently downloading pkgs for MD.
Um... maybe a bit too fast to report there - MD is 10.04 based.

Diskless_CreateTBZ.sh is not currently finishing on 1204, this will need to be looked at before 1204 MDs can be created.

J.

coley

  • Guru
  • ****
  • Posts: 474
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #26 on: March 27, 2013, 07:25:19 pm »
Diskless_CreateTBZ.sh is not currently finishing on 1204, this will need to be looked at before 1204 MDs can be created.

J.
Currently failing trying to install xine-ui, pluto-orbiter won't install as a result.
It's listed in packages for 1204 but I'll need to check why its not installing.

-Coley.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 945
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #27 on: March 27, 2013, 07:30:33 pm »
Currently failing trying to install xine-ui, pluto-orbiter won't install as a result.
It's listed in packages for 1204 but I'll need to check why its not installing.

Diskless_CreateTBZ.sh finishes up to tarball creation for me, then fails.  I'm on IRC to chat, don't want to highjack polly's thread.

J.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #28 on: April 01, 2013, 03:28:20 am »
Hey.... some more Progress...

New update script:
http://dokuwiki.knallimall.org/de/linuxmce_macmini_2010_4_1/linuxmce_1204_upgrade_script

Changes:
- Pre answer all prompts - DONE
- PK_Distro = 18 needs to change to 20 - DONE <- thanks ph-enigma for the hint
- add message if "sudo" is not used
- add upgrade confirmation message
- REMOVE FOR NOW:    echo '### CHECKING INSTALLATION ...'
   /usr/pluto/bin/ConfirmDependencies -h localhost -u root -o 20 -f -d 1 install > /usr/pluto/bin/verifyinstallation.sh && chmod +x /usr/pluto/bin/verifyinstallation.sh && /usr/pluto/bin/verifyinstallation.sh

 Should better run once after reboot to verify the upgrade

cheers,
ochorocho

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 945
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #29 on: April 01, 2013, 03:32:59 am »
Polly,

Thanks for keeping on with this.  I'm wondering why are you removing the ConfirmDependencies?  It is vital to a proper upgrade and should be in the script.

J.