Author Topic: Update 10.04 to 12.04 = success (at least to me)  (Read 10117 times)

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Update 10.04 to 12.04 = success (at least to me)
« on: March 13, 2013, 11:42:43 pm »
Hey ...

i upgraded my LMCE 810 to LMCE 1204 and from the current point of view it was a success story for me as a semi skilled programmer.

With the help of Google i was able to fix all the install issues i had.

Here is what i roughly did:
http://dokuwiki.knallimall.org/de/linuxmce_macmini_2010_4_1/linuxmce_1204_upgrade

For now i couldn't find any big issue ... i'm not using any special equipment, currently its more a HTPC than a home automation system.

Parts of the System i tested till now:
  • VDR works
  • both network cards work
  • NVIDIA graphics works
  • AvWizard detected audio correctly and played sounds nicely

i expected the upgrade driving me nuts, but it was quite easy ... :-)

thoughts and questions are welcome :-)

ochorocho
« Last Edit: March 18, 2013, 12:35:51 pm by polly »

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3014
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #1 on: March 14, 2013, 06:40:34 am »
Create a script to make it a one-click affair for others.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #2 on: March 14, 2013, 09:15:35 am »
yes, sir!

shoudn't be to much effort... :-)
« Last Edit: March 14, 2013, 12:24:48 pm by polly »

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #3 on: March 15, 2013, 12:00:11 am »
hey ...

i wrote a little script which aims to make the upgrade process a bit smother.
it changes a few lines in the config of mysql and upnp. It prepares sources.list for precise.
before changeing the file will be backed up in *.1004.

download it from here:
http://dokuwiki.knallimall.org/de/linuxmce_macmini_2010_4_1/linuxmce_1204_upgrade_script

i need people to test it.
Its experimental! So if anything goes wrong while using this script let me know.

cheer,
ochorocho

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #4 on: March 15, 2013, 12:20:27 am »
This is 0810 to 1204, what are you thoughts on this working for 1004 to 1204?  I'm test this on mine after my relatives leave on Monday, unless there is a very good shot that this won't work for 1004.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #5 on: March 15, 2013, 01:26:51 am »
hey ....

i should rename it into 1004 to 1204 !!!

sorry for the confusion.

can i rename the post? ....

coley

  • Guru
  • ****
  • Posts: 481
    • View Profile
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #6 on: March 15, 2013, 03:14:43 pm »
Hi
I tried this on a headless 10.04 VM and it fails.
I get:
Code: [Select]
W: Failed to fetch http://deb.linuxmce.org/ubuntu/dists/precise/beta2/binary-i386/Packages.gz 404 Not Foundallowing it to continue I get:
Code: [Select]
E: Could not perform immediate configuration on 'python2.7-minimal'. Please see man 5 apt.conf under APT::Immediate-Configure for details. (2)and finally:
Code: [Select]
E: Couldn't configure pre-depend multiarch-support for libnih-dbus1, probably a dependency cycle.
I can leave this as is if you want me to try something else with it.

Meanwhile I will d/load the 10.04 release iso and set up as a hybrid VM and try the script on that.

-Coley.

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3014
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #7 on: March 15, 2013, 04:03:49 pm »
The first error can be ignored. Seems that the script changes the linuxmce.org line from lucid to precise, instead of also changing beta2 to unstable.

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1005
    • View Profile
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #8 on: March 17, 2013, 05:18:38 am »
I had the same failures as coley on a 1004 VM.

And this line will leave all of the new packages unconfigured, not really a full upgrade.
Code: [Select]
apt-get dist-upgrade -o APT::Immediate-Configure=0


J.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #9 on: March 17, 2013, 09:25:58 am »
Hey .... currently working on it ...

i test the install on VM before release it ... :-)
its running quite well atm, the only thing is mysql needs to be restarted during "apt-get dist-upgrade" which fails. when i restart mysql manually the script goes on ...

Leaving stuff unconfigured while doing dist-upgrade worked for me, but i did a "dpkg --configure -a" afterwards....

give me a few more hours, as said, the script now works not to bad .... testing takes its time here...

phenigma

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1005
    • View Profile
Re: Update 8.10 to 12.04 = success (at least to me)
« Reply #10 on: March 17, 2013, 09:58:47 pm »
No problem, just reporting my experience.  Thank you for taking this on!  I will test any updated scripts you create as well.

J.

ps, if you go back and modify your original post you can change the original Subject of the thread.

polly

  • Administrator
  • Guru
  • *****
  • Posts: 180
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #11 on: March 18, 2013, 12:40:51 pm »
Hey ...

Thanks!
Current process is:

1. Search google for a solution
2. change script
3. run script (... wait for 2+ hours till it get stuck)
4. revert VM and start with #1 again ....

i hope i'm getting closer :-/ ... i found a couple of promising suggestions ...

Cheers,
ochorocho

ardirtbiker

  • Guru
  • ****
  • Posts: 248
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #12 on: March 18, 2013, 04:50:17 pm »
Im trying this on a 2nd server I have (regular install, no vm) running 1004.

running apt-get install multiarch-support gets past this issue:
E: Couldn't configure pre-depend multiarch-support for libnih-dbus1, probably a dependency cycle.

I kept running the script (about 4 times) fixing the issues like above and the orbiter is onscreen.     I did have to manually install xserver-xorg because 'X failed to start' message came up on initial AVWizard run.

I will clone my working 1004 core disc and try an upgrade on the clone.  

Question:   Will running Diskless_CreateTBZ.sh build an 1004 MD image or will it build a 1204 MD image?

Dennis

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3014
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #13 on: March 18, 2013, 05:18:19 pm »
Try it, and let us know. Hint: Rename /usr/pluto/install/PlutoMD_Debootstraped.tar.bz2 to something else.

ardirtbiker

  • Guru
  • ****
  • Posts: 248
    • View Profile
Re: Update 10.04 to 12.04 = success (at least to me)
« Reply #14 on: March 18, 2013, 07:18:45 pm »
okay!   later this afternoon since it is supposed to rain again!   messin with my patio building!!!! and yardwork!!