Author Topic: mediatomb  (Read 1175 times)

iberium

  • Veteran
  • ***
  • Posts: 84
    • View Profile
    • Innovative Sight & Sound
mediatomb
« on: February 17, 2013, 03:26:10 pm »
I have a sharp tv, and when I go to browse for dlna devices, only mythtv shows up (on my computers, both mediatomb and mythtv show).  All of the media that I want to play is stored in media tomb,  what do I need to do to resolve this.  Do I need to copy my mediatomb media over to mythtv?

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: mediatomb
« Reply #1 on: February 17, 2013, 04:04:21 pm »
No need to copy the media.  Mediatomb should be accessible as a upnp device just as mythtv.  However, I don't recall if Mediatomb is DLNA compatible.

J.

theteju

  • Veteran
  • ***
  • Posts: 127
    • View Profile
Re: mediatomb
« Reply #2 on: March 02, 2013, 03:52:34 am »
Something has been changed with mediatomb. On ubuntu community document it shows that mediatomb needs user log in , in order to work stable.
I have mediatomb found by my tv (samsung) and also playing audio and video contents. https://help.ubuntu.com/community/MediaTomb

For that you have to edit its config.xml  file for it. I forgot its path on our system, believe its /etc/pluto/mediatomb/ (dont quote me on that) in that xml file you will have to add mame types for your content. I will post my config.xml when I fire up my core.

however my problem is, mediatomb does not seem to scan all the media. It does not update its database even though scanned manually.
and the video does not play with its proper display, In other words quality of video looks crap on my MD.

I hope I am not too late to reply.
Good luck.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: mediatomb
« Reply #3 on: March 02, 2013, 07:05:22 pm »
Something has been changed with mediatomb. On ubuntu community document it shows that mediatomb needs user log in , in order to work stable.
I have mediatomb found by my tv (samsung) and also playing audio and video contents. https://help.ubuntu.com/community/MediaTomb

For that you have to edit its config.xml  file for it. I forgot its path on our system, believe its /etc/pluto/mediatomb/ (dont quote me on that) in that xml file you will have to add mame types for your content. I will post my config.xml when I fire up my core.

It would be great if you could file a bug in trac at svn.linuxmce.org and attach your .xml file to it.  That way it can be checked and tracked.

however my problem is, mediatomb does not seem to scan all the media. It does not update its database even though scanned manually.
and the video does not play with its proper display, In other words quality of video looks crap on my MD.

First question, why are you using mediatomb to play media on your MD?
Second question, can you be more specific about the locations of media that are/are not showing in mediatomb?  Are they private user_? data or public?  LMCE data structure or public?
Could you file a bug in svn about this issue as well.  Include as much detail as you can.

Filing bugs in svn is the only way devs have to track the issues that people are having and attemp to fix them.  If they are not filed in trac they may not be addressed.

Thanks for the info!

Jason

theteju

  • Veteran
  • ***
  • Posts: 127
    • View Profile
Re: mediatomb
« Reply #4 on: March 03, 2013, 06:17:15 pm »
Ok. First of all. My bad, I was addressing the issue on the post having said, I am attempting to access the media from my Samsung LED tv which in inside of my network via its DLNA playback capabilities, that is where the quality of video gets messed up. it was my mistake to call it MD. sorry.

secondly,
the media hard drive architecture is linuxmce style. so I have media under user_1 and public folders. mediatomb is only showing contents of pubic. Which is fine and which is what I want. but it does not show all the contents. in other words, its being picky !

I will post my confing.xml soon.

Thanks.

theteju

  • Veteran
  • ***
  • Posts: 127
    • View Profile
Re: mediatomb
« Reply #5 on: March 03, 2013, 07:00:47 pm »
here is my http://pastebin.com/5uDHQqvL  /etc/mediatomb/config.xml
Quote
theteju@dcerouter:/etc/mediatomb$ cat config.xml
<?xml version="1.0" encoding="UTF-8"?>
<config version="1" xmlns="http://mediatomb.cc/config/1" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://mediatomb.cc/config/1 http://mediatomb.cc/config/1.xsd">
  <server>
    <ui enabled="yes" show-tooltips="yes">
      <accounts enabled="yes" session-timeout="30">
        <account user="mediatomb" password="mediatomb"/>
      </accounts>

    </ui>

    <port>49153</port>
    <interface>eth0</interface>
    <name>LinuxMCE via MediaTomb</name>
    <udn>uuid:915f7219-1615-4f30-af6d-4c526315c691</udn>
    <home>/var/lib/mediatomb</home>
    <webroot>/usr/share/mediatomb/web</webroot>
    <storage>
      <sqlite3 enabled="no">
        <database-file>sqlite3.db</database-file>
      </sqlite3>
      <mysql enabled="yes">
        <host>localhost</host>
        <username>root</username>
        <database>pluto_mediatomb</database>
      </mysql>
    </storage>
    <protocolInfo extend="yes"/><!-- For PS3 support change to "yes" -->
    <!--
       Uncomment the lines below to get rid of jerky avi playback on the
       DSM320 or to enable subtitles support on the DSM units
    -->
   
    <custom-http-headers>
      <add header="transferMode.dlna.org: Streaming"/>
      <add header="contentFeatures.dlna.org: DLNA.ORG_OP=01;DLNA.ORG_CI=0;DLNA.ORG_FLAGS=01500000000000000000000000000000"/>
    </custom-http-headers>

    <manufacturerURL>redsonic.com</manufacturerURL>
    <modelNumber>105</modelNumber>
   
    <!-- Uncomment the line below if you have a Telegent TG100 -->
    <!--
       <upnp-string-limit>101</upnp-string-limit>
    -->
  </server>
  <import hidden-files="no">
    <scripting script-charset="UTF-8">
      <common-script>/usr/share/mediatomb/js/common.js</common-script>
      <playlist-script>/usr/share/mediatomb/js/playlists.js</playlist-script>
      <virtual-layout type="builtin">
        <import-script>/usr/share/mediatomb/js/import.js</import-script>
      </virtual-layout>
    </scripting>
    <mappings>
      <extension-mimetype ignore-unknown="no">
        <map from="mp3" to="audio/mpeg"/>
        <map from="ogg" to="application/ogg"/>
        <map from="asf" to="video/x-ms-asf"/>
        <map from="asx" to="video/x-ms-asf"/>
        <map from="wma" to="audio/x-ms-wma"/>
        <map from="wax" to="audio/x-ms-wax"/>
        <map from="wmv" to="video/x-ms-wmv"/>
        <map from="wvx" to="video/x-ms-wvx"/>
        <map from="wm" to="video/x-ms-wm"/>
        <map from="wmx" to="video/x-ms-wmx"/>
        <map from="m3u" to="audio/x-mpegurl"/>
        <map from="pls" to="audio/x-scpls"/>
        <map from="flv" to="video/x-flv"/>
        <map from="vdrs" to="video/x-vdr"/>
        <map from="avi" to="video/mpeg"/>
        <!-- Uncomment the line below for PS3 divx support -->
        <!-- <map from="avi" to="video/divx"/> -->
        <!-- Uncomment the line below for D-Link DSM / ZyXEL DMA-1000 -->
        <!-- <map from="avi" to="video/avi"/> -->
      </extension-mimetype>
      <mimetype-upnpclass>
        <map from="audio/*" to="object.item.audioItem.musicTrack"/>
        <map from="video/*" to="object.item.videoItem"/>
        <map from="image/*" to="object.item.imageItem"/>
      </mimetype-upnpclass>
      <mimetype-contenttype>
        <treat mimetype="audio/mpeg" as="mp3"/>
        <treat mimetype="application/ogg" as="ogg"/>
        <treat mimetype="audio/x-flac" as="flac"/>
        <treat mimetype="image/jpeg" as="jpg"/>
        <treat mimetype="audio/x-mpegurl" as="playlist"/>
        <treat mimetype="audio/x-scpls" as="playlist"/>
        <treat mimetype="audio/x-wav" as="pcm"/>
        <treat mimetype="video/x-msvideo" as="avi"/>
        <treat mimetype="video/mp4" as="mp4"/>
        <treat mimetype="audio/mp4" as="mp4"/>

      </mimetype-contenttype>
    </mappings>
    <autoscan use-inotify="auto">
      <directory location="/home/public/data/audio" mode="timed" interval="3600"
          level="full" recursive="yes" hidden-files="no"/>
      <directory location="/home/public/data/videos" mode="timed" interval="3600"
          level="full" recursive="yes" hidden-files="no"/>
      <directory location="/home/public/data/pictures" mode="timed" interval="3600"
          level="full" recursive="yes" hidden-files="no"/>                 
      <directory location="/var/lib/mediatomb/TV" mode="timed" interval="3600"
          level="full" recursive="no" hidden-files="no"/>                 
     
    </autoscan>
  </import>
  <transcoding enabled="yes">
      <mimetype-profile-mappings>
        <transcode mimetype="video/x-vdr" using="vdrplay"/>
      </mimetype-profile-mappings>
      <profiles>
        <profile name="vdrplay" enabled="yes" type="external">
          <mimetype>video/mpeg</mimetype>
          <agent command="vdrplay.sh" arguments="%in %out"/>
          <buffer size="10485760" chunk-size="131072" fill-size="2621440"/>
          <accept-url>yes</accept-url>
     <first-resource>yes</first-resource>
         </profile>
      </profiles>
  </transcoding>
                                               
  <transcoding enabled="no">
    <mimetype-profile-mappings>
      <transcode mimetype="video/x-flv" using="vlcmpeg"/>
      <transcode mimetype="application/ogg" using="vlcmpeg"/>
      <transcode mimetype="application/ogg" using="oggflac2raw"/>
      <transcode mimetype="audio/x-flac" using="oggflac2raw"/>
    </mimetype-profile-mappings>
    <profiles>
      <profile name="oggflac2raw" enabled="no" type="external">
        <mimetype>audio/L16</mimetype>
        <accept-url>no</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>no</accept-ogg-theora>
        <agent command="ogg123" arguments="-d raw -f %out %in"/>
        <buffer size="1048576" chunk-size="131072" fill-size="262144"/>
      </profile>
      <profile name="vlcmpeg" enabled="no" type="external">
        <mimetype>video/mpeg</mimetype>
        <accept-url>yes</accept-url>
        <first-resource>yes</first-resource>
        <accept-ogg-theora>yes</accept-ogg-theora>
        <agent command="vlc" arguments="-I dummy %in --sout #transcode{venc=ffmpeg,vcodec=mp2v,vb=4096,fps=25,aenc=ffmpeg,acodec=mpga,ab=192,samplerate=44100,channels=2}:standard{access=file,mux=ps,dst=%out} vlc:quit"/>
        <buffer size="14400000" chunk-size="512000" fill-size="120000"/>
      </profile>
    </profiles>
  </transcoding>
</config>

I do not remember exactly ,, but lines above in red is what I edited in my file. I would love to have mediatomb server accessible from the external network but I have not been successful yet.

« Last Edit: March 03, 2013, 07:09:00 pm by theteju »

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 944
    • View Profile
Re: mediatomb
« Reply #6 on: March 03, 2013, 09:33:34 pm »
Hi,

I've never used mediatomb, it looks like you have defined only certain mime types, it may be ignoring files that it doesn't know what to do with, like .mkv files that are not defined.  I'd do some searching on google for mediatomb and see what you can find.  And open a trac ticket with all the information that you do have, update if you find more.

J.