Author Topic: [SOLVED] NIC not recognized - BIOSTAR G41D3C - kernel driver atl1c  (Read 947 times)

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
[SOLVED] NIC not recognized - BIOSTAR G41D3C - kernel driver atl1c
« on: September 20, 2012, 03:36:44 am »
I have a Biostar G41D3C (http://www.biostar.com.tw/app/en/mb/introduction.php?S_ID=518) with a pci-x (VDPAU capable) hdmi out card and 2 gigs of ram.  I should world great as an MD, but apparently the NIC is not supported by the kernel or the drivers are not loaded by default.  I'm a little confused on the offical way to get this md working and possible supported OTB by linuxmce future release.  

Can some one post help me figure this out... maybe by posting here some official instructions so I can try them and then I''ll document them correctly in the wiki (It seems that the current documentation of this on the wiki doesnt work right)?

Thanks
« Last Edit: December 30, 2012, 07:07:07 am by joerod »

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2931
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: NIC not recoginzed and md install not starting
« Reply #1 on: September 20, 2012, 12:28:39 pm »
There is  a wiki page about unrecognized nics. That should help you.

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: NIC not recoginzed and md install not starting
« Reply #2 on: September 23, 2012, 08:27:02 pm »
I'm currently trying this:

http://wiki.linuxmce.org/index.php/Unrecognized_NIC

but it doesnt seem to be working.  Are these instructions up to date? Should the instruction on the above link be working?

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2931
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: NIC not recoginzed and md install not starting
« Reply #3 on: September 23, 2012, 08:29:31 pm »
yes, afaict, most of the stuff should be up-to-date. put it that way: i had a nic working with 1004 after following that page.

joerod

  • Guru
  • ****
  • Posts: 153
    • View Profile
Re: NIC not recoginzed and md install not starting
« Reply #4 on: December 30, 2012, 06:38:39 am »
Interesting note for someone in the future (probably me if I ever have to reinstall this MD)

the steps located at: http://wiki.linuxmce.org/index.php/Unrecognized_NIC are partially incomplete (at least for my motherboard)

the atl1c driver is a little different in kernel < 2.6.34 and it would seem 1004 is running 2.6.32

So i had to apt-get install kernel-image-2.6.35, then run /usr/pluto/bin/Diskless_BuildDefaultImage.sh NOT mkinitramfs -d /etc/initramfs-tools-interactor/ -o /tftpboot/default/initrd (which gets run anyways inside the previous script Diskless_BuildDefaultImage.sh).

the trick was I had to remove the directory /lib/modules/2.6.32 (the previously installed kernel). Then running /usr/pluto/bin/Diskless_BuildDefaultImage.sh once the first part of the md install was over I had to follow the directions at the link above and add proper symlink in /usr/pluto/diskless/<md id>/initrd.img and vmlinuz
« Last Edit: December 30, 2012, 07:04:58 am by joerod »

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2931
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: [SOLVED] NIC not recognized - BIOSTAR G41D3C - kernel driver atl1c
« Reply #5 on: December 30, 2012, 11:24:33 am »
Did you put a note on the unrecognized nic wiki article?