Author Topic: Raspberry Pi builder  (Read 8576 times)

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 942
    • View Profile
Re: Raspberry Pi builder
« Reply #45 on: April 02, 2013, 03:58:40 am »
Yes please!  ;D  That may let me remove a hack to address the usb-uirt!

J.

SBCC

  • Veteran
  • ***
  • Posts: 122
    • View Profile
Re: Raspberry Pi builder
« Reply #46 on: April 02, 2013, 04:12:53 am »
I followed instructions here

http://mitchtech.net/raspberry-pi-kernel-compile/

Mostly. The kernel.img goes on the sd card and the modules and firmware go in /usr/pluto/diskless/xx/lib/

You will have to install the gcc cross complier. I followed this

https://wiki.linaro.org/Resources/ToolchainInstall-10

I can put a more user friendly outline together if you want to add it to you wiki. There is a shell script on rpi that should do this but did not work for me. At least not before I updated the modules. I think it may now. It's /usr/bin/rpi-update. You can see more about that at

https://github.com/Hexxeh/rpi-update

Hope this helps

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 942
    • View Profile
Re: Raspberry Pi builder
« Reply #47 on: April 02, 2013, 02:25:20 pm »
Thanks, I'll see what I can do with that.

J.

SBCC

  • Veteran
  • ***
  • Posts: 122
    • View Profile
Re: Raspberry Pi builder
« Reply #48 on: April 02, 2013, 10:35:41 pm »
Trying to attached templates to serial devices with lmce-admin I find under "COM Port on PC"
Code: [Select]
Error: top parent device not found
I did have to install mysql-client. I ran UpdateAvailableSerialPorts.sh and the ttyUSB0 shows up in mysql under device data 133 with fkdevice being the rpi. Any idea whats causing this?

Also seeing this under "Sound Card" in the rpi device

Thanks again

Jim

SBCC

  • Veteran
  • ***
  • Posts: 122
    • View Profile
Re: Raspberry Pi builder
« Reply #49 on: April 03, 2013, 03:38:56 pm »
Ok figured out the problem.

Because the rpi is a new style MD I needed to let lmce-admin know that. Added
Code: [Select]
$GLOBALS['rootRPIMediaDirectorsID'] = 2216; // Raspberry PI Media Directors
in hardCoded.php

and then had to make that a choice option when checking for MDs. Changed in utils.inc.php
Code: [Select]
if($row['FK_DeviceCategory']==$GLOBALS['CategoryCore'] || $row['FK_DeviceTemplate']==$GLOBALS['rootMediaDirectorsID']){
to
Code: [Select]
if($row['FK_DeviceCategory']==$GLOBALS['CategoryCore'] || $row['FK_DeviceTemplate']==$GLOBALS['rootMediaDirectorsID'] || $row['FK_DeviceTemplate']==$GLOBALS['rootRPIMediaDirectorsID']){under
Code: [Select]
function getTopLevelParent($deviceID,$dbADO)
That was causing my problem. Also changed same line under
Code: [Select]
function getTopLevelParentIP($deviceID,$dbADO)And changed under
Code: [Select]
function isMediaDirector($deviceID,$dbADO,$mdOnly=0)this line
Code: [Select]
if($DeviceTemplate==$GLOBALS['rootMediaDirectorsID']){
To this
Code: [Select]
if($DeviceTemplate==$GLOBALS['rootMediaDirectorsID'] || $DeviceTemplate==$GLOBALS['rootRPIMediaDirectorsID']){

I haven't tested it too much yet but appears to work.
Let me knwo if you need anything more.

Jim

SBCC

  • Veteran
  • ***
  • Posts: 122
    • View Profile
Re: Raspberry Pi builder
« Reply #50 on: April 03, 2013, 05:10:48 pm »
now I'm finding it will not down load software for new devices. Well at least for oneWire.

Any incites there?

Thanks

coley

  • Guru
  • ****
  • Posts: 472
    • View Profile
Re: Raspberry Pi builder
« Reply #51 on: April 03, 2013, 06:04:54 pm »
now I'm finding it will not down load software for new devices. Well at least for oneWire.

Any incites there?

Thanks
Phenigma may not have *all* of the lmce debs up for armhf, or there may be missing raspbian debs either.
-Coley
« Last Edit: April 03, 2013, 06:19:41 pm by coley »

SBCC

  • Veteran
  • ***
  • Posts: 122
    • View Profile
Re: Raspberry Pi builder
« Reply #52 on: April 03, 2013, 06:11:58 pm »
I thought that might be the case. I also forgot different OS. I am building what I need. Anything I can do?

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 942
    • View Profile
Re: Raspberry Pi builder
« Reply #53 on: April 04, 2013, 04:53:17 pm »
SBCC, my raspbian repo for lmce is not stable at the moment.  I have been rebuilding packages twice a day working on the build-system and many things are broken, but getting fixed.  As soon as I have a stable repo, likely tonight.  I will let you know and you can report issues you may have.  One-wire may not be building currently, but that is likely easy to rectify.

At this point my next step is MD setup to launch orbiter, rather than the simple debootstrapped system of a moonpi so far.

J.

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 942
    • View Profile
Re: Raspberry Pi builder
« Reply #54 on: April 04, 2013, 04:56:21 pm »
Ok figured out the problem.

Great stuff!  I hadn't got there yet.  A big help!  I will get these incorporated soon.  It would really help me if you could create a ticket and set phenigma as the owner and detail these items in the ticket @ svn.linuxmce.org.  It would be really handy if you could do this for any issues that you do encounter, that way I can pull of a list of issues.  Thank you so much for testing, I am hoping to have more working very soon as my builder stabilizes ;D

J.

SBCC

  • Veteran
  • ***
  • Posts: 122
    • View Profile
Re: Raspberry Pi builder
« Reply #55 on: April 04, 2013, 05:09:19 pm »
phenigma

Thanks for all your work. I can put that together that ticket. If I have any questions I'll let you know. I am building some things now, OneWire being one of them. I'm building dependencies as I go as needed. I am building what I need to use the rpi for headless automation. If you like I can dropbox them for you.

Jim

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 942
    • View Profile
Re: Raspberry Pi builder
« Reply #56 on: April 04, 2013, 05:13:56 pm »
That would be great.  I can reference what you have vs what we have in svn.  I am trying to incorporate everything into the standard build system.

J.

SBCC

  • Veteran
  • ***
  • Posts: 122
    • View Profile
Re: Raspberry Pi builder
« Reply #57 on: April 06, 2013, 09:03:17 pm »
Not sure if this is the best place for this.

I had to make some changes so TranslateUSB works. I show it on ticket #1738.
With those changes OneWire runs on the rpi. It just will not start on it's own. I have not installed any sensors yet but I will soon.


Edit:
Sensors work fine. I had to reload router to see them in lmce-admin.
« Last Edit: April 06, 2013, 09:25:40 pm by SBCC »

phenigma

  • wants to work for LinuxMCE
  • **
  • Posts: 942
    • View Profile
Re: Raspberry Pi builder
« Reply #58 on: April 09, 2013, 04:37:04 pm »
Not sure if this is the best place for this.

I had to make some changes so TranslateUSB works. I show it on ticket #1738.
With those changes OneWire runs on the rpi. It just will not start on it's own. I have not installed any sensors yet but I will soon.

Edit:
Sensors work fine. I had to reload router to see them in lmce-admin.

This is as good a place as any right now!   ;D

Thanks for the ticket!  I have been making good progress on pi MD creation and I hope to incorporate your changes very soon.

As for it not starting on its own, that is a result of not having the rest of the MD infrastructure in place on your pi.  I have it running but have some things to do before submitting.

Thanks again!  The testing you have done has been extremely helpful!
J.