Author Topic: 1004: The time has come.  (Read 27428 times)

OldBob

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: 1004: The time has come.
« Reply #195 on: October 29, 2012, 09:28:20 pm »
My recollection with earlier versions was that the "Software" section of the installer presented a screen populated with libdvdcss and W32, W64 options.   These sections are now blank.  Is this intentional or has my installation failed?

Likewise, the remote (control) "learning" screen is blank, my recollection was that it was populated with "up", "down", etc and that you could send the codes and it would save the file without having to go into the web admin.  This section also presents a blank two sections screen.

If it's not behaving as intended please let me know and I will submit a ticket with the hardware details.   My location is Australia.

Regards,

Bob

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2935
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: 1004: The time has come.
« Reply #196 on: October 29, 2012, 11:37:36 pm »
My recollection with earlier versions was that the "Software" section of the installer presented a screen populated with libdvdcss and W32, W64 options.   These sections are now blank.  Is this intentional or has my installation failed?

Intentional. We no longer provide extra software the way it used to be provided.

OldBob

  • Regular Poster
  • **
  • Posts: 16
    • View Profile
Re: 1004: The time has come.
« Reply #197 on: October 30, 2012, 03:03:45 am »
Thanks, understood.

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: 1004: The time has come.
« Reply #198 on: October 30, 2012, 06:36:54 pm »
If the learning part used to work and now doesn't, please submit a ticket with hw details. http://svn.linuxmce.org/trac.cgi/newticket

As much detail as you can muster... perhaps watch /var/log/pluto/DCERouter.log

I never quit... I just ping out.

tsoukas

  • Regular Poster
  • **
  • Posts: 18
    • View Profile
Re: 1004: The time has come.
« Reply #199 on: November 03, 2012, 11:44:18 am »
Dear all,

While I was hapily streaming radio stations for a while, in the last few snapshots wma playback seems broken.
Unfortunately, it is not confined to radio playback; any file encoded in windows codecs refuses to play.

This is the playback of a typical wma file:

Code: [Select]
========== NEW LOG SECTION ==========
1       11/03/12 12:27:01       23 (spawning-device)    Starting... 1
1       11/03/12 12:27:01       23 (spawning-device)    Found ./Xine_Player
05      11/03/12 12:27:01.765           Xine_Player::GetConfig default zoom 100 <0xb7770ab0>
05      11/03/12 12:27:01.791           Warning: libxine.so.1 is not loaded yet (?) <0xb7770ab0>
05      11/03/12 12:27:01.791           Custom xine functions status:  xine_seek=(nil), xine_start_trick_play=(nil), xine_stop_trick_play=(nil). Trickplay and seeking support: absent <0xb7770ab0>
05      11/03/12 12:27:02.050           Count of screens at this display: 1 <0xb7770ab0>
05      11/03/12 12:27:02.051           XMapWindow returned: 1 <0xb7770ab0>
05      11/03/12 12:27:08.593           Xine_Player::CMD_Play_Media() called for id 1001 filename: /home/public/data/audio/Software Raid 1 [39]/ALBUMS/U2/The Best Of 1990-2000 [UK]/01 Even Better Than The Real Thing.wma () <0xb6d6eb70>
05      11/03/12 12:27:08.593           Xine_Stream_Factory::GetStream streamID is 0 <0xb6d6eb70>
05      11/03/12 12:27:08.845           Created new stream with ID=1001 deint 0  100 0 <0xb6d6eb70>
05      11/03/12 12:27:08.845           Xine_Player::CMD_Play_Media() set stream 1001 as last rendering to screen. <0xb6d6eb70>
05      11/03/12 12:27:08.845           Xine_Player::CMD_Play_Media() called for id 1001 filename: /home/public/data/audio/Software Raid 1 [39]/ALBUMS/U2/The Best Of 1990-2000 [UK]/01 Even Better Than The Real Thing.wma () with corresponding stream 0x8b05d00. <0xb6d6eb70>
05      11/03/12 12:27:08.875           Opening media without chapters/title position: 'file:///home/public/data/audio/Software Raid 1 [39]/ALBUMS/U2/The Best Of 1990-2000 [UK]/01 Even Better Than The Real Thing.wma'  <0xb6d6eb70>
05      11/03/12 12:27:09.759           Visualizing plugin not enabled <0xb6d6eb70>
05      11/03/12 12:27:09.760           Xine_Stream::changePlaybackSpeed no running seekers found <0xb6d6eb70>
05      11/03/12 12:27:09.760           Xine engine set new zoom level to X:100, Y:100 <0xb6d6eb70>
05      11/03/12 12:27:09.761           Read media A/V information: [MS Windows Media Audio 2 (ffmpeg)]/[] => [pcm]/[] <0xb0d6db70>
05      11/03/12 12:27:09.761           Xine_Player::EVENT_Playback_Started(streamID=1001) <= AV info <0xb0d6db70>
05      11/03/12 12:27:09.761           Read media A/V information: [MS Windows Media Audio 2 (ffmpeg)]/[] => [pcm]/[] <0xb0d6db70>
05      11/03/12 12:27:09.761           Xine_Player::EVENT_Playback_Started(streamID=1001) <= AV info <0xb0d6db70>
05      11/03/12 12:27:09.763           Read media A/V information: [MS Windows Media Audio 2 (ffmpeg)]/[] => [pcm]/[] <0xb6d6eb70>
05      11/03/12 12:27:09.763           Xine_Player::EVENT_Playback_Started(streamID=1001) <0xb6d6eb70>
05      11/03/12 12:27:09.763           Xine_Player::CMD_Play_Media() ended for filename: /home/public/data/audio/Software Raid 1 [39]/ALBUMS/U2/The Best Of 1990-2000 [UK]/01 Even Better Than The Real Thing.wma with stream 0x8b05d00. <0xb6d6eb70>
05      11/03/12 12:27:10.676           [ID: 1001]  CHAPTER:0 POS:0 TITLE:0 SUBTITLE:-1 AUDIO:-1 TOTAL:222165 (seek 0) t.c. ctr 0 freq 1, <0x56a7b70>
05      11/03/12 12:27:11.677           [ID: 1001]  CHAPTER:0 POS:0 TITLE:0 SUBTITLE:-1 AUDIO:-1 TOTAL:222165 (seek 0) t.c. ctr 1 freq 1, <0x56a7b70>
Even though playback stops for the specific filename, it appearts as if streaming continues normally.

Before I dump my problem onto you, I tried researching it a little bit.

1. w32codecs is installed (along with libdvdcss2, but thats not important here..)
2. ffmpeg results in error (WARNING: library configuration mismatch), but pluto-ffmpeg works ok (so I installed that with a symlink so it loads it by default, along with ffplay, ffserver,ffprobe)

Cant seem to pinpoint the problem though... Any clues?
Thanks for your help,
ted


l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: 1004: The time has come.
« Reply #200 on: November 04, 2012, 12:28:38 am »
Yeah... I broke the heck out of audio.

Try upgrading to the current set of things.
I never quit... I just ping out.

tsoukas

  • Regular Poster
  • **
  • Posts: 18
    • View Profile
Re: 1004: The time has come.
« Reply #201 on: November 04, 2012, 12:36:16 am »
No problem, all of us are in it for the trip and not the destination.
How do I upgrade ? Through apt-get update/upgrade or is there any other way?

Thanks,
ted

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: 1004: The time has come.
« Reply #202 on: November 04, 2012, 12:50:39 am »
That is the best way for this one.
I never quit... I just ping out.

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: 1004: The time has come.
« Reply #203 on: November 05, 2012, 12:34:30 am »
Don't know if this belongs here or not, but my AMD motherboard (ECS IC780M-A) (no onboard video, but it has onboard audio) paired with a nVidia video card (EVGA 512-P3-1213-LR GeForce 210) did not have audio while l3mce was working on the video/audio.  It had previously been working... after a GlobalUpgrades today I reran through the AVWizard, was presented with both audio cards.  Selected the right card and now have working HDMI audio with DTS and Dolby Digital- the later two had never been used.

TLDR: video/audio work great- thank you.

Dap-P

  • Veteran
  • ***
  • Posts: 85
    • View Profile
Re: 1004: The time has come.
« Reply #204 on: November 05, 2012, 03:56:33 am »
I dont know if this belongs here,

But after connecting my Synology NAS in my LinuxMCE network, it got detected. I have set the share's up as Public content, and use LMCE direcory structure. I moved my videos and audio into the LMCE dir structure. All things looked good. But video's do not get indexed. I can search for video's and they will play at my core, but not at any MD.

 For Audio, it doesn't work at all....

I've checked the directories, and there are only softlinks made in the /home/public/data/videos dir. Not in any other public directory

Also softlinks for videos are made on the MD's, but the NFS share doesn't get mounted.

Can anybody help me to shed some light onto this issue?

Anton



tschak909

  • LinuxMCE God
  • ****
  • Posts: 5495
  • DOES work for LinuxMCE.
    • View Profile
Re: 1004: The time has come.
« Reply #205 on: November 05, 2012, 05:09:47 am »
I would suggest after adding a storage device, to reboot.

-Thom

l3mce

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1081
    • View Profile
Re: 1004: The time has come.
« Reply #206 on: November 06, 2012, 12:40:21 am »
Please start a thread if this is something you would like to discuss or need help fixing.

I never quit... I just ping out.

Dap-P

  • Veteran
  • ***
  • Posts: 85
    • View Profile
Re: 1004: The time has come.
« Reply #207 on: November 06, 2012, 01:44:51 am »
Thanks guys,
I already fixed the issue of non index media. It had to do that my media was already indexed on another location.

If there is something i can do to help resolve the issue with the softlinks, let me know.

Regards,
Anton