Author Topic: Diskless_CreateTBZ.sh has dependency problems  (Read 928 times)

seagullarity

  • Regular Poster
  • **
  • Posts: 18
    • View Profile
Diskless_CreateTBZ.sh has dependency problems
« on: May 27, 2011, 03:46:29 am »
I'm getting the following error when I run /usr/pluto/bin/Diskless_CreateTBZ.sh. I have run apt-get update/upgrade on both the CORE and the MD. According to dpkg -l, all of the dependencies listed below are met on both CORE and MD. It says to file a bug report, and I willl. Any other ideas? I've looked at the forums but none of the suggested fixes apply -- my sources.list doesn't really have anything wrong with it.

Thanks,
seagullarity

 
Code: [Select]
   1.
      #### Package pluto-orbiter failed (/tmp/tmp.JyAFY27358) - We wait 10sec and try again - to stop retrying press Ctrl-C.
   2.
      Reading package lists... Done
   3.
      Building dependency tree
   4.
      Reading state information... Done
   5.
      Some packages could not be installed. This may mean that you have
   6.
      requested an impossible situation or if you are using the unstable
   7.
      distribution that some required packages have not yet been created
   8.
      or been moved out of Incoming.
   9.
       
  10.
      Since you only requested a single operation it is extremely likely that
  11.
      the package is simply not installable and a bug report against
  12.
      that package should be filed.
  13.
      The following information may help to resolve the situation:
  14.
       
  15.
      The following packages have unmet dependencies:
  16.
        pluto-orbiter: Depends: pluto-avwizard (>= 2.0.0.44) but it is not going to be installed
  17.
                       Depends: pluto-avwizard (< 2.0.0.45) but it is not going to be installed
  18.
                       PreDepends: xine-ui but it is not going to be installed
  19.
      E: Broken packages

posde

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 3062
  • Wastes Life On LinuxMCE Since 2007
    • View Profile
    • My Home
Re: Diskless_CreateTBZ.sh has dependency problems
« Reply #1 on: May 27, 2011, 08:15:27 am »
Next time, chroot into the /tmp dir that is written on top, and type
apt-get install pluto-orbiter
(or whatever the package is) followed by apt-get install of any package that the first apt-get install command complained about.

seagullarity

  • Regular Poster
  • **
  • Posts: 18
    • View Profile
Re: Diskless_CreateTBZ.sh has dependency problems
« Reply #2 on: May 27, 2011, 10:32:11 pm »
I chrooted into the directory and ran apt-get install pluto-orbiter. It raised dependency issues that went like this:
pluto-orbiter needs pluto-avwizard
pluto-avwizard needs pluto-xine-player
pluto-xine-player needs libxine1
libxine1 needs libmagick10
libmagick10 needs libgraphviz4

Finally, libgraphviz4 allowed me to install it. Then I tried to go back up the chain, but libmagick10 raised the following dependency error:

libmagick10: Depends: libgraphviz4 (>= 2.20.0) but 2.18-1ubuntu2 is to be installed
E: broken packages

I tried apt-get install 2.18-1ubuntu2 but that failed (no such package).

I'm also getting the following errors when I run apt-get update:

Code: [Select]
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/intrepid/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.46 80]

W: Failed to fetch http://fastspeedtest.net/mirrors/ubuntu/dists/intrepid/Release  Unable to find expected entry  non-free/binary-i386/Packages in Meta-index file (malformed Release file?)

W: Failed to fetch http://fastspeedtest.net/mirrors/ubuntu/dists/pool/main/binary-i386/Packages.gz  404 Not Found

W: Failed to fetch http://fastspeedtest.net/mirrors/ubuntu/dists/replacements_debian/main/binary-i386/Packages.gz  404 Not Found

E: Some index files failed to download, they have been ignored, or old ones used instead.

Any other ideas ? Thanks so much posde for your help.