Author Topic: 1wire support  (Read 24555 times)

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: 1wire support
« Reply #180 on: February 04, 2012, 06:22:10 pm »
it depends on libowfs.. we should nag possy maybe there is something wrong with the package
rock your home - http://www.agocontrol.com home automation

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: 1wire support
« Reply #181 on: February 04, 2012, 06:27:21 pm »
try to run this from the command line: "apt-get update && apt-get install libowfs27"
rock your home - http://www.agocontrol.com home automation

Gangsingen

  • Veteran
  • ***
  • Posts: 54
    • View Profile
Re: 1wire support
« Reply #182 on: February 04, 2012, 09:03:37 pm »
The interface I´m using is a super cheap chineese variant of the 9097.

http://pcsensor.com/index.php?_a=viewProd&productId=33

In 8.10 it doesn´t work, and isn´t listed with lsusb. But in 10.04 though, it´s listed using lsusb, and once added manually in webadmin the sensors are detected automatically.

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: 1wire support
« Reply #183 on: February 04, 2012, 09:10:22 pm »
Gangsingen - thanks - having just bought a more expensive adapter I hope I don't have to buy another! Perhaps I'm having trouble because I'm using 0810. I'll try my test 1004 system when I can set it up.

Hari. No luck with the update and install. I'm appreciating your assistance and I'm sure this is going to work eventually.

Code: [Select]
js@dcerouter:~$ sudo apt-get update && apt-get install libowfs27
[sudo] password for js:                                        
Ign file: ./ Release.gpg                                        
Ign file: ./ Translation-en_US                                                                                
Ign file: ./ Release                                                                                          
Ign file: ./ Packages                                                                                          
Ign http://debian.slimdevices.com stable Release.gpg                                                          
Ign http://archive.ubuntu.com intrepid Release.gpg                                                            
Ign http://archive.ubuntu.com intrepid/main Translation-en_US                                                  
Ign http://archive.ubuntu.com intrepid/universe Translation-en_US                                              
Ign http://debian.slimdevices.com stable/main Translation-en_US                                                
Hit http://packages.medibuntu.org intrepid Release.gpg                                                        
Get:1 http://debian.slimdevices.com stable Release [1645B]                                                    
Hit http://old-releases.ubuntu.com intrepid Release.gpg                                                        
Ign http://old-releases.ubuntu.com intrepid/main Translation-en_US                                            
Ign http://old-releases.ubuntu.com intrepid/restricted Translation-en_US                                      
Ign http://archive.ubuntu.com intrepid/multiverse Translation-en_US                                            
Ign http://archive.ubuntu.com replacements_debian Release.gpg                                                  
Ign http://archive.ubuntu.com replacements_debian/main Translation-en_US                                      
Ign http://archive.ubuntu.com intrepid Release                                                                
Ign http://debian.slimdevices.com stable/main Packages                                                        
Ign http://old-releases.ubuntu.com intrepid/universe Translation-en_US                                        
Ign http://old-releases.ubuntu.com intrepid/multiverse Translation-en_US                                      
Hit http://old-releases.ubuntu.com intrepid-security Release.gpg                                              
Ign http://old-releases.ubuntu.com intrepid-security/main Translation-en_US                                    
Ign http://old-releases.ubuntu.com intrepid-security/restricted Translation-en_US                              
Ign http://old-releases.ubuntu.com intrepid-security/multiverse Translation-en_US                              
Ign http://old-releases.ubuntu.com intrepid-security/universe Translation-en_US                                
Hit http://old-releases.ubuntu.com intrepid-updates Release.gpg                                                
Ign http://archive.ubuntu.com replacements_debian Release                                                      
Hit http://debian.slimdevices.com stable/main Packages                                                        
Ign http://old-releases.ubuntu.com intrepid-updates/main Translation-en_US                                    
Ign http://old-releases.ubuntu.com intrepid-updates/restricted Translation-en_US                              
Ign http://old-releases.ubuntu.com intrepid-updates/multiverse Translation-en_US                              
Ign http://packages.medibuntu.org intrepid/free Translation-en_US                                              
Ign http://deb.linuxmce.org intrepid Release.gpg                                                              
Ign http://deb.linuxmce.org intrepid/beta2 Translation-en_US                                                  
Ign http://archive.ubuntu.com intrepid/main Packages                                                          
Ign http://archive.ubuntu.com intrepid/universe Packages                                                      
Ign http://archive.ubuntu.com intrepid/multiverse Packages                                                    
Ign http://deb.linuxmce.org 20dev_ubuntu Release.gpg                                                          
Ign http://old-releases.ubuntu.com intrepid-updates/universe Translation-en_US                                
Hit http://old-releases.ubuntu.com intrepid Release                                                            
Hit http://old-releases.ubuntu.com intrepid-security Release                                                  
Ign http://deb.linuxmce.org 20dev_ubuntu/main Translation-en_US                                                
Ign http://deb.linuxmce.org intrepid Release                                                                  
Ign http://archive.ubuntu.com replacements_debian/main Packages                                                
Hit http://old-releases.ubuntu.com intrepid-updates Release                                                    
Ign http://packages.medibuntu.org intrepid/non-free Translation-en_US                                          
Ign http://deb.linuxmce.org 20dev_ubuntu Release                                                              
Err http://archive.ubuntu.com intrepid/main Packages                                                          
  404 Not Found [IP: 91.189.88.31 80]                                                                          
Err http://archive.ubuntu.com intrepid/universe Packages                                                      
  404 Not Found [IP: 91.189.88.31 80]                                                                          
Hit http://old-releases.ubuntu.com intrepid/main Packages                                                      
Hit http://old-releases.ubuntu.com intrepid/restricted Packages                                                
Hit http://old-releases.ubuntu.com intrepid/universe Packages                                                  
Hit http://old-releases.ubuntu.com intrepid/multiverse Packages                                                
Hit http://old-releases.ubuntu.com intrepid/main Sources                                                      
Hit http://old-releases.ubuntu.com intrepid/restricted Sources                                                
Hit http://old-releases.ubuntu.com intrepid/multiverse Sources                                                
Hit http://old-releases.ubuntu.com intrepid/universe Sources                                                  
Err http://archive.ubuntu.com intrepid/multiverse Packages                                                    
  404 Not Found [IP: 91.189.88.31 80]                                                                          
Ign http://deb.linuxmce.org intrepid/beta2 Packages                                                            
Hit http://old-releases.ubuntu.com intrepid-security/main Packages                                            
Hit http://old-releases.ubuntu.com intrepid-security/restricted Packages                                      
Hit http://old-releases.ubuntu.com intrepid-security/multiverse Packages                                      
Hit http://old-releases.ubuntu.com intrepid-security/universe Packages                                        
Hit http://old-releases.ubuntu.com intrepid-security/main Sources                                              
Hit http://old-releases.ubuntu.com intrepid-security/restricted Sources                                        
Hit http://old-releases.ubuntu.com intrepid-security/multiverse Sources                                        
Hit http://old-releases.ubuntu.com intrepid-security/universe Sources                                          
Hit http://old-releases.ubuntu.com intrepid-updates/main Packages                                              
Err http://archive.ubuntu.com replacements_debian/main Packages                                                
  404 Not Found [IP: 91.189.88.31 80]                                                                          
Ign http://deb.linuxmce.org 20dev_ubuntu/main Packages                                                        
Hit http://packages.medibuntu.org intrepid Release                                                            
Hit http://old-releases.ubuntu.com intrepid-updates/restricted Packages                                        
Hit http://old-releases.ubuntu.com intrepid-updates/multiverse Packages                                        
Hit http://deb.linuxmce.org intrepid/beta2 Packages                                                            
Hit http://old-releases.ubuntu.com intrepid-updates/universe Packages                                          
Hit http://old-releases.ubuntu.com intrepid-updates/main Sources                                              
Hit http://old-releases.ubuntu.com intrepid-updates/restricted Sources                                        
Hit http://old-releases.ubuntu.com intrepid-updates/multiverse Sources                                        
Hit http://old-releases.ubuntu.com intrepid-updates/universe Sources                                          
Hit http://deb.linuxmce.org 20dev_ubuntu/main Packages                                                        
Hit http://packages.medibuntu.org intrepid/free Packages                                                      
Hit http://packages.medibuntu.org intrepid/non-free Packages                                                  
Fetched 1B in 2s (0B/s)                                                                                        
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/intrepid/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]                                                                                            

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/intrepid/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]                                                                                        

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/intrepid/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.88.31 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/replacements_debian/main/binary-i386/Packages.gz  404Not Found [IP: 91.189.88.31 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.
js@dcerouter:~$

« Last Edit: February 04, 2012, 09:12:02 pm by twodogs »
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 1wire support
« Reply #184 on: February 06, 2012, 06:03:06 am »
I can report that mine is now working.

I did deleted the device and then re-added it.  I had other issues I was trying to solve so a couple of reboots happened over the next 24hrs but now the temp sensor is showing the temp

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: 1wire support
« Reply #185 on: February 07, 2012, 05:07:42 am »
I deleted and re-added this morning. Nothin. Not sure that libowfs ever loaded. Any idea where it should be?
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: 1wire support
« Reply #186 on: February 07, 2012, 07:03:37 am »
Maybe try and add another device in the webadmin.
Like a CM15A or something. Mine and Techstyle's started working while adding or fixing something else........

hari

  • Administrator
  • LinuxMCE God
  • *****
  • Posts: 2421
    • View Profile
    • ago control
Re: 1wire support
« Reply #187 on: February 07, 2012, 06:26:14 pm »
Thanks DragonK - that's good to know. The temp sensor has been in all night and has not appeared as a child yet. Hari, I'll be patient but why does it take so long?
it does not take long, the child is created as soon as it is detected on the 1wire bus. That happens within seconds.
rock your home - http://www.agocontrol.com home automation

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: 1wire support
« Reply #188 on: February 07, 2012, 08:50:06 pm »
Is there a way to check the existence of libowfs and force it to load?
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

mkbrown69

  • Guru
  • ****
  • Posts: 192
    • View Profile
Re: 1wire support
« Reply #189 on: February 07, 2012, 10:33:12 pm »
TwoDogs,

To check for it from command-line, on the core issue

dpkg --get-selections | grep libowfs

If you get nothing from that, issue

sudo apt-get install libowfs27

HTH!

/Mike

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: 1wire support
« Reply #190 on: February 08, 2012, 06:59:53 am »
it does not take long, the child is created as soon as it is detected on the 1wire bus. That happens within seconds.

Hari,

it was a mission to get the first sensor up and running.
1. I added the Interface in Webadmin.
2. Waited. Reloaded and rebooted.
3. Even left the core for 24hours reloaded and rebooted. Still no sensor.

So I left it and added an MD to my system. Relaoded the router when asked, and then I noticed the temp sensor was added.
The second and third sensors were detected and added allmost immediately though.

Karel

Techstyle

  • Addicted
  • *
  • Posts: 674
    • View Profile
    • Techstyle UK Ltd.
Re: 1wire support
« Reply #191 on: February 08, 2012, 06:20:14 pm »
DragonK,

you are right it seems to be a mission to get the sensor loaded but I noticed (and other have too) that some of the software did fail to load/install the first time around.  On the reboot after adding my HDD back in I noticed the libowfs package downloading and installing, only after this point did I see a child added and the device listed as 'registered: yes'

I had previously run "apt-get update && apt-get install libowfs27" per Hari's instructions but to no avail.  I was getting errors associated with radvd after running the command that hari suggested.  I did the fix (removed the 'blank line 2') and run apt-get update and apt-get upgrade.  I don't think I ran apt-get install libowfs27 again though.

twodogs,
if you run apt-get update do you get an radvd.conf error?

DragonK,
have you added a second sensor? how quick is that found?

I am thinking about starting a new thread to get some discussion going on 1-wire deployment - for instance I am thinking of running the 1-wire network within a Cat5e cable along with my POTS and would like to know how others are doing it

huh

  • Guru
  • ****
  • Posts: 235
    • View Profile
Re: 1wire support
« Reply #192 on: February 08, 2012, 07:07:43 pm »
I have mine (1wire usb and temp sensors) scheduled for delivery today from ibuttonlink that twodogs linked above.  I'm running 1004 with all but the updates released today.  I was going to apt-get update && apt-get upgrade before plugging in the device to see if I have the same experiences. 

I ran this command last night:
Code: [Select]
dpkg --get-selections | grep libowfs
And as expected do not have libowfs installed as I currently dont' have any 1wire devices.

Is there anything else someone would like me to try before I plug in the device?  Or any log files to tail to watch for errors?

twodogs

  • Guru
  • ****
  • Posts: 224
    • View Profile
Re: 1wire support
« Reply #193 on: February 08, 2012, 07:39:57 pm »
Looks like the packages are installed. I've tried to delete and re-add 1-wire, but womb is still barren - no children at all. The update gave me some errors that don't look like they concern 1-wire, but then again who knows? My 1-wire adapter is still showing unregistered after several hours. It had registered before, but I don't know how long it took.

Code: [Select]
js@dcerouter:~$ dpkg --get-selections | grep libowfs
libowfs27                                       install
js@dcerouter:~$ dpkg --get-selections | grep fuseowfs
fuseowfs                                        install
js@dcerouter:~$ sudo apt-get update                    
blah...
blah...
W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/intrepid/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.92.171 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/intrepid/universe/binary-i386/Packages.gz  404 Not Found [IP: 91.189.92.171 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/intrepid/multiverse/binary-i386/Packages.gz  404 Not Found [IP: 91.189.92.171 80]

W: Failed to fetch http://archive.ubuntu.com/ubuntu/dists/replacements_debian/main/binary-i386/Packages.gz  404 Not Found [IP: 91.189.92.171 80]

E: Some index files failed to download, they have been ignored, or old ones used instead.
js@dcerouter:~$
« Last Edit: February 08, 2012, 08:49:52 pm by twodogs »
http://greenrenovation.wordpress.com/home-automation/
system:
ASUS P5N7A-VM
integrated GeForce 9300
E5200 processor
Fusion 5 lite HDTV card
2G RAM
SYBA SY-PCI15001 6-port serial card
Denon AVR 3805
LG 42" Plasma
Gyration GYR3101
Cisco SPA3102 analog telephone adapter
Cisco 7971G IP phone/orbiter

DragonK

  • Guru
  • ****
  • Posts: 429
    • View Profile
Re: 1wire support
« Reply #194 on: February 09, 2012, 06:51:21 am »
DragonK,
have you added a second sensor? how quick is that found?

I have 3 sensors and the second and third showed up as childs within a minute or two.