Author Topic: How to resend mobile orbiter to phone ?  (Read 5680 times)

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
How to resend mobile orbiter to phone ?
« on: March 27, 2005, 11:11:08 am »
Hi,

I was deleting stuff on mobile phone and mistakenly deleted mobile orbiter. How can I resend it to phone ?

Regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
How to resend mobile orbiter to phone ?
« Reply #1 on: March 27, 2005, 11:31:03 am »
Go to Advanced, Devices.  Find the mobile phone, and check the box "Reconfigure Device" (save changes).

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
How to resend mobile orbiter to phone ?
« Reply #2 on: March 27, 2005, 11:43:21 am »
Quote from: "aaron.b"
Go to Advanced, Devices.  Find the mobile phone, and check the box "Reconfigure Device" (save changes).

Hi,

I already did that, but no change :
Code: newbielink:javascript:void(0); [nonactive]
# inquiry result: 1
10 03/27/05 11:46:20.530 Device 00:60:57:85:B7:1D responded.
10 03/27/05 11:46:20.530 Analyzing device 00:60:57:85:B7:1D. Existing (nil), connected 0
10 03/27/05 11:46:20.530 Bluetooth dongle intercepted new device.  We're not connected.  Proceeding like normal.
10 03/27/05 11:46:20.530 Adding device to map1: N/A m_mapPhoneDevice_Detected size is now: 1
05 03/27/05 11:46:20.530 Detected device mac: 00:60:57:85:B7:1D link quality: 0
10 03/27/05 11:46:20.531 Receive string: MESSAGE 91            
Command #60 - Link with mobile orbiter
Parm #42 - MediaPosition=1
Parm #47 - Mac_address=00:60:57:85:B7:1D
btcp const: 0x81646b8

end of btcp const: 0x81646b8

start of constructor 0x81646b8
10 03/27/05 11:46:20.532 start of const 00:60:57:85:B7:1D
@mac address: 00:60:57:85:B7:1D
# try to connect
# in poll
# got: 4
05 03/27/05 11:46:20.545 Inquiry complete

10 03/27/05 11:46:20.545 loop 4 m_mapPhoneDevice_Detected size: 1
# closed device
10 03/27/05 11:46:20.545 loop 5 m_mapPhoneDevice_Detected size: 1
10 03/27/05 11:46:20.545 Devices detected last loop: 1
10 03/27/05 11:46:20.545 Devices detected this loop: 1
10 03/27/05 11:46:20.545 loop 1 m_mapPhoneDevice_Detected size: 1
10 03/27/05 11:46:20.545 Start of scan loop
10 03/27/05 11:46:20.545 Attached to BT adapter: hci0 00:10:60:A2:E4:3C

# ready to send command
05 03/27/05 11:46:20.545 Inquiry started
# in poll
# got: 7
# got a status
# in poll
# got: 7
# got a status
10 03/27/05 11:46:20.570 loop 4 m_mapPhoneDevice_Detected size: 1
# closed device
05 03/27/05 11:46:20.570 Error in bluetooth scan: 16

05 03/27/05 11:46:21.960 Can't connect RFCOMM socket 00:60:57:85:B7:1D. (The symbian app is not started or it's dead)
# error code: -1
10 03/27/05 11:46:35.571 Devices detected last loop: 1
10 03/27/05 11:46:35.571 Devices detected this loop: 0
10 03/27/05 11:46:35.571 Deleting lost device from map: N/A size: 1
05 03/27/05 11:46:35.571 Lost connection to device: mac 00:60:57:85:B7:1D, id N/A
10 03/27/05 11:46:35.571 Bluetooth dongle intercepted lost device.  We're not connected.  Proceeding like normal
10 03/27/05 11:46:35.571 lost dev 1 m_mapPhoneDevice_Detected size: 0
10 03/27/05 11:46:35.572 lost dev 2 m_mapPhoneDevice_Detected size: 0
10 03/27/05 11:46:35.572 loop 1 m_mapPhoneDevice_Detected size: 0
10 03/27/05 11:46:35.572 Start of scan loop
10 03/27/05 11:46:35.572 Attached to BT adapter: hci0 00:10:60:A2:E4:3C

# ready to send command
05 03/27/05 11:46:35.572 Inquiry started
# in poll
# got: 7
# got a status
# in poll
# got: 18
# inquiry result: 1
10 03/27/05 11:46:38.789 Device 00:60:57:85:B7:1D responded.
10 03/27/05 11:46:38.789 Analyzing device 00:60:57:85:B7:1D. Existing (nil), connected 0
10 03/27/05 11:46:38.789 Bluetooth dongle intercepted new device.  We're not connected.  Proceeding like normal.
10 03/27/05 11:46:38.789 Adding device to map1: N/A m_mapPhoneDevice_Detected size is now: 1
05 03/27/05 11:46:38.789 Detected device mac: 00:60:57:85:B7:1D link quality: 0
10 03/27/05 11:46:38.790 Receive string: MESSAGE 91            
Command #60 - Link with mobile orbiter
Parm #42 - MediaPosition=1
Parm #47 - Mac_address=00:60:57:85:B7:1D
btcp const: 0x81646b8

end of btcp const: 0x81646b8



Should I reboot ?

Regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
How to resend mobile orbiter to phone ?
« Reply #3 on: March 27, 2005, 12:04:56 pm »
I checked the code.  We check the "Reconfigure Device" flag after the bluetooth dongle links to the phone--which can only happen when it connects to the software.  So, checking Reconfigure Device will cause it to re-send the app to the phone, but only if there's already another version running on the phone.  I fixed the logic, so in the .14 build, it will also check the flag upon detection of the phone in cases like yours where there is no version on the phone.

So, to manually force it to install...  Login to the box that has the bluetooth dongle and run this command:

/usr/pluto/bin/PhoneInstall.sh [mac address] /usr/pluto/bin/Pluto_S60.sis

where mac address is the mac of the phone.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
How to resend mobile orbiter to phone ?
« Reply #4 on: April 07, 2005, 09:23:39 am »
Quote from: "aaron.b"
I checked the code.  We check the "Reconfigure Device" flag after the bluetooth dongle links to the phone--which can only happen when it connects to the software.  So, checking Reconfigure Device will cause it to re-send the app to the phone, but only if there's already another version running on the phone.  I fixed the logic, so in the .14 build, it will also check the flag upon detection of the phone in cases like yours where there is no version on the phone.

So, to manually force it to install...  Login to the box that has the bluetooth dongle and run this command:

/usr/pluto/bin/PhoneInstall.sh [mac address] /usr/pluto/bin/Pluto_S60.sis

where mac address is the mac of the phone.

Hi,

I've waited for version 0.14, but nothing happend automatically (I didn't have reconfigure checked - was this cause?). So I installed it manually with above command.

But now, GUI on phone is garbled, many copies mixed one on another only on upper half of the screen ?

Do you see the same ?

I will regenerate all Orbiters and will see if that helps...

Regards,

Rob.

archived

  • Hello, I'm new here
  • Posts: 0
    • View Profile
PlutoMO issue
« Reply #5 on: April 07, 2005, 12:24:50 pm »
Hi Rob,

Quote
But now, GUI on phone is garbled, many copies mixed one on another only on upper half of the screen ?

Do you see the same ?

I will regenerate all Orbiters and will see if that helps...


There is a devicedata for orbiter devices: UseOCG (boolean) to generate OCG graphic files instead of PNGs. By default, mobile phone device has this flag set to false (PlutoMO doesn't know how to handle OCG files). Please check if this flag is set.

Regards,
Chris. M