Author Topic: Mythtv database has newer tv schema (1254) then expected (1244)  (Read 1926 times)

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
"Mythtv database has newer tv schema (1254) then expected (1244)"

Running mythtv 0.23 on the core. Had to dist-upgrade to complete the upgrade. Now getting this message on the md. Are there still problems with this version of mythtv on the mds? Do I need to rerun /usr/pluto/bin/Diskless_CreateTBZ.sh and rebuild?
Any ideas?
Barney

sambuca

  • Guru
  • ****
  • Posts: 447
    • View Profile
Re: Mythtv database has newer tv schema (1254) then expected (1244)
« Reply #1 on: June 03, 2010, 01:18:49 pm »
Did you also run an upgrade on the MD?
As myth on the MD also accesses the same database, it needs to be the same version.

sambuca

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Mythtv database has newer tv schema (1254) then expected (1244)
« Reply #2 on: June 04, 2010, 01:40:28 am »
Sambuca:
Figured it our. Had to modify the preferences file and do apt-get dist-upgrade on the md.

Now got this db error which I've seen on another thread (no solution yet):
Failed to execute SQL: GRANT ALL PRIVILEGES ON mythconverg.* TO mythtv@localhost IDENTIFIED BY 'xxxxxxxx' Access denied for user 'root'@'192.168.80.2' to database 'mythconverg' at -e line 8

Thanks for the info.
Barney

tkmedia

  • wants to work for LinuxMCE
  • **
  • Posts: 937
    • View Profile
    • LMCECompatible
Re: Mythtv database has newer tv schema (1254) then expected (1244)
« Reply #3 on: June 04, 2010, 07:57:38 am »
rem lines 47 and 49 of  /var/lib/dpkg/info/mythtv-database.postinst
 and do a dpkg-reconfigure mythtv-database. reinstall mythv-database  or apt-get -f install if need be.




HTH

Tim
My Setup http://wiki.linuxmce.org/index.php/User:Tkmedia

For LinuxMce compatible  systems and accessories
http://lmcecompatible.com/

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Mythtv database has newer tv schema (1254) then expected (1244)
« Reply #4 on: June 04, 2010, 07:24:07 pm »
Thanks Tim,

Think I've messed up my md with a bad preferences file.

Doing a /usr/pluto/bin/Diskless_CreateTBZ.sh then will rebuild my md and see what happens.
Barney