Author Topic: Motion blur (especially when watching TV)  (Read 1327 times)

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1374
  • If it ain't broke, tweak it
    • View Profile
Motion blur (especially when watching TV)
« on: April 16, 2010, 01:29:27 pm »
I'm running a 42" LCD TV (1080 resolution) with an nVidia ion board as the MD. I've set it to "vdpau" in web admin - apart from that I haven't changed anything else, everything else is running as default.

I just wondered if there were any settings I could be playing with from the point of view of reducing motion blur when watching TV? (Using 2 off KWorld 599 tuners) I see a little bit of motion blur on ripped HD movies (hardly noticeable), but it's defintely quite bad when watching TV.

At first I suspected the TV, but having tried it with a standard SD digibox, I can confirm that it is fine.

Any help would be much appreciated.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #1 on: April 18, 2010, 12:46:47 am »
Hi Purps,
I remember setting up mythtv frontend on my acer revo (nvidia ion) and making sure vdpau is selected there.
Hope this helps.
Barney

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1374
  • If it ain't broke, tweak it
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #2 on: April 19, 2010, 10:42:42 am »
Hi Purps,
I remember setting up mythtv frontend on my acer revo (nvidia ion) and making sure vdpau is selected there.
Hope this helps.
Barney

Thanks for the reply.

I did see that option, but myth seems to crash when I use it (only the vdpau ones, there are 3 right?). The other options (CPU++, slim, etc) all work, but give me the motion blur. I can't remember the error message exactly, think it was "Video frame buffer failed too many times", but can't be sure. I'll check it out and report back.

Thanks again for the suggestion.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

maverick0815

  • Addicted
  • *
  • Posts: 539
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #3 on: April 19, 2010, 01:44:29 pm »
I have a asrock ion330 running vpdau-slim in mythtv without much of a problem...I didn't see any motion blur....
by the way, what ui are you using? try ui2 with overlay instead of alphablending.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1374
  • If it ain't broke, tweak it
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #4 on: April 20, 2010, 05:22:24 pm »
I've tried enabling the vdpau option in myth frontend, and now I remember..... orbiter takes a VERY long time to respond if you try to change channel/volume etc with this option in place, up to a minute, and leaves a black imprint of the orbiter on the screen for that time.

I'll have a go with vdpau-slim later, see how it goes. I am using UI2 with overlay.

I did see some deinterlace quality settings in webadmin for individual MDs, maybe I'll have a fiddle with that and see if it makes any difference.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #5 on: April 20, 2010, 05:36:30 pm »
Hi purps,
i did try vdpau-slim and had freezing (more than 1 minute)  problems when trying the OSD. I´m also using UI2 overlay.
Under kde, mythfrontend with vdpau, vdpau-slim, works fine with not freezes.
The way i solved it was using the "normal" profile.

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1374
  • If it ain't broke, tweak it
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #6 on: April 21, 2010, 10:34:12 am »
That's exactly the problem I am having.

Will also have a go with the "normal" profile. I still need to try playing with deinterlace settings as well.

How do you get myth frontend going under KDE? And why would it work under KDE but not in the normal fashion?
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps

pw44

  • Addicted
  • *
  • Posts: 653
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #7 on: April 21, 2010, 04:00:04 pm »
I think that webadmin -> media director -> hardware acceleration vdpau does not affect the profile myth uses.
I do have the md hw accelaration set to vdpau, and with myth "normal" profile it works well (core/hybrid and md), but setting myth profile to vdpau, it works well on the core/hybrid, but hangs on the md, so i've set the myth profile to "normal" on both (core/hybrid and md).  I didn't change the deinterlace settings for the normal profile.
on the md deinterlace quality (webadmin -> media director) i've set it to highest.
Under KDE (in any, core/hybrid or md's), open the console window and call mythfrontend.
I guess (just guess) that the problem might be the linuxmce wrap, but maybe one of the developers can give a better answer.
« Last Edit: April 21, 2010, 04:08:33 pm by pw44 »

b4rney

  • Guru
  • ****
  • Posts: 454
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #8 on: May 18, 2010, 10:20:24 pm »
@pw44
I've fixed some locking up problems in another thread:
http://forum.linuxmce.org/index.php?topic=10101.msg69320#msg69320

Maybe your solution is the same?

@purps
Has your motion blur improved?

purps

  • NEEDS to work for LinuxMCE
  • ***
  • Posts: 1374
  • If it ain't broke, tweak it
    • View Profile
Re: Motion blur (especially when watching TV)
« Reply #9 on: May 18, 2010, 10:49:55 pm »
I think so, am starting to think it might be my eyes! :) Going to experiment with the settings a bit more, will let you know.
1004 RC :: looking good :: upgraded 01/04/2013
my setup :: http://wiki.linuxmce.org/index.php/User:Purps